aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--archivers/php-lz4/Makefile1
-rw-r--r--chinese/php-opencc/Makefile1
-rw-r--r--databases/pecl-cassandra/Makefile2
-rw-r--r--databases/pecl-couchbase/Makefile1
-rw-r--r--devel/ioncube/Makefile1
-rw-r--r--devel/pecl-APCu_bc/Makefile2
-rw-r--r--devel/pecl-eio/Makefile1
-rw-r--r--devel/pecl-hrtime/Makefile1
-rw-r--r--devel/pecl-jsmin/Makefile1
-rw-r--r--devel/pecl-jsond/Makefile1
-rw-r--r--devel/pecl-propro2/Makefile1
-rw-r--r--devel/pecl-sync/Makefile1
-rw-r--r--devel/pecl-vld/Makefile1
-rw-r--r--devel/php-ice37/Makefile1
-rw-r--r--ftp/php-fastdfs/Makefile1
-rw-r--r--net/pear-Auth_RADIUS/Makefile1
-rw-r--r--net/pecl-amqp/Makefile2
-rw-r--r--net/pecl-mosquitto/Makefile1
-rw-r--r--net/pecl-radius/Makefile1
-rw-r--r--security/pecl-crypto/Makefile1
-rw-r--r--security/pecl-pam/Makefile1
-rw-r--r--textproc/php-mecab/Makefile2
-rw-r--r--www/moodle310/Makefile1
-rw-r--r--www/moodle35/Makefile1
-rw-r--r--www/moodle38/Makefile1
-rw-r--r--www/moodle39/Makefile1
-rw-r--r--www/pecl-http/Makefile1
-rw-r--r--www/pecl-yar/Makefile1
28 files changed, 28 insertions, 4 deletions
diff --git a/archivers/php-lz4/Makefile b/archivers/php-lz4/Makefile
index c003a706dd11..4d411bdad1eb 100644
--- a/archivers/php-lz4/Makefile
+++ b/archivers/php-lz4/Makefile
@@ -14,6 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= liblz4.so:archivers/liblz4
USES= php:ext
+IGNORE_WITH_PHP= 80
USE_GITHUB= yes
GH_ACCOUNT= kjdev
diff --git a/chinese/php-opencc/Makefile b/chinese/php-opencc/Makefile
index 170c71320dc5..d56b3badbcb2 100644
--- a/chinese/php-opencc/Makefile
+++ b/chinese/php-opencc/Makefile
@@ -19,5 +19,6 @@ GH_PROJECT= opencc4php
GH_TAGNAME= 8007639
USES= php:ext
+IGNORE_WITH_PHP= 80
.include <bsd.port.mk>
diff --git a/databases/pecl-cassandra/Makefile b/databases/pecl-cassandra/Makefile
index 7fff232f7aa2..e5efdc07243e 100644
--- a/databases/pecl-cassandra/Makefile
+++ b/databases/pecl-cassandra/Makefile
@@ -15,6 +15,6 @@ LIB_DEPENDS= libuv.so:devel/libuv \
libgmp.so:math/gmp
USES= php:pecl localbase
-IGNORE_WITH_PHP= 74
+IGNORE_WITH_PHP= 74 80
.include <bsd.port.mk>
diff --git a/databases/pecl-couchbase/Makefile b/databases/pecl-couchbase/Makefile
index 595965dd0a96..bea51046ed58 100644
--- a/databases/pecl-couchbase/Makefile
+++ b/databases/pecl-couchbase/Makefile
@@ -16,5 +16,6 @@ LIB_DEPENDS= libcouchbase.so:databases/libcouchbase
USES= php:pecl
USE_PHP= json:build
+IGNORE_WITH_PHP= 80
.include <bsd.port.mk>
diff --git a/devel/ioncube/Makefile b/devel/ioncube/Makefile
index 827c6704839c..be2ae8104f0d 100644
--- a/devel/ioncube/Makefile
+++ b/devel/ioncube/Makefile
@@ -23,6 +23,7 @@ IGNORE_DragonFly= is unsupported on DragonFly
ONLY_FOR_ARCHS= amd64 i386
NO_BUILD= yes
USES= php:flavors
+IGNORE_WITH_PHP= 80
SUB_FILES= pkg-message
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/devel/pecl-APCu_bc/Makefile b/devel/pecl-APCu_bc/Makefile
index b032cd8769c8..b1d13bb539e7 100644
--- a/devel/pecl-APCu_bc/Makefile
+++ b/devel/pecl-APCu_bc/Makefile
@@ -15,7 +15,7 @@ BUILD_DEPENDS= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/apcu.so:devel/pecl-APCu@${PHP_F
USES= localbase php:pecl
-IGNORE_WITH_PHP= 55 56
+IGNORE_WITH_PHP= 80
PHP_MODNAME= apc
PHP_MOD_PRIO=30
diff --git a/devel/pecl-eio/Makefile b/devel/pecl-eio/Makefile
index 9d9a814fb5d0..89aca8853e0e 100644
--- a/devel/pecl-eio/Makefile
+++ b/devel/pecl-eio/Makefile
@@ -11,6 +11,7 @@ COMMENT= Provides interface to the libeio library
LICENSE= PHP301
USES= php:pecl
+IGNORE_WITH_PHP= 80
CONFIGURE_ARGS= --enable-eio
diff --git a/devel/pecl-hrtime/Makefile b/devel/pecl-hrtime/Makefile
index 2699dbd98cb0..12604df6ef64 100644
--- a/devel/pecl-hrtime/Makefile
+++ b/devel/pecl-hrtime/Makefile
@@ -11,5 +11,6 @@ COMMENT= High resolution timing for PHP
LICENSE= BSD2CLAUSE
USES= php:pecl
+IGNORE_WITH_PHP= 80
.include <bsd.port.mk>
diff --git a/devel/pecl-jsmin/Makefile b/devel/pecl-jsmin/Makefile
index 8e82cafa3425..80f535d0a80a 100644
--- a/devel/pecl-jsmin/Makefile
+++ b/devel/pecl-jsmin/Makefile
@@ -11,5 +11,6 @@ COMMENT= PHP extension for minifying JavaScript
LICENSE= PHP301
USES= php:pecl
+IGNORE_WITH_PHP= 80
.include <bsd.port.mk>
diff --git a/devel/pecl-jsond/Makefile b/devel/pecl-jsond/Makefile
index c49c9632e240..2d213e097018 100644
--- a/devel/pecl-jsond/Makefile
+++ b/devel/pecl-jsond/Makefile
@@ -11,5 +11,6 @@ COMMENT= JavaScript Object Notation in PHP
LICENSE= PHP301
USES= php:pecl
+IGNORE_WITH_PHP= 80
.include <bsd.port.mk>
diff --git a/devel/pecl-propro2/Makefile b/devel/pecl-propro2/Makefile
index 48c78171f22e..170904b1b283 100644
--- a/devel/pecl-propro2/Makefile
+++ b/devel/pecl-propro2/Makefile
@@ -14,6 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
PORTSCOUT= limit:^2.*
USES= gmake php:pecl
+IGNORE_WITH_PHP= 80
CONFLICTS= pecl-propro-1*
.include <bsd.port.mk>
diff --git a/devel/pecl-sync/Makefile b/devel/pecl-sync/Makefile
index 18e4d3654de3..acbfd535e580 100644
--- a/devel/pecl-sync/Makefile
+++ b/devel/pecl-sync/Makefile
@@ -12,5 +12,6 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= php:pecl
+IGNORE_WITH_PHP= 80
.include <bsd.port.mk>
diff --git a/devel/pecl-vld/Makefile b/devel/pecl-vld/Makefile
index ead02801ea78..f8f18c2edcfe 100644
--- a/devel/pecl-vld/Makefile
+++ b/devel/pecl-vld/Makefile
@@ -12,6 +12,7 @@ LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= php:pecl
+IGNORE_WITH_PHP= 80
CONFIGURE_ARGS= --enable-vld
diff --git a/devel/php-ice37/Makefile b/devel/php-ice37/Makefile
index c61e460bab32..2e2f5dbac7f9 100644
--- a/devel/php-ice37/Makefile
+++ b/devel/php-ice37/Makefile
@@ -23,6 +23,7 @@ PLIST= ${.CURDIR}/pkg-plist
MAKE_ARGS+= PHP_EXT_DIR=${PHP_EXT_DIR} ICE_HOME=${LOCALBASE} \
PHP_HOME=${LOCALBASE} OPTIMIZE=yes
USES+= php:build,flavors
+IGNORE_WITH_PHP= 80
BUILD_WRKSRC= ${WRKSRC}/php
INSTALL_WRKSRC= ${WRKSRC}/php
diff --git a/ftp/php-fastdfs/Makefile b/ftp/php-fastdfs/Makefile
index 01f3337cc1a9..ee5dba8d668e 100644
--- a/ftp/php-fastdfs/Makefile
+++ b/ftp/php-fastdfs/Makefile
@@ -14,6 +14,7 @@ LIB_DEPENDS= libfastcommon.so:devel/libfastcommon \
libfdfsclient.so:ftp/fastdfs
USES= php:ext
+IGNORE_WITH_PHP= 80
USE_GITHUB= yes
GH_ACCOUNT= happyfish100
diff --git a/net/pear-Auth_RADIUS/Makefile b/net/pear-Auth_RADIUS/Makefile
index 015db6231125..668cd713f690 100644
--- a/net/pear-Auth_RADIUS/Makefile
+++ b/net/pear-Auth_RADIUS/Makefile
@@ -12,5 +12,6 @@ LICENSE= BSD3CLAUSE
USE_PHP= radius
USES= pear php:flavors
+IGNORE_WITH_PHP= 80
.include <bsd.port.mk>
diff --git a/net/pecl-amqp/Makefile b/net/pecl-amqp/Makefile
index a9f0ff6a3539..aba68ef51045 100644
--- a/net/pecl-amqp/Makefile
+++ b/net/pecl-amqp/Makefile
@@ -14,6 +14,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= librabbitmq.so:net/rabbitmq-c-devel
USES= php:pecl
-IGNORE_WITH_PHP= 74
+IGNORE_WITH_PHP= 74 80
.include <bsd.port.mk>
diff --git a/net/pecl-mosquitto/Makefile b/net/pecl-mosquitto/Makefile
index 4f18bd71d28c..fe87fce6c153 100644
--- a/net/pecl-mosquitto/Makefile
+++ b/net/pecl-mosquitto/Makefile
@@ -14,5 +14,6 @@ LICENSE= BSD3CLAUSE
BUILD_DEPENDS= mosquitto>=0:net/mosquitto
USES= php:pecl
+IGNORE_WITH_PHP= 80
.include <bsd.port.mk>
diff --git a/net/pecl-radius/Makefile b/net/pecl-radius/Makefile
index d7e1cf18087d..39250ae62cda 100644
--- a/net/pecl-radius/Makefile
+++ b/net/pecl-radius/Makefile
@@ -11,6 +11,7 @@ COMMENT= Radius client library for PHP
LICENSE= BSD3CLAUSE
USES= php:pecl
+IGNORE_WITH_PHP= 80
CONFIGURE_ARGS= --enable-radius
diff --git a/security/pecl-crypto/Makefile b/security/pecl-crypto/Makefile
index abd7db8a0384..4149e4ebc0bd 100644
--- a/security/pecl-crypto/Makefile
+++ b/security/pecl-crypto/Makefile
@@ -15,5 +15,6 @@ USES= compiler:c++11-lang php:pecl
CONFIGURE_ARGS= --with-crypto
CFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}
+IGNORE_WITH_PHP= 80
.include <bsd.port.mk>
diff --git a/security/pecl-pam/Makefile b/security/pecl-pam/Makefile
index ef4bca7f76e1..35c532ed14ec 100644
--- a/security/pecl-pam/Makefile
+++ b/security/pecl-pam/Makefile
@@ -12,5 +12,6 @@ COMMENT= PECL classes for PAM integration
LICENSE= PHP202
USES= php:pecl dos2unix
+IGNORE_WITH_PHP= 80
.include <bsd.port.mk>
diff --git a/textproc/php-mecab/Makefile b/textproc/php-mecab/Makefile
index 0b9aed9dacdf..ad98b5f8d252 100644
--- a/textproc/php-mecab/Makefile
+++ b/textproc/php-mecab/Makefile
@@ -22,6 +22,6 @@ GH_PROJECT= php-${PORTNAME}
WRKSRC_SUBDIR= mecab
CONFIGURE_ARGS= --with-mecab=${LOCALBASE}/bin/mecab-config
USES= php:ext
-IGNORE_WITH_PHP= 74
+IGNORE_WITH_PHP= 74 80
.include <bsd.port.mk>
diff --git a/www/moodle310/Makefile b/www/moodle310/Makefile
index 4106e299123f..4dedf9e68b97 100644
--- a/www/moodle310/Makefile
+++ b/www/moodle310/Makefile
@@ -19,6 +19,7 @@ USES= cpe php:flavors tar:tgz
USE_PHP= ctype curl dom fileinfo filter gd hash iconv intl json mbstring \
opcache openssl pcre session simplexml soap spl tokenizer \
xml xmlreader zip zlib
+IGNORE_WITH_PHP= 80
WRKSRC= ${WRKDIR}/moodle
OPTIONS_SINGLE= BACKEND
diff --git a/www/moodle35/Makefile b/www/moodle35/Makefile
index f42869f96528..2c66de744975 100644
--- a/www/moodle35/Makefile
+++ b/www/moodle35/Makefile
@@ -22,6 +22,7 @@ USES= cpe php:flavors tar:tgz
USE_PHP= ctype curl dom fileinfo filter gd hash iconv intl json mbstring \
opcache openssl pcre session simplexml soap spl tokenizer \
xml xmlreader zip zlib
+IGNORE_WITH_PHP= 80
WRKSRC= ${WRKDIR}/moodle
OPTIONS_SINGLE= BACKEND
diff --git a/www/moodle38/Makefile b/www/moodle38/Makefile
index cebe3f2ea545..6be1cba10a88 100644
--- a/www/moodle38/Makefile
+++ b/www/moodle38/Makefile
@@ -22,6 +22,7 @@ USES= cpe php:flavors tar:tgz
USE_PHP= ctype curl dom fileinfo filter gd hash iconv intl json mbstring \
opcache openssl pcre session simplexml soap spl tokenizer \
xml xmlreader zip zlib
+IGNORE_WITH_PHP= 80
WRKSRC= ${WRKDIR}/moodle
OPTIONS_SINGLE= BACKEND
diff --git a/www/moodle39/Makefile b/www/moodle39/Makefile
index c0a69685d641..61dd2163f204 100644
--- a/www/moodle39/Makefile
+++ b/www/moodle39/Makefile
@@ -19,6 +19,7 @@ USES= cpe php:flavors tar:tgz
USE_PHP= ctype curl dom fileinfo filter gd hash iconv intl json mbstring \
opcache openssl pcre session simplexml soap spl tokenizer \
xml xmlreader zip zlib
+IGNORE_WITH_PHP= 80
WRKSRC= ${WRKDIR}/moodle
OPTIONS_SINGLE= BACKEND
diff --git a/www/pecl-http/Makefile b/www/pecl-http/Makefile
index 5bc810f29fcc..f3555b4905f0 100644
--- a/www/pecl-http/Makefile
+++ b/www/pecl-http/Makefile
@@ -25,6 +25,7 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
USES= php:pecl
USE_PHP= zlib:build
+IGNORE_WITH_PHP= 80
CONFLICTS= pecl-http[12]*
diff --git a/www/pecl-yar/Makefile b/www/pecl-yar/Makefile
index 91993aa80bf4..46aac482b0fa 100644
--- a/www/pecl-yar/Makefile
+++ b/www/pecl-yar/Makefile
@@ -15,6 +15,7 @@ LIB_DEPENDS= libcurl.so:ftp/curl
USES= localbase:ldflags php:pecl
USE_PHP= curl json:build
+IGNORE_WITH_PHP= 80
OPTIONS_DEFINE= MSGPACK
MSGPACK_DESC= Enable MSGPACK module