aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/automake14/Makefile2
-rw-r--r--devel/automake14/files/patch-automake.in20
2 files changed, 21 insertions, 1 deletions
diff --git a/devel/automake14/Makefile b/devel/automake14/Makefile
index c586e841a01e..a6af78f9572f 100644
--- a/devel/automake14/Makefile
+++ b/devel/automake14/Makefile
@@ -3,7 +3,7 @@
PORTNAME= automake
PORTVERSION= 1.4.6
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= devel
MASTER_SITES= GNU
PKGNAMESUFFIX= 14
diff --git a/devel/automake14/files/patch-automake.in b/devel/automake14/files/patch-automake.in
new file mode 100644
index 000000000000..f594c81ff0fd
--- /dev/null
+++ b/devel/automake14/files/patch-automake.in
@@ -0,0 +1,20 @@
+--- automake.in.orig 2002-07-27 20:55:58 UTC
++++ automake.in
+@@ -983,7 +983,7 @@ sub finish_languages
+
+ # Compute the function name of the finisher and then call it.
+ $name = 'lang_' . $lang . '_finish';
+- do $name ();
++ &$name ();
+ }
+
+ # If the project is entirely C++ or entirely Fortran 77, don't
+@@ -1144,7 +1144,7 @@ sub handle_single_transform_list
+ # Found the language, so see what it says.
+ local ($subr) = 'lang_' . $lang . '_rewrite';
+ # Note: computed subr call.
+- local ($r) = do $subr ($base, $extension);
++ local ($r) = &$subr ($base, $extension);
+ # Skip this entry if we were asked not to process it.
+ next if ! $r;
+