aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/gdchart/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/graphics/gdchart/Makefile b/graphics/gdchart/Makefile
index 6f17307cbab9..9f4ec74f5933 100644
--- a/graphics/gdchart/Makefile
+++ b/graphics/gdchart/Makefile
@@ -23,9 +23,13 @@ USE_LDCONFIG= yes
EXAMPLES= ft_samp.c gdc_pie_samp.c gdc_samp1.c gdc_samp2.c
-OPTIONS_DEFINE= DOCS EXAMPLES PROFILE
-OPTIONS_DEFAULT=PROFILE
-OPTIONS_SUB= yes
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+.if defined(NO_PROFILE)
+PLIST_SUB+= PROFILE="@comment "
+.else
+PLIST_SUB+= PROFILE=""
+.endif
post-patch:
${REINPLACE_CMD} \