aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING11
-rw-r--r--www/node/Makefile8
-rw-r--r--www/node/distinfo6
-rw-r--r--www/node/files/patch-deps_openssl_openssl-cl__no__asm.gypi4
-rw-r--r--www/node/files/patch-deps_openssl_openssl__no__asm.gypi4
-rw-r--r--www/node/files/patch-deps_v8_src_arm_cpu-arm.cc4
-rw-r--r--www/node/files/patch-deps_v8_src_libsampler_sampler.cc4
-rw-r--r--www/node/files/patch-node.gypi4
-rw-r--r--www/node/pkg-plist3
9 files changed, 31 insertions, 17 deletions
diff --git a/UPDATING b/UPDATING
index a7d9fcf5ff12..5612b53ea6fa 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,17 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20190424:
+ AFFECTS: users of www/node
+ AUTHOR: bhughes@FreeBSD.org
+
+ The www/node port has been udpated to Node.js v12.0.0, the latest
+ upstream release. This is a major release, including many significant
+ changes. Users are encouraged to read the release announcements before
+ upgrading:
+
+ https://nodejs.org/en/blog/release/v12.0.0/
+
20190423:
AFFECTS: users of www/gitlab-ce
AUTHOR: mfechner@FreeBSD.org
diff --git a/www/node/Makefile b/www/node/Makefile
index 5b7bfcdc3843..0618d6e51767 100644
--- a/www/node/Makefile
+++ b/www/node/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= node
-PORTVERSION= 11.14.0
+PORTVERSION= 12.0.0
DISTVERSIONPREFIX= v
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/v${PORTVERSION}/
@@ -66,8 +66,8 @@ MAKE_ENV+= CC.host=${CC} CFLAGS.host="${CFLAGS}" \
LINK.host=${CXX} LDFLAGS.host="${LDFLAGS}"
BUILD_DEPENDS+= c-ares>=1.15.0:dns/c-ares\
- libuv>=1.27.0:devel/libuv \
- libnghttp2>=1.37.0:www/libnghttp2
+ libuv>=1.28.0:devel/libuv \
+ libnghttp2>=1.38.0:www/libnghttp2
LIB_DEPENDS+= libcares.so:dns/c-ares\
libuv.so:devel/libuv \
libnghttp2.so:www/libnghttp2
@@ -91,7 +91,7 @@ CXXFLAGS+= -D_GLIBCXX_USE_C99
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
- ${WRKSRC}/deps/v8/gypfiles/v8.gyp
+ ${WRKSRC}/tools/v8_gypfiles/v8.gyp
post-configure:
# Post-process Makefile and *.mk files created by node-gyp and remove
diff --git a/www/node/distinfo b/www/node/distinfo
index ed689e663080..64613c4627b6 100644
--- a/www/node/distinfo
+++ b/www/node/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1555041551
-SHA256 (node-v11.14.0.tar.gz) = b903ba6dc8131b9357e7c5e26967a0f48aa460c708154244a6348d49a7d8ff9a
-SIZE (node-v11.14.0.tar.gz) = 48639068
+TIMESTAMP = 1556041566
+SHA256 (node-v12.0.0.tar.gz) = ef7a25d25370a0c618d50ea72f2e78b8777e015160694d7b7cac05188cc0db65
+SIZE (node-v12.0.0.tar.gz) = 49096161
diff --git a/www/node/files/patch-deps_openssl_openssl-cl__no__asm.gypi b/www/node/files/patch-deps_openssl_openssl-cl__no__asm.gypi
index a2506b4b97ff..0f3e18221a63 100644
--- a/www/node/files/patch-deps_openssl_openssl-cl__no__asm.gypi
+++ b/www/node/files/patch-deps_openssl_openssl-cl__no__asm.gypi
@@ -1,4 +1,4 @@
---- deps/openssl/openssl-cl_no_asm.gypi.orig 2018-05-11 10:11:27 UTC
+--- deps/openssl/openssl-cl_no_asm.gypi.orig 2019-04-23 12:30:43 UTC
+++ deps/openssl/openssl-cl_no_asm.gypi
@@ -1,4 +1,5 @@
{
@@ -6,7 +6,7 @@
'conditions': [
['target_arch=="ppc" and OS=="aix"', {
'includes': ['config/archs/aix-gcc/no-asm/openssl-cl.gypi'],
-@@ -41,7 +42,7 @@
+@@ -43,7 +44,7 @@
'includes': ['config/archs/linux-x86_64/no-asm/openssl-cl.gypi'],
}, {
# Other architectures don't use assembly
diff --git a/www/node/files/patch-deps_openssl_openssl__no__asm.gypi b/www/node/files/patch-deps_openssl_openssl__no__asm.gypi
index e5410e9771a5..29736bd9038e 100644
--- a/www/node/files/patch-deps_openssl_openssl__no__asm.gypi
+++ b/www/node/files/patch-deps_openssl_openssl__no__asm.gypi
@@ -1,6 +1,6 @@
---- deps/openssl/openssl_no_asm.gypi.orig 2018-05-11 12:27:27 UTC
+--- deps/openssl/openssl_no_asm.gypi.orig 2019-04-23 12:30:43 UTC
+++ deps/openssl/openssl_no_asm.gypi
-@@ -42,7 +42,7 @@
+@@ -44,7 +44,7 @@
'includes': ['config/archs/linux-x86_64/no-asm/openssl.gypi'],
}, {
# Other architectures don't use assembly
diff --git a/www/node/files/patch-deps_v8_src_arm_cpu-arm.cc b/www/node/files/patch-deps_v8_src_arm_cpu-arm.cc
index 191fc6d6f8ab..da9aa442827e 100644
--- a/www/node/files/patch-deps_v8_src_arm_cpu-arm.cc
+++ b/www/node/files/patch-deps_v8_src_arm_cpu-arm.cc
@@ -1,4 +1,4 @@
---- deps/v8/src/arm/cpu-arm.cc.orig 2019-01-30 20:43:13 UTC
+--- deps/v8/src/arm/cpu-arm.cc.orig 2019-04-23 12:30:43 UTC
+++ deps/v8/src/arm/cpu-arm.cc
@@ -7,6 +7,9 @@
#ifdef __QNXNTO__
@@ -10,7 +10,7 @@
#else
#include <sys/syscall.h> // for cache flushing.
#endif
-@@ -24,6 +27,9 @@ void CpuFeatures::FlushICache(void* start, size_t size
+@@ -23,6 +26,9 @@ void CpuFeatures::FlushICache(void* start, size_t size
#if !defined(USE_SIMULATOR)
#if V8_OS_QNX
msync(start, size, MS_SYNC | MS_INVALIDATE_ICACHE);
diff --git a/www/node/files/patch-deps_v8_src_libsampler_sampler.cc b/www/node/files/patch-deps_v8_src_libsampler_sampler.cc
index 0bcc86c4f8ee..1fefaa63175f 100644
--- a/www/node/files/patch-deps_v8_src_libsampler_sampler.cc
+++ b/www/node/files/patch-deps_v8_src_libsampler_sampler.cc
@@ -1,6 +1,6 @@
---- deps/v8/src/libsampler/sampler.cc.orig 2019-01-30 20:43:14 UTC
+--- deps/v8/src/libsampler/sampler.cc.orig 2019-04-23 12:30:43 UTC
+++ deps/v8/src/libsampler/sampler.cc
-@@ -550,9 +550,9 @@ void SignalHandler::FillRegisterState(void* context, R
+@@ -466,9 +466,9 @@ void SignalHandler::FillRegisterState(void* context, R
state->sp = reinterpret_cast<void*>(mcontext.mc_rsp);
state->fp = reinterpret_cast<void*>(mcontext.mc_rbp);
#elif V8_HOST_ARCH_ARM
diff --git a/www/node/files/patch-node.gypi b/www/node/files/patch-node.gypi
index d37ad101bb1a..e27f34049ec9 100644
--- a/www/node/files/patch-node.gypi
+++ b/www/node/files/patch-node.gypi
@@ -1,6 +1,6 @@
---- node.gypi.orig 2019-01-30 20:43:35 UTC
+--- node.gypi.orig 2019-04-23 12:30:45 UTC
+++ node.gypi
-@@ -322,6 +322,9 @@
+@@ -315,6 +315,9 @@
['openssl_fips != "" or openssl_is_fips=="true"', {
'defines': [ 'NODE_FIPS_MODE' ],
}],
diff --git a/www/node/pkg-plist b/www/node/pkg-plist
index eb7430d65db5..c9b75338efd0 100644
--- a/www/node/pkg-plist
+++ b/www/node/pkg-plist
@@ -414,6 +414,7 @@ include/node/node_version.h
%%BUNDLED_SSL%%include/node/openssl/x509err.h
%%BUNDLED_SSL%%include/node/openssl/x509v3.h
%%BUNDLED_SSL%%include/node/openssl/x509v3err.h
+include/node/v8-internal.h
include/node/v8-platform.h
include/node/v8-profiler.h
include/node/v8-testing.h
@@ -421,6 +422,8 @@ include/node/v8-util.h
include/node/v8-value-serializer-version.h
include/node/v8-version.h
include/node/v8-version-string.h
+include/node/v8-wasm-trap-handler-posix.h
+include/node/v8-wasm-trap-handler-win.h
include/node/v8.h
include/node/v8config.h
%%DTRACE%%lib/dtrace/node.d