aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/linuxthreads/Makefile2
-rw-r--r--devel/linuxthreads/files/clone.S1
2 files changed, 2 insertions, 1 deletions
diff --git a/devel/linuxthreads/Makefile b/devel/linuxthreads/Makefile
index 1a9e5a51182e..c2e5a5b87f81 100644
--- a/devel/linuxthreads/Makefile
+++ b/devel/linuxthreads/Makefile
@@ -7,7 +7,7 @@
PORTNAME= linuxthreads
PORTVERSION= 2.2.3
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= glibc
diff --git a/devel/linuxthreads/files/clone.S b/devel/linuxthreads/files/clone.S
index bd4c7601e34b..9782fc52a3e5 100644
--- a/devel/linuxthreads/files/clone.S
+++ b/devel/linuxthreads/files/clone.S
@@ -44,6 +44,7 @@ ENTRY(_clone)
movl 12(%ebp), %esi /* get stack addr */
subl $4, %esi
+ andl $-16, %esi /* Align stack addr */
movl 20(%ebp), %eax /* get __arg */
movl %eax, (%esi)