aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-cli-helpers/Makefile30
-rw-r--r--devel/py-cli-helpers/distinfo3
-rw-r--r--devel/py-cli-helpers/pkg-descr17
4 files changed, 51 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 747aca16e283..eed8f5887e50 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4203,6 +4203,7 @@
SUBDIR += py-circuits
SUBDIR += py-cjson
SUBDIR += py-cld
+ SUBDIR += py-cli-helpers
SUBDIR += py-cliapp
SUBDIR += py-click
SUBDIR += py-click-log
diff --git a/devel/py-cli-helpers/Makefile b/devel/py-cli-helpers/Makefile
new file mode 100644
index 000000000000..b8dafeea7a9b
--- /dev/null
+++ b/devel/py-cli-helpers/Makefile
@@ -0,0 +1,30 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= cli-helpers
+PORTVERSION= 0.2.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= cli_helpers-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Helpers for building command-line apps
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pygments>=1.6:textproc/py-pygments \
+ ${PYTHON_PKGNAMEPREFIX}terminaltables>=3.0.0:textproc/py-terminaltables
+
+NO_ARCH= yes
+USE_PYTHON= autoplist distutils
+USES= python
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3000
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}backports.csv>=1.0.0:devel/py-backports.csv
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/py-cli-helpers/distinfo b/devel/py-cli-helpers/distinfo
new file mode 100644
index 000000000000..c860ed055b56
--- /dev/null
+++ b/devel/py-cli-helpers/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1499882308
+SHA256 (cli_helpers-0.2.1.tar.gz) = a868e69e780c1fd5091c83e784e8b18e2005cab921f1dfda4ffd376271ee85ac
+SIZE (cli_helpers-0.2.1.tar.gz) = 35019
diff --git a/devel/py-cli-helpers/pkg-descr b/devel/py-cli-helpers/pkg-descr
new file mode 100644
index 000000000000..efc95ad72937
--- /dev/null
+++ b/devel/py-cli-helpers/pkg-descr
@@ -0,0 +1,17 @@
+CLI Helpers is a Python package that makes it easy to perform common tasks when
+building command-line apps. It’s a helper library for command-line interfaces.
+
+Libraries like Click and Python Prompt Toolkit are amazing tools that help you
+create quality apps. CLI Helpers complements these libraries by wrapping up
+common tasks in simple interfaces.
+
+CLI Helpers is not focused on your app’s design pattern or framework – you can
+use it on its own or in combination with other libraries. It’s lightweight and
+easy to extend.
+
+What’s included in CLI Helpers?
+- Prettyprinting of tabular data with custom pre-processing
+- [in progress] config file reading/writing
+
+WWW: https://pypi.python.org/pypi/cli-helpers
+WWW: https://github.com/dbcli/cli_helpers