aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/smokeqt/Makefile2
-rw-r--r--games/katomic/Makefile2
-rw-r--r--multimedia/gstreamer1-qt4/Makefile6
-rw-r--r--net-im/kopete-kde4/Makefile3
-rw-r--r--sysutils/kfilemetadata/Makefile2
-rw-r--r--sysutils/polkit-qt/Makefile2
-rw-r--r--x11/kde4-runtime/Makefile3
7 files changed, 9 insertions, 11 deletions
diff --git a/devel/smokeqt/Makefile b/devel/smokeqt/Makefile
index 271a7cd7a0ad..dbc8608e885c 100644
--- a/devel/smokeqt/Makefile
+++ b/devel/smokeqt/Makefile
@@ -18,7 +18,7 @@ USE_QT4= corelib dbus declarative designer_build gui help \
multimedia network opengl phonon qtestlib script \
sql svg webkit xml xmlpatterns \
qmake_build moc_build uic_build rcc_build
-USES= cmake:outsource tar:xz
+USES= cmake:outsource pkgconfig tar:xz
USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/games/katomic/Makefile b/games/katomic/Makefile
index 2476b9885724..a863e310623d 100644
--- a/games/katomic/Makefile
+++ b/games/katomic/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz shebangfix
+USES= cmake:outsource shebangfix tar:xz
SHEBANG_FILES= katomic-levelset-upd.pl
USE_QT4= moc_build qmake_build rcc_build uic_build
diff --git a/multimedia/gstreamer1-qt4/Makefile b/multimedia/gstreamer1-qt4/Makefile
index cb3c4c0b8bc8..ec3788183da9 100644
--- a/multimedia/gstreamer1-qt4/Makefile
+++ b/multimedia/gstreamer1-qt4/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libboost_thread.so:devel/boost-libs
CONFLICTS_INSTALL= gstreamer-qt4-*
-USES= bison cmake:outsource gmake pkgconfig tar:xz
+USES= bison cmake:outsource pathfix pkgconfig tar:xz
USE_GSTREAMER1= yes
USE_QT4= corelib gui opengl declarative \
qmake_build moc_build rcc_build uic_build qtestlib_build
@@ -25,8 +25,4 @@ CMAKE_ARGS= -DUSE_GST_PLUGIN_DIR=off \
PLIST_SUB= SHLIB_VER="${PORTVERSION}"
-post-patch:
- ${REINPLACE_CMD} -e 's|$${CMAKE_INSTALL_LIBDIR}/pkgconfig|libdata/pkgconfig|' \
- ${WRKSRC}/CMakeLists.txt
-
.include <bsd.port.mk>
diff --git a/net-im/kopete-kde4/Makefile b/net-im/kopete-kde4/Makefile
index b3f669df55da..07c6a19fea46 100644
--- a/net-im/kopete-kde4/Makefile
+++ b/net-im/kopete-kde4/Makefile
@@ -20,7 +20,8 @@ LIB_DEPENDS= libidn.so:dns/libidn \
libjasper.so:graphics/jasper
BUILD_DEPENDS= ${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat
-USES= cmake:outsource jpeg pkgconfig shebangfix sqlite tar:xz webplugin:native
+USES= cmake:outsource jpeg pkgconfig shebangfix sqlite tar:xz \
+ webplugin:native
USE_GNOME= libxml2 libxslt
USE_KDE4= kdelibs pimlibs \
automoc4 qimageblitz
diff --git a/sysutils/kfilemetadata/Makefile b/sysutils/kfilemetadata/Makefile
index cb0badf48080..b5e87687b1c0 100644
--- a/sysutils/kfilemetadata/Makefile
+++ b/sysutils/kfilemetadata/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libpoppler-qt4.so:graphics/poppler-qt4 \
libqmobipocket.so:graphics/kdegraphics4-mobipocket
USE_KDE4= automoc4 kdelibs
-USES= cmake:outsource tar:xz
+USES= cmake:outsource pkgconfig tar:xz
USE_QT4= corelib qmake_build moc_build rcc_build uic_build
USE_LDCONFIG= yes
diff --git a/sysutils/polkit-qt/Makefile b/sysutils/polkit-qt/Makefile
index 46fce623b75f..6af126e46d3c 100644
--- a/sysutils/polkit-qt/Makefile
+++ b/sysutils/polkit-qt/Makefile
@@ -23,7 +23,7 @@ USE_GNOME= glib20
USE_KDE4= automoc4
USE_QT4= corelib dbus gui \
qmake_build moc_build rcc_build uic_build
-USES= cmake:outsource tar:bzip2
+USES= cmake:outsource pkgconfig tar:bzip2
USE_LDCONFIG= yes
post-patch:
diff --git a/x11/kde4-runtime/Makefile b/x11/kde4-runtime/Makefile
index 0738421068a5..b3f2224c18e4 100644
--- a/x11/kde4-runtime/Makefile
+++ b/x11/kde4-runtime/Makefile
@@ -24,7 +24,8 @@ RUN_DEPENDS= cagibid:net/cagibi
USE_KDE4= kactivities kdelibs oxygen \
attica automoc4 pimlibs strigi nepomuk-core
-USES= cmake:outsource gettext gmake jpeg shared-mime-info shebangfix tar:xz
+USES= cmake:outsource gettext gmake jpeg shared-mime-info shebangfix \
+ tar:xz
USE_QT4= corelib dbus declarative designer_build gui phonon \
network qtestlib script svg webkit xml \
moc_build qmake_build rcc_build uic_build