aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--science/ecs/Makefile16
-rw-r--r--science/v_sim/Makefile16
2 files changed, 18 insertions, 14 deletions
diff --git a/science/ecs/Makefile b/science/ecs/Makefile
index 7d92df4cc37a..7a64b8311ffd 100644
--- a/science/ecs/Makefile
+++ b/science/ecs/Makefile
@@ -40,19 +40,21 @@ CONFIGURE_ARGS+=--with-adf=${LOCALBASE} \
CONFIGURE_ARGS+=--without-adf --without-ccm
.endif
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext iconv
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
USE_TEX= tex:build
BUILD_DEPENDS+= fig2dev:${PORTSDIR}/print/transfig
PORTDOCS= mi_ecs.pdf mt_ecs.pdf
@@ -76,12 +78,12 @@ CONFIGURE_ARGS+= --with-scotch=${LOCALBASE}
.endif
pre-configure:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${REINPLACE_CMD} -e '/^SUBDIRS/s| po| po doc|' ${WRKSRC}/Makefile.in
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/doc/|} ${DOCSDIR}
.endif
diff --git a/science/v_sim/Makefile b/science/v_sim/Makefile
index 680d095e3127..d425c58c12da 100644
--- a/science/v_sim/Makefile
+++ b/science/v_sim/Makefile
@@ -29,15 +29,17 @@ LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
-.if !defined(NOPORTDOCS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
MAN1= v_sim.1
.endif
-.if defined(WITHOUT_NLS)
-PLIST_SUB+= NLS="@comment "
-.else
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
.endif
.if !defined(WITHOUT_CDF)
@@ -63,15 +65,15 @@ pre-configure:
-e 's|CFLAGS="-O2"|#CFLAGS="-O2"|;s|Werror ansi pedantic-errors||' \
-e 's|$${docdir}/examples|${EXAMPLESDIR}|' \
${WRKSRC}/${CONFIGURE_SCRIPT}
-.if defined(WITHOUT_NLS)
+.if ! ${PORT_OPTIONS:MNLS}
${REINPLACE_CMD} -e 's| po ||' \
${WRKSRC}/Makefile.in
.endif
-.if defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${REINPLACE_CMD} -e 's|Documentation||' \
${WRKSRC}/Makefile.in
.endif
-.if defined(NOPORTEXAMPLES)
+.if ! ${PORT_OPTIONS:MEXAMPLES}
${REINPLACE_CMD} -e 's|pixmaps \\|pixmaps|;s|examples$$||' \
${WRKSRC}/Makefile.in
${FIND} ${WRKSRC}/lib/plug-ins -name Makefile.in | ${XARGS} \