aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/ode/Makefile15
-rw-r--r--devel/ode/distinfo4
-rw-r--r--devel/ode/pkg-plist4
-rw-r--r--devel/py-ode/Makefile2
-rw-r--r--games/gillo/Makefile2
-rw-r--r--games/stormbaancoureur/Makefile2
-rw-r--r--games/xmoto/Makefile2
-rw-r--r--graphics/py-soya3d/Makefile2
8 files changed, 17 insertions, 16 deletions
diff --git a/devel/ode/Makefile b/devel/ode/Makefile
index 6e4c7ef494c5..f7e18479509a 100644
--- a/devel/ode/Makefile
+++ b/devel/ode/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= ode
-PORTVERSION= 0.11.1
+PORTVERSION= 0.13
PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= devel
@@ -18,17 +18,14 @@ USES= tar:bzip2 gmake libtool
USE_GL= yes
GNU_CONFIGURE= yes
-OPTIONS_DEFINE= GIMPACT GYROSCOPIC DOUBLE OU
-OPTIONS_DEFAULT= GYROSCOPIC
+OPTIONS_DEFINE= GIMPACT DOUBLE OU
GIMPACT_DESC= Enable gimpact instead of opcode support
-GYROSCOPIC_DESC= Configure ODE to work with gyroscopic term
DOUBLE_DESC= Enable double precision (BROKEN with GIMPACT)
OU_DESC= Enable Thread-local storage (Experimental)
GIMPACT_CONFIGURE_ON= --with-trimesh=gimpact
GIMPACT_CONFIGURE_OFF= --with-trimesh=opcode
-GYROSCOPIC_CONFIGURE_ENABLE= gyroscopic
DOUBLE_CONFIGURE_ENABLE= double-precision
OU_CONFIGURE_ENABLE= ou
@@ -49,17 +46,17 @@ post-patch:
-e 's|^\( *CPPFLAGS=\)|#\1|' -e 's|^\( *CXXFLAGS=\)|#\1|' \
-e 's|CPPFLAGS+=" |CPPFLAGS="$$CPPFLAGS |' \
${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|__isnanf||g; s|__isnan||g' \
- ${WRKSRC}/configure
- @${REINPLACE_CMD} -e '/^traplib_PROGRAMS / d' ${WRKSRC}/ode/src/Makefile.in
@${FIND} ${WRKSRC} -type f -name Makefile.in -print0 | ${XARGS} -0 ${REINPLACE_CMD} \
-e '/^DEFAULT_INCLUDES/ s|$$| -I$$(top_builddir)/include|' \
-e '/CFLAGS/ s|-O[12]||'
@${FIND} ${WRKSRC} -type f -print0 | ${XARGS} -0 ${REINPLACE_CMD} \
- -i "" -e 's|malloc.h|stdlib.h|g'
+ -i "" -e 's|<malloc.h>|<stdlib.h>|g'
post-install:
${SED} -e '/PACKAGE/ s|^|//|; /VERSION/ s|^|//|' ${WRKSRC}/ode/src/config.h \
> ${STAGEDIR}${PREFIX}/include/ode/config.h
+regression-test: build
+ @(cd ${WRKSRC} && ${MAKE} check)
+
.include <bsd.port.post.mk>
diff --git a/devel/ode/distinfo b/devel/ode/distinfo
index 507fceb7d94a..4679824956d8 100644
--- a/devel/ode/distinfo
+++ b/devel/ode/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ode-0.11.1.tar.bz2) = 877884a86a3d53f3c5f2e35fbd8a3dc23c20249f0636c76f6ef41f6bf57a03a1
-SIZE (ode-0.11.1.tar.bz2) = 1720088
+SHA256 (ode-0.13.tar.bz2) = 34ce3e236e313bf109a0cb5546d2fca462aed99f29a42e62bc1463b803c31ef9
+SIZE (ode-0.13.tar.bz2) = 2008288
diff --git a/devel/ode/pkg-plist b/devel/ode/pkg-plist
index 3d5288580c1b..50cab3525c56 100644
--- a/devel/ode/pkg-plist
+++ b/devel/ode/pkg-plist
@@ -19,7 +19,11 @@ include/ode/odecpp.h
include/ode/odecpp_collision.h
include/ode/odeinit.h
include/ode/odemath.h
+include/ode/odemath_legacy.h
+include/ode/precision.h
include/ode/rotation.h
+include/ode/threading.h
+include/ode/threading_impl.h
include/ode/timer.h
lib/libode.a
libdata/pkgconfig/ode.pc
diff --git a/devel/py-ode/Makefile b/devel/py-ode/Makefile
index 9b90f0397562..053b9d29f35e 100644
--- a/devel/py-ode/Makefile
+++ b/devel/py-ode/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ode
PORTVERSION= 1.2.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel python
MASTER_SITES= SF/py${PORTNAME}/py${PORTNAME}/${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/games/gillo/Makefile b/games/gillo/Makefile
index 503149963331..71835926553c 100644
--- a/games/gillo/Makefile
+++ b/games/gillo/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gillo
DISTVERSION= 1.0beta1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/1.0beta1
DISTNAME= ${PORTNAME}-${DISTVERSION}-src
diff --git a/games/stormbaancoureur/Makefile b/games/stormbaancoureur/Makefile
index d82edbadb2b7..d377a15764a3 100644
--- a/games/stormbaancoureur/Makefile
+++ b/games/stormbaancoureur/Makefile
@@ -3,7 +3,7 @@
PORTNAME= stormbaancoureur
PORTVERSION= 2.1.5
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= games
MASTER_SITES= http://bram.creative4vision.nl/stormbaancoureur/download/ \
http://mirror.amdmi3.ru/distfiles/
diff --git a/games/xmoto/Makefile b/games/xmoto/Makefile
index c5d3172e87b1..837304333b04 100644
--- a/games/xmoto/Makefile
+++ b/games/xmoto/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xmoto
PORTVERSION= 0.5.11
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= http://download.tuxfamily.org/xmoto/xmoto/${PORTVERSION}/ \
http://mirror.amdmi3.ru/distfiles/
diff --git a/graphics/py-soya3d/Makefile b/graphics/py-soya3d/Makefile
index a8fe9f4a1ce5..eff48a50cade 100644
--- a/graphics/py-soya3d/Makefile
+++ b/graphics/py-soya3d/Makefile
@@ -3,7 +3,7 @@
PORTNAME= soya3d
PORTVERSION= 0.14
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= graphics python
MASTER_SITES= http://download.gna.org/soya/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}