aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/xapian-core/Makefile2
-rw-r--r--devel/aarch64-binutils/Makefile4
-rw-r--r--devel/llvm34/Makefile3
-rw-r--r--devel/mingw32-gcc/Makefile2
-rw-r--r--editors/vim/Makefile2
-rw-r--r--emulators/qemu/Makefile12
-rw-r--r--lang/pypy/Makefile3
-rw-r--r--multimedia/cuse4bsd-kmod/Makefile2
-rw-r--r--multimedia/ffmpegthumbnailer/Makefile2
-rw-r--r--multimedia/libcec/Makefile2
-rw-r--r--multimedia/vlc-qt4/Makefile2
-rw-r--r--net/p5-Net-SSH-Perl/Makefile2
-rw-r--r--print/texlive-base/Makefile3
-rw-r--r--science/orthanc/Makefile2
-rw-r--r--sysutils/cdrdao/Makefile4
-rw-r--r--sysutils/lsof/Makefile2
16 files changed, 41 insertions, 8 deletions
diff --git a/databases/xapian-core/Makefile b/databases/xapian-core/Makefile
index b18bb6947108..5dcab17f06c4 100644
--- a/databases/xapian-core/Makefile
+++ b/databases/xapian-core/Makefile
@@ -14,6 +14,8 @@ COMMENT= Probabilistic text search database engine
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc64= fails to configure: A compiler with support for C++11 language features is required
+
CONFLICTS_INSTALL= xapian-core10- xapian-core12-
OPTIONS_DEFINE= DOCS SSE2
diff --git a/devel/aarch64-binutils/Makefile b/devel/aarch64-binutils/Makefile
index 4e971f31d5a4..17733da0e19e 100644
--- a/devel/aarch64-binutils/Makefile
+++ b/devel/aarch64-binutils/Makefile
@@ -4,6 +4,10 @@ COMMENT= GNU binutils for AArch64 cross-development
PKGNAMEPREFIX= aarch64-
PLIST= ${.CURDIR}/pkg-plist
+BROKEN_mips= fails to configure: error: C compiler cannot create executables
+BROKEN_mips64= fails to configure: error: C compiler cannot create executables
+BROKEN_powerpc64= fails to configure: error: C compiler cannot create executables
+
MASTERDIR= ${.CURDIR}/../binutils
OPTIONS_DEFAULT= STATIC
diff --git a/devel/llvm34/Makefile b/devel/llvm34/Makefile
index aa127b3b6acf..ed12000ca551 100644
--- a/devel/llvm34/Makefile
+++ b/devel/llvm34/Makefile
@@ -11,7 +11,8 @@ PKGNAMESUFFIX= ${LLVM_SUFFIX}
MAINTAINER= brooks@FreeBSD.org
COMMENT= Low Level Virtual Machine
-BROKEN_powerpc64= Does not build
+BROKEN_powerpc64= does not compile: libLLVMMipsCodeGen.a: sibling call optimization does not allow automatic multiple TOCs
+BROKEN_sparc64= does not compile: llvm::Function::lookupIntrinsicID() Function.cpp: internal compiler error: Abort trap
LLVM_SUFFIX= ${PORTVERSION:C/([0-9]\.[0-9]).*/\1/:S/.//g:C/r.//}
LLVM_PREFIX= ${PREFIX}/llvm${LLVM_SUFFIX}
diff --git a/devel/mingw32-gcc/Makefile b/devel/mingw32-gcc/Makefile
index 93372c52e7d6..532fc7946d62 100644
--- a/devel/mingw32-gcc/Makefile
+++ b/devel/mingw32-gcc/Makefile
@@ -22,6 +22,8 @@ LIB_DEPENDS= libgmp.so:math/gmp \
libmpfr.so:math/mpfr \
libmpc.so:math/mpc
+BROKEN_powerpc64= fails to configure: error: cannot compute suffix of object files: cannot compile
+
GCCVERSION= 4.8.1
SSP_UNSAFE= yes
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index beb153760f40..efb1ed92ebdd 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -14,6 +14,8 @@ LICENSE_NAME= VIM License
LICENSE_FILE= ${WRKSRC}/runtime/doc/uganda.txt
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+BROKEN_powerpc64= fails to compile: ruby.h: error: wrong number of arguments specified for 'deprecated' attribute
+
OPTIONS_DEFINE= CSCOPE DEFAULT_VIMRC EXUBERANT_CTAGS NLS XTERM_SAVE
OPTIONS_SINGLE= UI
OPTIONS_SINGLE_UI= ATHENA CONSOLE GNOME GTK2 GTK3 MOTIF X11
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index 76201440119b..359b079d5729 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -22,6 +22,8 @@ USE_GNOME+= cairo glib20
ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64 # XXX someone wants to debug sparc64 hosts?
.endif
+BROKEN_powerpc64= fails to compile: In function aio_bh_poll: internal compiler error: Segmentation fault
+
OPTIONS_DEFINE= SAMBA X11 GTK2 OPENGL GNUTLS SASL JPEG PNG CURL \
CDROM_DMA PCAP USBREDIR GNS3 X86_TARGETS \
STATIC_LINK DOCS NCURSES
@@ -107,11 +109,11 @@ MAKE_ARGS+= ARCH=ppc64
CONFIGURE_ARGS+= --sparc_cpu=v9
.endif
-# clang in freebsd 10 is unable to assemble linuxboot_dma.bin
-.if (${OSVERSION} < 1100000)
-PLIST_SUB+= LINUXBOOT_DMA="@comment "
-.else
-PLIST_SUB+= LINUXBOOT_DMA=""
+# clang in freebsd 10 is unable to assemble linuxboot_dma.bin
+.if (${OSVERSION} < 1100000)
+PLIST_SUB+= LINUXBOOT_DMA="@comment "
+.else
+PLIST_SUB+= LINUXBOOT_DMA=""
.endif
# -lprocstat actually only _needs_ -lelf after r249666 or r250870 (MFC)
diff --git a/lang/pypy/Makefile b/lang/pypy/Makefile
index 16e80900fbe2..ffe163247739 100644
--- a/lang/pypy/Makefile
+++ b/lang/pypy/Makefile
@@ -24,6 +24,9 @@ TEST_DEPENDS= ${LOCALBASE}/${PYPY_DIR}/lib_pypy/_gdbm_cffi.${PYPY_CFFI_VER}.so:d
ONLY_FOR_ARCHS?=i386 amd64 armv6 powerpc64
ONLY_FOR_ARCHS_REASON?= PyPy JIT only supported on these architectures
+BROKEN_armv6= fails to package: pypy_objspace_std.c: Crash in JIT!
+BROKEN_powerpc64= fails to compile: platcheck_109.c: fatal error: linux/auxvec.h: No such file or directory
+
OPTIONS_SINGLE= TRANS
OPTIONS_SINGLE_TRANS= PYTHON
PYTHON_DESC= Use Python-2.7 to translate (slowest)
diff --git a/multimedia/cuse4bsd-kmod/Makefile b/multimedia/cuse4bsd-kmod/Makefile
index 2620821371f9..6032600ff2be 100644
--- a/multimedia/cuse4bsd-kmod/Makefile
+++ b/multimedia/cuse4bsd-kmod/Makefile
@@ -11,6 +11,8 @@ COMMENT= Cuse4BSD character device loopback driver for userspace
CONFLICTS= video4bsd-kmod*
+BROKEN_powerpc64= fails to compile: pcpu.h: error: size of array '__assert_0' is negative
+
KMODNAME= cuse4bsd
LIBDIR= ${PREFIX}/lib
INCLUDEDIR= ${PREFIX}/include
diff --git a/multimedia/ffmpegthumbnailer/Makefile b/multimedia/ffmpegthumbnailer/Makefile
index 6e90a80a51e7..54394aa2520a 100644
--- a/multimedia/ffmpegthumbnailer/Makefile
+++ b/multimedia/ffmpegthumbnailer/Makefile
@@ -15,6 +15,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpng.so:graphics/png \
libswscale.so:multimedia/ffmpeg
+BROKEN_powerpc64= fails to compile: moviedecoder.cpp: error: 'to_string' is not a member of 'std'
+
USE_GITHUB= yes
GH_ACCOUNT= dirkvdb
diff --git a/multimedia/libcec/Makefile b/multimedia/libcec/Makefile
index 2ef7911fdbe6..69529bd43591 100644
--- a/multimedia/libcec/Makefile
+++ b/multimedia/libcec/Makefile
@@ -14,6 +14,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libp8-platform.so:devel/p8-platform
+BROKEN_powerpc64= fails to compile: cecloader.h: converting to 'bool' from 'std::nullptr_t' requires direct-initialization
+
USE_GITHUB= yes
GH_ACCOUNT= Pulse-Eight
diff --git a/multimedia/vlc-qt4/Makefile b/multimedia/vlc-qt4/Makefile
index 6de8c659cd67..daeb0590d45e 100644
--- a/multimedia/vlc-qt4/Makefile
+++ b/multimedia/vlc-qt4/Makefile
@@ -10,6 +10,8 @@ OPTIONS_EXCLUDE= QT5
CONFLICTS= vlc-[0-9]*
+BROKEN_powerpc64= fails to compile: modules/plugins.dat: Segmentation fault (core dumped)
+
MASTERDIR= ${.CURDIR}/../vlc
.include "${MASTERDIR}/Makefile"
diff --git a/net/p5-Net-SSH-Perl/Makefile b/net/p5-Net-SSH-Perl/Makefile
index b26a394b886b..57eedce84066 100644
--- a/net/p5-Net-SSH-Perl/Makefile
+++ b/net/p5-Net-SSH-Perl/Makefile
@@ -26,6 +26,8 @@ BUILD_DEPENDS= p5-Crypt-Curve25519>=0.05:security/p5-Crypt-Curve25519 \
p5-String-CRC32>=1.2:devel/p5-String-CRC32
RUN_DEPENDS:= ${BUILD_DEPENDS}
+BROKEN_powerpc64= fails to compile: src/chacha/poly1305.c: subscripted value is neither array nor pointer
+
CONFIGURE_ENV= PERL_MM_USE_DEFAULT="1"
NO_ARCH= yes
USES= perl5
diff --git a/print/texlive-base/Makefile b/print/texlive-base/Makefile
index e19a0f805be9..75704fb0655a 100644
--- a/print/texlive-base/Makefile
+++ b/print/texlive-base/Makefile
@@ -26,6 +26,8 @@ LIB_DEPENDS= libicuio.so:devel/icu \
libpoppler.so:graphics/poppler \
libpotrace.so:graphics/libpotrace
+BROKEN_powerpc64= fails to configure: checking requested system `icu' library... failed
+
CONFLICTS_INSTALL= texlive-texmf-201[234]*
USE_TEX= web2c kpathsea ptexenc tlmgr texhash-bootstrap
@@ -112,7 +114,6 @@ SHEBANG_FILES= texk/texlive/linked_scripts/accfonts/mkt1font \
texk/texlive/linked_scripts/urlbst/urlbst \
texk/texlive/linked_scripts/yplan/yplan
-
INFO= dvipng tlbuild
OPTIONS_DEFINE= X11
diff --git a/science/orthanc/Makefile b/science/orthanc/Makefile
index 6b73f04ddc09..1e27dc93f09f 100644
--- a/science/orthanc/Makefile
+++ b/science/orthanc/Makefile
@@ -35,7 +35,7 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libgtest.so:devel/googletest \
libpugixml.so:textproc/pugixml
-BROKEN_powerpc64= Does not build
+BROKEN_powerpc64= fails to configure: CMake: Looking for C++ include pugixml.hpp - not found
CMAKE_ARGS= -DDCMTK_LIBRARIES="dcmdsig;charls;dcmjpls" \
-DDCMTK_DIR="${LOCALBASE}" \
diff --git a/sysutils/cdrdao/Makefile b/sysutils/cdrdao/Makefile
index 1bcaa66d31e6..f34c7a6f5d55 100644
--- a/sysutils/cdrdao/Makefile
+++ b/sysutils/cdrdao/Makefile
@@ -13,6 +13,10 @@ COMMENT?= Record CD-R[W]s in disk-at-once mode
LICENSE= GPLv2
+BROKEN_mips= fails to compile: cc1plus: error: unrecognized command line option "-std=c++11"
+BROKEN_mips64= fails to compile: cc1plus: error: unrecognized command line option "-std=c++11"
+BROKEN_powerpc64= fails to compile: cc1plus: error: unrecognized command line option "-std=c++11"
+
GNU_CONFIGURE= yes
USE_CXXSTD= c++11
USES= alias gmake tar:bzip2
diff --git a/sysutils/lsof/Makefile b/sysutils/lsof/Makefile
index 70fdb5fb38fc..8b6bc6518090 100644
--- a/sysutils/lsof/Makefile
+++ b/sysutils/lsof/Makefile
@@ -29,6 +29,8 @@ LICENSE_NAME=lsof
LICENSE_FILE=${FILESDIR}/LICENSE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+BROKEN_powerpc64= fails to compile: sys/pcpu.h: error: size of array '__assert_0' is negative
+
#Please leave the below line in for the next clean up.
FIXUP_RELEASE= YES
.if defined(FIXUP_RELEASE)