aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emulators/mame/Makefile16
-rw-r--r--emulators/mess/Makefile2
-rw-r--r--emulators/mess/pkg-plist163
3 files changed, 158 insertions, 23 deletions
diff --git a/emulators/mame/Makefile b/emulators/mame/Makefile
index c5f0db89515b..73f94b1369fd 100644
--- a/emulators/mame/Makefile
+++ b/emulators/mame/Makefile
@@ -15,9 +15,11 @@ ONLY_FOR_ARCHS_REASON= not yet ported to any arch other than x86
LIB_DEPENDS= libFLAC.so:audio/flac \
libexpat.so:textproc/expat2 \
- libfontconfig.so:x11-fonts/fontconfig
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
RUN_DEPENDS= liberation-fonts-ttf>=0:x11-fonts/liberation-fonts-ttf
+USES= compiler:c11 gmake jpeg pkgconfig python:2.7,build shebangfix
USE_GITHUB= yes
GH_ACCOUNT= mamedev
GH_PROJECT= mame # explicit (master port)
@@ -28,10 +30,11 @@ OPTIONS_DEFINE= DEBUG DOCS EXAMPLES
.include <bsd.port.options.mk>
.if ${OSVERSION} < 1100055
-USE_GCC= 6
+BUILD_DEPENDS+= clang50:devel/llvm50
+CC= clang50
+CXX= clang++50
.endif
-USES= compiler:c11 gmake jpeg pkgconfig python:2.7,build shebangfix
SHEBANG_FILES= src/devices/cpu/m6502/m6502make.py \
src/devices/cpu/m6809/m6809make.py \
src/devices/cpu/mcs96/mcs96make.py \
@@ -39,7 +42,7 @@ SHEBANG_FILES= src/devices/cpu/m6502/m6502make.py \
USE_XORG= x11 xext xi xinerama xrender
USE_GL= gl
USE_SDL= sdl2 ttf2
-USE_QT5= buildtools gui qmake_build widgets
+USE_QT5= buildtools core gui qmake_build widgets
MTARGET?= mame
MSUBTARGET?= mame
CFLAGS+= -I${LOCALBASE}/include
@@ -112,8 +115,9 @@ do-install:
${STAGEDIR}${PREFIX}/libexec/mame)
.endif
.if ${MSUBTARGET:Mmess}
- (cd ${WRKSRC} && ${INSTALL_PROGRAM} castool chdman imgtool jedutil \
- ldresample ldverify romcmp testkeys unidasm \
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} castool chdman floptool imgtool jedutil \
+ ldresample ldverify nltool nlwav pngcmp regrep romcmp split src2html \
+ srcclean unidasm \
${STAGEDIR}${PREFIX}/libexec/mess)
.endif
(cd ${WRKSRC} && ${COPYTREE_SHARE} artwork ${STAGEDIR}${DATADIR})
diff --git a/emulators/mess/Makefile b/emulators/mess/Makefile
index 2fb4825eb652..612301e1158c 100644
--- a/emulators/mess/Makefile
+++ b/emulators/mess/Makefile
@@ -5,8 +5,6 @@ MTARGET= mame
MSUBTARGET= mess
COMMENT= Multiple Emulator Super System
-BROKEN= fails to install
-
MASTERDIR= ${.CURDIR}/../mame
DESCR= ${.CURDIR}/pkg-descr
PLIST= ${.CURDIR}/pkg-plist
diff --git a/emulators/mess/pkg-plist b/emulators/mess/pkg-plist
index d8167e4018f4..dbd24908476a 100644
--- a/emulators/mess/pkg-plist
+++ b/emulators/mess/pkg-plist
@@ -1,19 +1,58 @@
bin/%%EMULATOR%%
libexec/mess/castool
libexec/mess/chdman
+libexec/mess/floptool
libexec/mess/imgtool
libexec/mess/jedutil
libexec/mess/ldresample
libexec/mess/ldverify
+libexec/mess/nltool
+libexec/mess/nlwav
+libexec/mess/pngcmp
+libexec/mess/regrep
libexec/mess/romcmp
-libexec/mess/testkeys
+libexec/mess/split
+libexec/mess/src2html
+libexec/mess/srcclean
libexec/mess/unidasm
-%%DATADIR%%/artwork/adapture-grill.png
+%%DATADIR%%/artwork/LICENSE
+%%DATADIR%%/artwork/README.md
+%%DATADIR%%/artwork/aperture-grille.png
+%%DATADIR%%/artwork/aperture.png
+%%DATADIR%%/artwork/aperture1x2rb.png
+%%DATADIR%%/artwork/aperture1x3rb.png
+%%DATADIR%%/artwork/aperture2x4bg.png
+%%DATADIR%%/artwork/aperture2x4rb.png
+%%DATADIR%%/artwork/aperture4x6.png
+%%DATADIR%%/artwork/bgfx/border_blur/default.lay
+%%DATADIR%%/artwork/bgfx/chains/crt-geom/aperture_1_2_bgr.png
+%%DATADIR%%/artwork/bgfx/chains/crt-geom/aperture_1_4_rgb.png
+%%DATADIR%%/artwork/bgfx/chains/crt-geom/aperture_2_4_rgb.png
+%%DATADIR%%/artwork/bgfx/chains/crt-geom/aperture_2_5_bgr.png
+%%DATADIR%%/artwork/bgfx/chains/crt-geom/aperture_3_6_rgb.png
+%%DATADIR%%/artwork/bgfx/chains/crt-geom/delta_1_2x1_bgr.png
+%%DATADIR%%/artwork/bgfx/chains/crt-geom/delta_1_4x1_rgb.png
+%%DATADIR%%/artwork/bgfx/chains/crt-geom/delta_2_4x1_rgb.png
+%%DATADIR%%/artwork/bgfx/chains/crt-geom/delta_2_4x2_rgb.png
+%%DATADIR%%/artwork/bgfx/chains/crt-geom/none.png
+%%DATADIR%%/artwork/bgfx/chains/crt-geom/slot_2_4x4_rgb.png
+%%DATADIR%%/artwork/bgfx/chains/crt-geom/slot_2_5x4_bgr.png
+%%DATADIR%%/artwork/bgfx/chains/crt-geom/slot_3_7x6_rgb.png
+%%DATADIR%%/artwork/bgfx/chains/hq2x.png
+%%DATADIR%%/artwork/bgfx/chains/hq3x.png
+%%DATADIR%%/artwork/bgfx/chains/hq4x.png
+%%DATADIR%%/artwork/dir.txt
+%%DATADIR%%/artwork/monochrome-chessboard.png
+%%DATADIR%%/artwork/monochrome-matrix.png
+%%DATADIR%%/artwork/scanlines.png
%%DATADIR%%/artwork/shadow-mask.png
+%%DATADIR%%/artwork/slot-mask-aligned.png
%%DATADIR%%/artwork/slot-mask.png
%%DATADIR%%/artwork/white.png
%%DATADIR%%/hash/32x.xml
%%DATADIR%%/hash/3do_m2.xml
+%%DATADIR%%/hash/LICENSE
+%%DATADIR%%/hash/README.md
%%DATADIR%%/hash/a2600.xml
%%DATADIR%%/hash/a2600_cass.xml
%%DATADIR%%/hash/a5200.hsi
@@ -36,6 +75,7 @@ libexec/mess/unidasm
%%DATADIR%%/hash/aleste.xml
%%DATADIR%%/hash/alice32.xml
%%DATADIR%%/hash/alice90.xml
+%%DATADIR%%/hash/alphatro_cart.xml
%%DATADIR%%/hash/alphatro_flop.xml
%%DATADIR%%/hash/altos5.xml
%%DATADIR%%/hash/amiga_a1000.xml
@@ -55,26 +95,42 @@ libexec/mess/unidasm
%%DATADIR%%/hash/apollo_ctape.xml
%%DATADIR%%/hash/apple1.xml
%%DATADIR%%/hash/apple2.xml
+%%DATADIR%%/hash/apple2_cass.xml
%%DATADIR%%/hash/apple2gs.xml
%%DATADIR%%/hash/apple3.xml
+%%DATADIR%%/hash/apricot_flop.xml
%%DATADIR%%/hash/aquarius.xml
%%DATADIR%%/hash/arcadia.xml
%%DATADIR%%/hash/archimedes.xml
%%DATADIR%%/hash/astrocde.xml
-%%DATADIR%%/hash/atom.xml
+%%DATADIR%%/hash/atom_cass.xml
+%%DATADIR%%/hash/atom_flop.xml
+%%DATADIR%%/hash/atom_rom.xml
%%DATADIR%%/hash/attache.xml
%%DATADIR%%/hash/b2m.xml
+%%DATADIR%%/hash/bbc_flop_32016.xml
+%%DATADIR%%/hash/bbc_flop_6502.xml
+%%DATADIR%%/hash/bbc_flop_65c102.xml
+%%DATADIR%%/hash/bbc_flop_68000.xml
+%%DATADIR%%/hash/bbc_flop_80186.xml
+%%DATADIR%%/hash/bbc_flop_arm.xml
+%%DATADIR%%/hash/bbc_flop_torch.xml
+%%DATADIR%%/hash/bbc_flop_z80.xml
%%DATADIR%%/hash/bbca_cass.xml
%%DATADIR%%/hash/bbcb_cass.xml
-%%DATADIR%%/hash/bbcb_de_cass.xml
-%%DATADIR%%/hash/bbcb_us_flop.xml
+%%DATADIR%%/hash/bbcb_cass_de.xml
+%%DATADIR%%/hash/bbcb_flop.xml
+%%DATADIR%%/hash/bbcb_flop_orig.xml
+%%DATADIR%%/hash/bbcb_flop_us.xml
%%DATADIR%%/hash/bbcbc.xml
%%DATADIR%%/hash/bbcm_cart.xml
%%DATADIR%%/hash/bbcm_cass.xml
+%%DATADIR%%/hash/bbcm_flop.xml
%%DATADIR%%/hash/bbcmc_flop.xml
%%DATADIR%%/hash/bk0010.xml
%%DATADIR%%/hash/bml3_flop.xml
%%DATADIR%%/hash/bw12.xml
+%%DATADIR%%/hash/bw14.xml
%%DATADIR%%/hash/bw2.xml
%%DATADIR%%/hash/bx256hp_flop.xml
%%DATADIR%%/hash/c128_cart.xml
@@ -93,9 +149,10 @@ libexec/mess/unidasm
%%DATADIR%%/hash/cd32.xml
%%DATADIR%%/hash/cdi.xml
%%DATADIR%%/hash/cdtv.xml
-%%DATADIR%%/hash/cgenie_cart.xml
%%DATADIR%%/hash/cgenie_cass.xml
+%%DATADIR%%/hash/cgenie_flop_rom.xml
%%DATADIR%%/hash/channelf.xml
+%%DATADIR%%/hash/chessmstdm.xml
%%DATADIR%%/hash/coco_cart.xml
%%DATADIR%%/hash/coco_flop.xml
%%DATADIR%%/hash/coleco.xml
@@ -109,23 +166,38 @@ libexec/mess/unidasm
%%DATADIR%%/hash/cx3000tc.xml
%%DATADIR%%/hash/dai_cass.xml
%%DATADIR%%/hash/database.xml
+%%DATADIR%%/hash/dc.xml
+%%DATADIR%%/hash/dgnalpha_flop.xml
+%%DATADIR%%/hash/dgnbeta_flop.xml
%%DATADIR%%/hash/dim68k.xml
%%DATADIR%%/hash/dmv.xml
%%DATADIR%%/hash/dps1.xml
+%%DATADIR%%/hash/dragon_cart.xml
+%%DATADIR%%/hash/dragon_cass.xml
+%%DATADIR%%/hash/dragon_flex.xml
+%%DATADIR%%/hash/dragon_flop.xml
+%%DATADIR%%/hash/dragon_os9.xml
+%%DATADIR%%/hash/e01_flop.xml
%%DATADIR%%/hash/ec1841.xml
%%DATADIR%%/hash/einstein.xml
%%DATADIR%%/hash/electron_cart.xml
+%%DATADIR%%/hash/electron_cass.xml
+%%DATADIR%%/hash/electron_flop.xml
+%%DATADIR%%/hash/electron_rom.xml
%%DATADIR%%/hash/ep64_cart.xml
%%DATADIR%%/hash/ep64_cass.xml
%%DATADIR%%/hash/ep64_flop.xml
%%DATADIR%%/hash/epson_cpm.xml
+%%DATADIR%%/hash/ews286_flop.xml
%%DATADIR%%/hash/exl100.xml
%%DATADIR%%/hash/famicom_cass.xml
%%DATADIR%%/hash/famicom_flop.xml
+%%DATADIR%%/hash/fidel_scc.xml
%%DATADIR%%/hash/fm77av.xml
%%DATADIR%%/hash/fm7_cass.xml
%%DATADIR%%/hash/fm7_disk.xml
%%DATADIR%%/hash/fmtowns_cd.xml
+%%DATADIR%%/hash/fmtowns_flop.xml
%%DATADIR%%/hash/g7400.xml
%%DATADIR%%/hash/galaxy.xml
%%DATADIR%%/hash/gamate.xml
@@ -136,6 +208,7 @@ libexec/mess/unidasm
%%DATADIR%%/hash/gameking3.xml
%%DATADIR%%/hash/gamepock.xml
%%DATADIR%%/hash/gba.xml
+%%DATADIR%%/hash/gba_ereader.xml
%%DATADIR%%/hash/gbcolor.xml
%%DATADIR%%/hash/genius.xml
%%DATADIR%%/hash/gimix.xml
@@ -147,18 +220,23 @@ libexec/mess/unidasm
%%DATADIR%%/hash/gp32.xml
%%DATADIR%%/hash/guab.xml
%%DATADIR%%/hash/gx4000.xml
+%%DATADIR%%/hash/h21.xml
%%DATADIR%%/hash/horizon.xml
+%%DATADIR%%/hash/hp85_rom.xml
%%DATADIR%%/hash/hp9835a_rom.xml
%%DATADIR%%/hash/hp9845a_rom.xml
%%DATADIR%%/hash/hp9845b_rom.xml
+%%DATADIR%%/hash/hp_ipc.xml
%%DATADIR%%/hash/ht68k.xml
+%%DATADIR%%/hash/hx20_rom.xml
+%%DATADIR%%/hash/hyperscan.xml
%%DATADIR%%/hash/i7000_card.xml
%%DATADIR%%/hash/ibm5140.xml
%%DATADIR%%/hash/ibm5150.xml
%%DATADIR%%/hash/ibm5150_cass.xml
-%%DATADIR%%/hash/ibm5160_flop.xml
%%DATADIR%%/hash/ibm5170.xml
%%DATADIR%%/hash/ibm5170_cdrom.xml
+%%DATADIR%%/hash/ibm6580.xml
%%DATADIR%%/hash/ibmpcjr_cart.xml
%%DATADIR%%/hash/ibmpcjr_flop.xml
%%DATADIR%%/hash/interact.xml
@@ -171,12 +249,15 @@ libexec/mess/unidasm
%%DATADIR%%/hash/jaguar.xml
%%DATADIR%%/hash/juicebox.xml
%%DATADIR%%/hash/jupace_cass.xml
+%%DATADIR%%/hash/k28m2.xml
%%DATADIR%%/hash/kayproii.xml
%%DATADIR%%/hash/kc_cart.xml
%%DATADIR%%/hash/kc_cass.xml
%%DATADIR%%/hash/kc_flop.xml
+%%DATADIR%%/hash/kim1_cass.xml
%%DATADIR%%/hash/korvet_flop.xml
%%DATADIR%%/hash/lantutor.xml
+%%DATADIR%%/hash/laser2001_cart.xml
%%DATADIR%%/hash/leapster.xml
%%DATADIR%%/hash/lisa.xml
%%DATADIR%%/hash/lisa2.xml
@@ -185,6 +266,7 @@ libexec/mess/unidasm
%%DATADIR%%/hash/m20.xml
%%DATADIR%%/hash/m5_cart.xml
%%DATADIR%%/hash/m5_cass.xml
+%%DATADIR%%/hash/m5_flop.xml
%%DATADIR%%/hash/mac_flop.xml
%%DATADIR%%/hash/mac_hdd.xml
%%DATADIR%%/hash/mbc200.xml
@@ -192,6 +274,7 @@ libexec/mess/unidasm
%%DATADIR%%/hash/mc10.xml
%%DATADIR%%/hash/mc1000_cass.xml
%%DATADIR%%/hash/mc1502_flop.xml
+%%DATADIR%%/hash/md2_flop.xml
%%DATADIR%%/hash/megacd.xml
%%DATADIR%%/hash/megacdj.xml
%%DATADIR%%/hash/megadriv.xml
@@ -205,6 +288,11 @@ libexec/mess/unidasm
%%DATADIR%%/hash/misterx.xml
%%DATADIR%%/hash/mm1_flop.xml
%%DATADIR%%/hash/mo5_cart.xml
+%%DATADIR%%/hash/mo5_cass.xml
+%%DATADIR%%/hash/mo5_flop.xml
+%%DATADIR%%/hash/mo5_qd.xml
+%%DATADIR%%/hash/mo6_cass.xml
+%%DATADIR%%/hash/mo6_flop.xml
%%DATADIR%%/hash/mpu1000.xml
%%DATADIR%%/hash/mpz80.xml
%%DATADIR%%/hash/msx.hsi
@@ -217,7 +305,9 @@ libexec/mess/unidasm
%%DATADIR%%/hash/msx2_flop.xml
%%DATADIR%%/hash/msx2p_flop.xml
%%DATADIR%%/hash/msxr_flop.xml
+%%DATADIR%%/hash/mtx_cart.xml
%%DATADIR%%/hash/mtx_cass.xml
+%%DATADIR%%/hash/mtx_rom.xml
%%DATADIR%%/hash/myvision.xml
%%DATADIR%%/hash/mz2000_cass.xml
%%DATADIR%%/hash/mz2000_flop.xml
@@ -240,6 +330,7 @@ libexec/mess/unidasm
%%DATADIR%%/hash/ngp.xml
%%DATADIR%%/hash/ngpc.xml
%%DATADIR%%/hash/nimbus.xml
+%%DATADIR%%/hash/octopus.xml
%%DATADIR%%/hash/odyssey2.xml
%%DATADIR%%/hash/ondra.xml
%%DATADIR%%/hash/orao.xml
@@ -254,15 +345,21 @@ libexec/mess/unidasm
%%DATADIR%%/hash/partner_flop.xml
%%DATADIR%%/hash/pasogo.xml
%%DATADIR%%/hash/pb2000c.xml
-%%DATADIR%%/hash/pc1512.xml
-%%DATADIR%%/hash/pc1640.xml
+%%DATADIR%%/hash/pc1000.xml
+%%DATADIR%%/hash/pc1512_flop.xml
+%%DATADIR%%/hash/pc1512_hdd.xml
+%%DATADIR%%/hash/pc1640_flop.xml
+%%DATADIR%%/hash/pc1640_hdd.xml
%%DATADIR%%/hash/pc8201.xml
%%DATADIR%%/hash/pc8801_cass.xml
%%DATADIR%%/hash/pc8801_flop.xml
%%DATADIR%%/hash/pc88va.xml
%%DATADIR%%/hash/pc98.xml
+%%DATADIR%%/hash/pc98_cd.xml
%%DATADIR%%/hash/pce.xml
+%%DATADIR%%/hash/pce_tourvision.xml
%%DATADIR%%/hash/pcecd.xml
+%%DATADIR%%/hash/pcfx.xml
%%DATADIR%%/hash/pcw.xml
%%DATADIR%%/hash/pcw16.xml
%%DATADIR%%/hash/pecom_cass.xml
@@ -272,7 +369,10 @@ libexec/mess/unidasm
%%DATADIR%%/hash/pet_cass.xml
%%DATADIR%%/hash/pet_flop.xml
%%DATADIR%%/hash/pet_hdd.xml
+%%DATADIR%%/hash/pet_quik.xml
%%DATADIR%%/hash/pet_rom.xml
+%%DATADIR%%/hash/phc25_cass.xml
+%%DATADIR%%/hash/picno.xml
%%DATADIR%%/hash/pico.xml
%%DATADIR%%/hash/pippin.xml
%%DATADIR%%/hash/pippin_flop.xml
@@ -280,10 +380,19 @@ libexec/mess/unidasm
%%DATADIR%%/hash/plus4_cass.xml
%%DATADIR%%/hash/plus4_flop.xml
%%DATADIR%%/hash/pmd85_cass.xml
+%%DATADIR%%/hash/pockchalv2.xml
+%%DATADIR%%/hash/pockchalw.xml
+%%DATADIR%%/hash/pofo.xml
+%%DATADIR%%/hash/poisk1_flop.xml
%%DATADIR%%/hash/pokemini.xml
+%%DATADIR%%/hash/princ.xml
%%DATADIR%%/hash/pro128_cart.xml
+%%DATADIR%%/hash/pro128_cass.xml
+%%DATADIR%%/hash/pro128_flop.xml
+%%DATADIR%%/hash/pro128s_flop.xml
%%DATADIR%%/hash/prof180.xml
%%DATADIR%%/hash/prof80.xml
+%%DATADIR%%/hash/psi98.xml
%%DATADIR%%/hash/psion1.xml
%%DATADIR%%/hash/psion2.xml
%%DATADIR%%/hash/psx.xml
@@ -291,11 +400,14 @@ libexec/mess/unidasm
%%DATADIR%%/hash/pv1000.xml
%%DATADIR%%/hash/pv2000.xml
%%DATADIR%%/hash/px4_cart.xml
+%%DATADIR%%/hash/px8_cart.xml
%%DATADIR%%/hash/pyl601.xml
%%DATADIR%%/hash/ql_cart.xml
%%DATADIR%%/hash/ql_cass.xml
%%DATADIR%%/hash/ql_flop.xml
+%%DATADIR%%/hash/quizwiz.xml
%%DATADIR%%/hash/qx10_flop.xml
+%%DATADIR%%/hash/r9751.xml
%%DATADIR%%/hash/radio86_cart.xml
%%DATADIR%%/hash/radio86_cass.xml
%%DATADIR%%/hash/rainbow.xml
@@ -305,6 +417,7 @@ libexec/mess/unidasm
%%DATADIR%%/hash/samcoupe_cass.xml
%%DATADIR%%/hash/samcoupe_flop.xml
%%DATADIR%%/hash/sat_cart.xml
+%%DATADIR%%/hash/sat_vccart.xml
%%DATADIR%%/hash/saturn.xml
%%DATADIR%%/hash/sawatte.xml
%%DATADIR%%/hash/sc3000_cart.xml
@@ -314,12 +427,15 @@ libexec/mess/unidasm
%%DATADIR%%/hash/sf7000.xml
%%DATADIR%%/hash/sg1000.xml
%%DATADIR%%/hash/sgx.xml
+%%DATADIR%%/hash/sitcom.xml
%%DATADIR%%/hash/smc777.xml
+%%DATADIR%%/hash/smondial2.xml
%%DATADIR%%/hash/sms.xml
%%DATADIR%%/hash/snes.xml
%%DATADIR%%/hash/snes_bspack.xml
%%DATADIR%%/hash/snes_strom.xml
%%DATADIR%%/hash/snes_vkun.xml
+%%DATADIR%%/hash/snotec.xml
%%DATADIR%%/hash/snread.xml
%%DATADIR%%/hash/snspell.xml
%%DATADIR%%/hash/socrates.xml
@@ -330,6 +446,7 @@ libexec/mess/unidasm
%%DATADIR%%/hash/sorcerer_cass.xml
%%DATADIR%%/hash/sorcerer_flop.xml
%%DATADIR%%/hash/spc1000_cass.xml
+%%DATADIR%%/hash/spc1500_cass.xml
%%DATADIR%%/hash/special_cass.xml
%%DATADIR%%/hash/special_flop.xml
%%DATADIR%%/hash/specpls3_flop.xml
@@ -337,9 +454,11 @@ libexec/mess/unidasm
%%DATADIR%%/hash/spectrum_cass.xml
%%DATADIR%%/hash/st_cart.xml
%%DATADIR%%/hash/st_flop.xml
+%%DATADIR%%/hash/stepone_flop.xml
%%DATADIR%%/hash/studio2.xml
%%DATADIR%%/hash/stv.xml
%%DATADIR%%/hash/super6.xml
+%%DATADIR%%/hash/super80_cass.xml
%%DATADIR%%/hash/superpet_flop.xml
%%DATADIR%%/hash/supracan.xml
%%DATADIR%%/hash/sv8000.xml
@@ -348,25 +467,35 @@ libexec/mess/unidasm
%%DATADIR%%/hash/svi318_flop.xml
%%DATADIR%%/hash/svision.xml
%%DATADIR%%/hash/svmu.xml
+%%DATADIR%%/hash/t1000.xml
%%DATADIR%%/hash/tandy200.xml
%%DATADIR%%/hash/tandy2k.xml
%%DATADIR%%/hash/tandy6k.xml
+%%DATADIR%%/hash/tc4.xml
%%DATADIR%%/hash/tdv2324.xml
%%DATADIR%%/hash/tek4052_cart.xml
%%DATADIR%%/hash/tg16.xml
%%DATADIR%%/hash/ti74_cart.xml
+%%DATADIR%%/hash/ti95_cart.xml
%%DATADIR%%/hash/ti99_cart.xml
%%DATADIR%%/hash/tiki100.xml
%%DATADIR%%/hash/timex_dock.xml
%%DATADIR%%/hash/tntell.xml
%%DATADIR%%/hash/to770_cart.xml
+%%DATADIR%%/hash/to770a_cart.xml
%%DATADIR%%/hash/to7_cart.xml
+%%DATADIR%%/hash/to7_cass.xml
+%%DATADIR%%/hash/to7_qd.xml
+%%DATADIR%%/hash/to8_cass.xml
+%%DATADIR%%/hash/to8_qd.xml
+%%DATADIR%%/hash/to_flop.xml
%%DATADIR%%/hash/trs80m2.xml
%%DATADIR%%/hash/trsm100.xml
%%DATADIR%%/hash/tutor.xml
%%DATADIR%%/hash/tvc_cart.xml
%%DATADIR%%/hash/tvc_cass.xml
%%DATADIR%%/hash/tvc_flop.xml
+%%DATADIR%%/hash/unichamp.xml
%%DATADIR%%/hash/ut88.xml
%%DATADIR%%/hash/uzebox.xml
%%DATADIR%%/hash/v1050_flop.xml
@@ -374,6 +503,7 @@ libexec/mess/unidasm
%%DATADIR%%/hash/vboy.xml
%%DATADIR%%/hash/vc4000.xml
%%DATADIR%%/hash/vector06_cart.xml
+%%DATADIR%%/hash/vector06_flop.xml
%%DATADIR%%/hash/vectrex.xml
%%DATADIR%%/hash/vg5k.xml
%%DATADIR%%/hash/vic10.xml
@@ -389,8 +519,11 @@ libexec/mess/unidasm
%%DATADIR%%/hash/vreader.xml
%%DATADIR%%/hash/vsmile_cart.xml
%%DATADIR%%/hash/vsmile_cd.xml
+%%DATADIR%%/hash/vsmileb_cart.xml
+%%DATADIR%%/hash/vsmilem_cart.xml
%%DATADIR%%/hash/vz_cass.xml
%%DATADIR%%/hash/wangpc.xml
+%%DATADIR%%/hash/waveterm.xml
%%DATADIR%%/hash/wicat.xml
%%DATADIR%%/hash/wmbullet.xml
%%DATADIR%%/hash/wscolor.xml
@@ -403,9 +536,9 @@ libexec/mess/unidasm
%%DATADIR%%/hash/xegs.xml
%%DATADIR%%/hash/xerox820.xml
%%DATADIR%%/hash/xerox820ii.xml
-%%DATADIR%%/keymaps/km-be.txt
-%%DATADIR%%/keymaps/km-ch.txt
-%%DATADIR%%/keymaps/km-de.txt
-%%DATADIR%%/keymaps/km-fr-OSX.txt
-%%DATADIR%%/keymaps/km-fr.txt
-%%DATADIR%%/keymaps/km_it.txt
+%%DATADIR%%/hash/z80ne_cass.xml
+%%DATADIR%%/hash/z80ne_flop.xml
+%%DATADIR%%/hash/z88_cart.xml
+%%DATADIR%%/hash/zorba.xml
+%%DATADIR%%/hash/zx80_cass.xml
+%%DATADIR%%/hash/zx81_cass.xml