aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/e2fsprogs/Makefile21
-rw-r--r--sysutils/e2fsprogs/pkg-descr3
-rw-r--r--sysutils/e2fsprogs/pkg-plist2
4 files changed, 27 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 0e98641d3346..3f425b3abc91 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -325,6 +325,7 @@
SUBDIR += dwatch-gource
SUBDIR += dwatch-json
SUBDIR += dwatch-pwsnoop
+ SUBDIR += e2fsprogs
SUBDIR += e2fsprogs-core
SUBDIR += e2tools
SUBDIR += ebsnvme-id
diff --git a/sysutils/e2fsprogs/Makefile b/sysutils/e2fsprogs/Makefile
new file mode 100644
index 000000000000..a59f478893cd
--- /dev/null
+++ b/sysutils/e2fsprogs/Makefile
@@ -0,0 +1,21 @@
+PORTNAME= e2fsprogs
+CATEGORIES= sysutils
+PORTVERSION= 1.46.5
+PORTREVISION= 5
+BUILD_DEPENDS= e2fsprogs-core>=${PORTVERSION}:sysutils/e2fsprogs-core
+RUN_DEPENDS= ${BUILD_DEPENDS}
+DISTFILES= # empty
+NO_BUILD= yes
+LICENSE= GPLv2+
+USES= cpe
+CPE_VENDOR= e2fsprogs_project
+
+MAINTAINER= mandree@FreeBSD.org
+COMMENT= Wrapper to install e2fsprogs into /sbin
+
+do-install:
+ ${MKDIR} ${STAGEDIR}/sbin
+ ${CP} -p ${LOCALBASE}/sbin/fsck_ext2fs ${STAGEDIR}/sbin
+ ${CP} -p ${LOCALBASE}/sbin/e2fsck ${STAGEDIR}/sbin
+
+.include <bsd.port.mk>
diff --git a/sysutils/e2fsprogs/pkg-descr b/sysutils/e2fsprogs/pkg-descr
new file mode 100644
index 000000000000..6df887766576
--- /dev/null
+++ b/sysutils/e2fsprogs/pkg-descr
@@ -0,0 +1,3 @@
+This is a helper package that will copy and register the essential binaries
+from e2fsprogs-core to /sbin, so that it is possible to have /usr in an ext2,
+ext3, or ext4 file system, and still have a proper fsck in /sbin.
diff --git a/sysutils/e2fsprogs/pkg-plist b/sysutils/e2fsprogs/pkg-plist
new file mode 100644
index 000000000000..796b2c90dfc4
--- /dev/null
+++ b/sysutils/e2fsprogs/pkg-plist
@@ -0,0 +1,2 @@
+/sbin/e2fsck
+/sbin/fsck_ext2fs