aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/bib2html/Makefile10
-rw-r--r--textproc/igor/Makefile3
-rw-r--r--textproc/p5-Excel-Template/Makefile3
-rw-r--r--textproc/p5-Lingua-EN-Inflect-Phrase/Makefile3
-rw-r--r--textproc/p5-POD2-Base/Makefile9
-rw-r--r--textproc/p5-Regexp-Common-profanity_us/Makefile9
-rw-r--r--textproc/p5-Spreadsheet-Read/Makefile9
-rw-r--r--textproc/p5-Term-QRCode/Makefile9
-rw-r--r--textproc/p5-Text-Brew/Makefile8
-rw-r--r--textproc/p5-Text-Emoticon/Makefile9
-rw-r--r--textproc/p5-Text-MicroTemplate-Extended/Makefile3
-rw-r--r--textproc/p5-Text-SpellChecker/Makefile9
-rw-r--r--textproc/p5-Text-Xslate-Bridge-TT2Like/Makefile3
-rw-r--r--textproc/p5-Tk-XMLViewer/Makefile9
-rw-r--r--textproc/p5-XML-Entities/Makefile8
-rw-r--r--textproc/p5-XML-FeedPP/Makefile9
-rw-r--r--textproc/p5-XML-Generator/Makefile9
-rw-r--r--textproc/p5-XML-LibXML-SAX-ChunkParser/Makefile3
-rw-r--r--textproc/p5-YAML-Shell/Makefile9
19 files changed, 50 insertions, 84 deletions
diff --git a/textproc/bib2html/Makefile b/textproc/bib2html/Makefile
index 5f904fabecc3..3e13ce4e5f66 100644
--- a/textproc/bib2html/Makefile
+++ b/textproc/bib2html/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: bib2html
-# Date created: Jan 5, 2004
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= bib2html
DISTVERSION= 5.1-1
@@ -18,7 +13,8 @@ COMMENT= The BibTeX to HTML Translator
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:C/-[0-9]$//}/src
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
NO_BUILD= yes
post-patch:
diff --git a/textproc/igor/Makefile b/textproc/igor/Makefile
index 33f707a5c6cf..6a11bdff5f2f 100644
--- a/textproc/igor/Makefile
+++ b/textproc/igor/Makefile
@@ -10,7 +10,8 @@ COMMENT= FreeBSD Documentation Project sanity check script
LICENSE= BSD
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
NO_BUILD= yes
diff --git a/textproc/p5-Excel-Template/Makefile b/textproc/p5-Excel-Template/Makefile
index 9908c034a14e..30bc6c9ab678 100644
--- a/textproc/p5-Excel-Template/Makefile
+++ b/textproc/p5-Excel-Template/Makefile
@@ -17,7 +17,8 @@ BUILD_DEPENDS= p5-IO-stringy>=0:${PORTSDIR}/devel/p5-IO-stringy \
p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Excel::Template.3 \
Excel::Template::Base.3 \
diff --git a/textproc/p5-Lingua-EN-Inflect-Phrase/Makefile b/textproc/p5-Lingua-EN-Inflect-Phrase/Makefile
index 978aa6896c45..c6b7716f10c2 100644
--- a/textproc/p5-Lingua-EN-Inflect-Phrase/Makefile
+++ b/textproc/p5-Lingua-EN-Inflect-Phrase/Makefile
@@ -20,7 +20,8 @@ TEST_DEPENDS= \
p5-Lingua-EN-Number-IsOrdinal>0:${PORTSDIR}/textproc/p5-Lingua-EN-Number-IsOrdinal \
p5-Test-NoWarnings>=0:${PORTSDIR}/devel/p5-Test-NoWarnings
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Lingua::EN::Inflect::Phrase.3
diff --git a/textproc/p5-POD2-Base/Makefile b/textproc/p5-POD2-Base/Makefile
index cf66c2a36f66..543e1acccb76 100644
--- a/textproc/p5-POD2-Base/Makefile
+++ b/textproc/p5-POD2-Base/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-POD2-Base
-# Date created: 2010-05-25
-# Whom: Ashish SHUKLA <wahjava@gmail.com>
-#
+# Created by: Ashish SHUKLA <wahjava@gmail.com>
# $FreeBSD$
-#
PORTNAME= POD2-Base
PORTVERSION= 0.043
@@ -15,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ashish@FreeBSD.org
COMMENT= Base module for translations of Perl documentation
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= POD2::Base.3 \
POD2::PT::POD2::Base.3
diff --git a/textproc/p5-Regexp-Common-profanity_us/Makefile b/textproc/p5-Regexp-Common-profanity_us/Makefile
index 81f625196dcd..41970c0d7c60 100644
--- a/textproc/p5-Regexp-Common-profanity_us/Makefile
+++ b/textproc/p5-Regexp-Common-profanity_us/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Regexp-Common-profanity_us
-# Date created: 2006-07-11
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Regexp-Common-profanity_us
PORTVERSION= 4.112150
@@ -17,7 +13,8 @@ COMMENT= Provide regexes for U.S. profanity
BUILD_DEPENDS= p5-Regexp-Common>=0:${PORTSDIR}/textproc/p5-Regexp-Common
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Regexp::Common::profanity_us.3 \
Regexp::Profanity::US.3
diff --git a/textproc/p5-Spreadsheet-Read/Makefile b/textproc/p5-Spreadsheet-Read/Makefile
index 19dddc72933d..7df149a220c8 100644
--- a/textproc/p5-Spreadsheet-Read/Makefile
+++ b/textproc/p5-Spreadsheet-Read/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Spreadsheet-Read
-# Date created: 2010-03-08
-# Whom: Steve Wills <steve@mouf.net>
-#
+# Created by: Steve Wills <steve@mouf.net>
# $FreeBSD$
-#
PORTNAME= Spreadsheet-Read
PORTVERSION= 0.47
@@ -24,7 +20,8 @@ BUILD_DEPENDS= p5-IO-stringy>0:${PORTSDIR}/devel/p5-IO-stringy \
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-NoWarnings>0:${PORTSDIR}/devel/p5-Test-NoWarnings
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Spreadsheet::Read.3
diff --git a/textproc/p5-Term-QRCode/Makefile b/textproc/p5-Term-QRCode/Makefile
index 762cdbefb0bd..3694a3bda9e8 100644
--- a/textproc/p5-Term-QRCode/Makefile
+++ b/textproc/p5-Term-QRCode/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Term-QRCode
-# Date created: 2012/03/22
-# Whom: Stephon Chen <stephon@gmail.com>
-#
+# Created by: Stephon Chen <stephon@gmail.com>
# $FreeBSD$
-#
PORTNAME= Term-QRCode
PORTVERSION= 0.01
@@ -18,7 +14,8 @@ BUILD_DEPENDS= libqrencode>=2.0.0:${PORTSDIR}/graphics/libqrencode \
p5-Text-QRCode>0:${PORTSDIR}/textproc/p5-Text-QRCode
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Term::QRCode.3
diff --git a/textproc/p5-Text-Brew/Makefile b/textproc/p5-Text-Brew/Makefile
index f6e7efa705b8..0aa19dda937d 100644
--- a/textproc/p5-Text-Brew/Makefile
+++ b/textproc/p5-Text-Brew/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: Text::Brew
-# Date created: 22 Aug 2012
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= Text-Brew
PORTVERSION= 0.02
@@ -14,7 +9,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl extension for the Brew edit distance
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Text::Brew.3
diff --git a/textproc/p5-Text-Emoticon/Makefile b/textproc/p5-Text-Emoticon/Makefile
index 9e514ebc01a8..268146141d51 100644
--- a/textproc/p5-Text-Emoticon/Makefile
+++ b/textproc/p5-Text-Emoticon/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Text-Emoticon
-# Date created: 2006-07-11
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Text-Emoticon
PORTVERSION= 0.04
@@ -17,7 +13,8 @@ COMMENT= Factory class for Yahoo! and MSN emoticons
BUILD_DEPENDS= p5-UNIVERSAL-require>=0:${PORTSDIR}/devel/p5-UNIVERSAL-require
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Text::Emoticon.3
diff --git a/textproc/p5-Text-MicroTemplate-Extended/Makefile b/textproc/p5-Text-MicroTemplate-Extended/Makefile
index 1d27bfe67d91..47b4a3a82891 100644
--- a/textproc/p5-Text-MicroTemplate-Extended/Makefile
+++ b/textproc/p5-Text-MicroTemplate-Extended/Makefile
@@ -13,7 +13,8 @@ RUN_DEPENDS= \
p5-Text-MicroTemplate>=0.18:${PORTSDIR}/textproc/p5-Text-MicroTemplate
BUILD_DEPENDS= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Text::MicroTemplate::Extended.3 \
Text::MicroTemplate::Extended.ja.3
diff --git a/textproc/p5-Text-SpellChecker/Makefile b/textproc/p5-Text-SpellChecker/Makefile
index 494434b48aab..e3471267b903 100644
--- a/textproc/p5-Text-SpellChecker/Makefile
+++ b/textproc/p5-Text-SpellChecker/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Text-SpellsChecker
-# Date created: 23 Nov 2008
-# Whom: Martin Wilke <miwi@FreeBSD.org>
-#
+# Created by: Martin Wilke <miwi@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Text-SpellChecker
PORTVERSION= 0.11
@@ -16,7 +12,8 @@ COMMENT= Perl5 OO interface for spell-checking a block of text
RUN_DEPENDS= p5-Text-Aspell>=0:${PORTSDIR}/textproc/p5-Text-Aspell
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Text::SpellChecker.3
diff --git a/textproc/p5-Text-Xslate-Bridge-TT2Like/Makefile b/textproc/p5-Text-Xslate-Bridge-TT2Like/Makefile
index 1a69321d4640..d91a8304dd27 100644
--- a/textproc/p5-Text-Xslate-Bridge-TT2Like/Makefile
+++ b/textproc/p5-Text-Xslate-Bridge-TT2Like/Makefile
@@ -13,7 +13,8 @@ RUN_DEPENDS= \
p5-Text-Xslate>=1.3000:${PORTSDIR}/textproc/p5-Text-Xslate
BUILD_DEPENDS= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Text::Xslate::Bridge::TT2Like.3
diff --git a/textproc/p5-Tk-XMLViewer/Makefile b/textproc/p5-Tk-XMLViewer/Makefile
index 2254554fd168..d79da934ac30 100644
--- a/textproc/p5-Tk-XMLViewer/Makefile
+++ b/textproc/p5-Tk-XMLViewer/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Tk-XMLViewer
-# Date created: May 28 2001
-# Whom: vanilla
-#
+# Created by: vanilla
# $FreeBSD$
-#
PORTNAME= Tk-XMLViewer
PORTVERSION= 0.21
@@ -19,7 +15,8 @@ BUILD_DEPENDS= p5-Tk>=0:${PORTSDIR}/x11-toolkits/p5-Tk \
p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Tk::XMLViewer.3
MAN1= tkxmlview.1
diff --git a/textproc/p5-XML-Entities/Makefile b/textproc/p5-XML-Entities/Makefile
index 804a114fb12d..0a3e306cf92d 100644
--- a/textproc/p5-XML-Entities/Makefile
+++ b/textproc/p5-XML-Entities/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: p5-XML-Entities
-# Date created: 2010-10-1
-# Whom: Tom Judge <tom@tomjudge.com>
-#
+# Created by: Tom Judge <tom@tomjudge.com>
# $FreeBSD$
PORTNAME= XML-Entities
@@ -17,7 +14,8 @@ BUILD_DEPENDS= p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
WRKSRC= ${WRKDIR}/${PORTNAME}
MAN3= XML::Entities.3pm XML::Entities::Data.3pm download-entities.pl.3pm
diff --git a/textproc/p5-XML-FeedPP/Makefile b/textproc/p5-XML-FeedPP/Makefile
index ebf4472a98ac..31efb7b3c819 100644
--- a/textproc/p5-XML-FeedPP/Makefile
+++ b/textproc/p5-XML-FeedPP/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: XML-FeedPP
-# Date created: 29 May 2008
-# Whom: Oleg Mamontov <oleg@mamontov.net>
-#
+# Created by: Oleg Mamontov <oleg@mamontov.net>
# $FreeBSD$
-#
PORTNAME= XML-FeedPP
PORTVERSION= 0.43
@@ -20,7 +16,8 @@ LICENSE_COMB= dual
BUILD_DEPENDS= p5-XML-TreePP>=0.39:${PORTSDIR}/textproc/p5-XML-TreePP
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= XML::FeedPP.3
diff --git a/textproc/p5-XML-Generator/Makefile b/textproc/p5-XML-Generator/Makefile
index 1b54e6d65bcb..3b25cfb0fb24 100644
--- a/textproc/p5-XML-Generator/Makefile
+++ b/textproc/p5-XML-Generator/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: XML::Generator
-# Date created: 22 January 2004
-# Whom: Andreas Heil <ah@linux-hq.de>
-#
+# Created by: Andreas Heil <ah@linux-hq.de>
# $FreeBSD$
-#
PORTNAME= XML-Generator
PORTVERSION= 1.04
@@ -19,7 +15,8 @@ RUN_DEPENDS= p5-XML-DOM>=0:${PORTSDIR}/textproc/p5-XML-DOM
TEST_DEPENDS= p5-Tie-IxHash>=0:${PORTSDIR}/devel/p5-Tie-IxHash
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= XML::Generator.3 XML::Generator::DOM.3
diff --git a/textproc/p5-XML-LibXML-SAX-ChunkParser/Makefile b/textproc/p5-XML-LibXML-SAX-ChunkParser/Makefile
index e9c2f82dedc3..fbeb1b00d73f 100644
--- a/textproc/p5-XML-LibXML-SAX-ChunkParser/Makefile
+++ b/textproc/p5-XML-LibXML-SAX-ChunkParser/Makefile
@@ -17,7 +17,8 @@ BUILD_DEPENDS= p5-XML-LibXML>=1.66:${PORTSDIR}/textproc/p5-XML-LibXML \
p5-XML-SAX>=0:${PORTSDIR}/textproc/p5-XML-SAX
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= XML::LibXML::SAX::ChunkParser.3
diff --git a/textproc/p5-YAML-Shell/Makefile b/textproc/p5-YAML-Shell/Makefile
index ebd7a6acc182..45b4f061b545 100644
--- a/textproc/p5-YAML-Shell/Makefile
+++ b/textproc/p5-YAML-Shell/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-YAML-Shell
-# Date created: 2011-05-24
-# Whom: Steve Wills <swills@FreeBSD.org>
-#
+# Created by: Steve Wills <swills@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= YAML-Shell
PORTVERSION= 0.60
@@ -18,7 +14,8 @@ COMMENT= The YAML Test Shell
BUILD_DEPENDS= p5-YAML>=0.67:${PORTSDIR}/textproc/p5-YAML
RUN_DEPENDS= p5-YAML>=0.67:${PORTSDIR}/textproc/p5-YAML
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= ysh.1
MAN3= YAML::Shell.3