aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--converters/Makefile1
-rw-r--r--converters/py-webencodings/Makefile18
-rw-r--r--converters/py-webencodings/distinfo3
-rw-r--r--converters/py-webencodings/pkg-descr16
4 files changed, 38 insertions, 0 deletions
diff --git a/converters/Makefile b/converters/Makefile
index cbd5a13eb105..9d44a8666335 100644
--- a/converters/Makefile
+++ b/converters/Makefile
@@ -159,6 +159,7 @@
SUBDIR += py-iconv
SUBDIR += py-rencode
SUBDIR += py-unidecode
+ SUBDIR += py-webencodings
SUBDIR += py-zfec
SUBDIR += rcctools
SUBDIR += recode
diff --git a/converters/py-webencodings/Makefile b/converters/py-webencodings/Makefile
new file mode 100644
index 000000000000..4b0df133bb1d
--- /dev/null
+++ b/converters/py-webencodings/Makefile
@@ -0,0 +1,18 @@
+# $FreeBSD$
+
+PORTNAME= webencodings
+DISTVERSION= 0.5.1
+CATEGORIES= converters www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= saper@saper.info
+COMMENT= Character encoding aliases for legacy web content
+
+LICENSE= BSD3CLAUSE
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/converters/py-webencodings/distinfo b/converters/py-webencodings/distinfo
new file mode 100644
index 000000000000..ce2189be6c2a
--- /dev/null
+++ b/converters/py-webencodings/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1520037325
+SHA256 (webencodings-0.5.1.tar.gz) = b36a1c245f2d304965eb4e0a82848379241dc04b865afcc4aab16748587e1923
+SIZE (webencodings-0.5.1.tar.gz) = 9721
diff --git a/converters/py-webencodings/pkg-descr b/converters/py-webencodings/pkg-descr
new file mode 100644
index 000000000000..3785abf21126
--- /dev/null
+++ b/converters/py-webencodings/pkg-descr
@@ -0,0 +1,16 @@
+In order to be compatible with legacy web content when interpreting
+something like Content-Type: text/html; charset=latin1, tools need
+to use a particular set of aliases for encoding labels as well as
+some overriding rules.
+
+For example, US-ASCII and iso-8859-1 on the web are actually aliases for
+windows-1252, and an UTF-8 or UTF-16 BOM takes precedence over any other
+encoding declaration.
+
+The Encoding standard defines all such details so that implementations
+do not have to reverse-engineer each other.
+
+This module has encoding labels and BOM detection, but the actual
+implementation for encoders and decoders is Python's.
+
+WWW: https://github.com/SimonSapin/python-webencodings