aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES3
-rw-r--r--Mk/bsd.sites.mk4
2 files changed, 6 insertions, 1 deletions
diff --git a/CHANGES b/CHANGES
index d19afa295b76..bdb63f5b0d63 100644
--- a/CHANGES
+++ b/CHANGES
@@ -19,6 +19,9 @@ All ports committers are allowed to commit to this file.
that has a different checksum than before due to a changed directory name
for extraction.
+ GH_TAGNAME can now be any length of the hash as long as it is unique. There
+ is no longer a 7-character requirement.
+
The following MASTER_SITES are provided to retain the old checksum and
directory structure (that require GH_COMMIT):
GH -> GHL
diff --git a/Mk/bsd.sites.mk b/Mk/bsd.sites.mk
index 22044a90618c..e945ae958da9 100644
--- a/Mk/bsd.sites.mk
+++ b/Mk/bsd.sites.mk
@@ -519,13 +519,15 @@ MASTER_SITE_GENTOO+= \
#
# GH_TAGNAME - name of the tag to download (2.0.1, hash, ...)
# Using the name of a branch here is incorrect. It is
-# possible to do GH_TAGNAME=${GH_COMMIT} to do a snapshot
+# possible to do GH_TAGNAME= GIT_HASH to do a snapshot.
# default: ${DISTVERSION}
#
# GH_COMMIT - first 7 digits of the commit that generated GH_TAGNAME
# (man git-describe(1))
# if this is not set, archive corresponding to tag is fetched
# default: not set
+# This is a deprecated option. Just set the hash in GH_TAGNAME
+# instead.
#
.if defined(USE_GITHUB)
. if defined(GH_TAGNAME) && ${GH_TAGNAME} == master