aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ftp/Makefile1
-rw-r--r--ftp/weex/Makefile39
-rw-r--r--ftp/weex/distinfo2
-rw-r--r--ftp/weex/pkg-descr14
-rw-r--r--ftp/weex/pkg-plist8
5 files changed, 64 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index d3e6a62625b4..3bb75d73905c 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -95,6 +95,7 @@
SUBDIR += urlgfe
SUBDIR += vcheck
SUBDIR += vsftpd
+ SUBDIR += weex
SUBDIR += wget
SUBDIR += wgetpro
SUBDIR += wmget
diff --git a/ftp/weex/Makefile b/ftp/weex/Makefile
new file mode 100644
index 000000000000..9acb3f3acc47
--- /dev/null
+++ b/ftp/weex/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: weex
+# Date created: 8 Sep 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= weex
+PORTVERSION= 2.6.1.5
+CATEGORIES= ftp
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A non-interactive FTP client
+
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+MANCOMPRESSED= no
+
+PORTDOCS= ChangeLog README
+MAN1= weex.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^\(SUBDIRS.*\)debian|\1|' \
+ ${WRKSRC}/Makefile.in
+
+post-install:
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/sample.weexrc ${EXAMPLESDIR}
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/ftp/weex/distinfo b/ftp/weex/distinfo
new file mode 100644
index 000000000000..8491ebe42846
--- /dev/null
+++ b/ftp/weex/distinfo
@@ -0,0 +1,2 @@
+MD5 (weex-2.6.1.5.tar.gz) = c10192608ab9f715c4c1ea63cf6ad2da
+SIZE (weex-2.6.1.5.tar.gz) = 206972
diff --git a/ftp/weex/pkg-descr b/ftp/weex/pkg-descr
new file mode 100644
index 000000000000..102e1be09682
--- /dev/null
+++ b/ftp/weex/pkg-descr
@@ -0,0 +1,14 @@
+Weex is an utility designed to automate the task of remotely maintaining a web
+page or other FTP archive. It will synchronize a set of local files to a remote
+server by performing uploads and remote deletes as required.
+
+Main features:
+
+ * easy configuration to easily maintain your remote Web sites
+ * nice colour output useful for tracking mistakes before you loose files
+ * caching to speed up the synchronization process
+
+WWW: http://weex.sourceforge.net/
+
+- ehaupt
+ehaupt@critical.ch
diff --git a/ftp/weex/pkg-plist b/ftp/weex/pkg-plist
new file mode 100644
index 000000000000..b766a1b72fe5
--- /dev/null
+++ b/ftp/weex/pkg-plist
@@ -0,0 +1,8 @@
+bin/weex
+share/locale/de/LC_MESSAGES/weex.mo
+share/locale/es/LC_MESSAGES/weex.mo
+share/locale/fr/LC_MESSAGES/weex.mo
+share/locale/ja/LC_MESSAGES/weex.mo
+share/locale/nl/LC_MESSAGES/weex.mo
+%%EXAMPLESDIR%%/sample.weexrc
+@dirrm %%EXAMPLESDIR%%