aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/py-paramiko/Makefile4
-rw-r--r--security/py-paramiko/distinfo5
-rw-r--r--security/py-paramiko/files/patch-setup.py23
3 files changed, 5 insertions, 27 deletions
diff --git a/security/py-paramiko/Makefile b/security/py-paramiko/Makefile
index 33162ddf1c1f..51f263a2218a 100644
--- a/security/py-paramiko/Makefile
+++ b/security/py-paramiko/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= paramiko
-PORTVERSION= 1.15.2
+PORTVERSION= 2.0.0
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,7 +12,7 @@ COMMENT= Python SSH2 protocol library
LICENSE= GPLv2
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycrypto>0:security/py-pycrypto \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>0:security/py-cryptography \
${PYTHON_PKGNAMEPREFIX}ecdsa>0:security/py-ecdsa
USES= python
diff --git a/security/py-paramiko/distinfo b/security/py-paramiko/distinfo
index 80f5bc690d2b..4b13f4d82c53 100644
--- a/security/py-paramiko/distinfo
+++ b/security/py-paramiko/distinfo
@@ -1,2 +1,3 @@
-SHA256 (paramiko-1.15.2.tar.gz) = 4f56a671a3eecbb76e6143e6e4ca007d503a39aa79aa9e14ade667fa53fd6e55
-SIZE (paramiko-1.15.2.tar.gz) = 1220578
+TIMESTAMP = 1464139163
+SHA256 (paramiko-2.0.0.tar.gz) = 51219ecaf88aa1cea9952b3c4ddcc0c1316f015d23d77edb7aee78a3468ef0e2
+SIZE (paramiko-2.0.0.tar.gz) = 1372885
diff --git a/security/py-paramiko/files/patch-setup.py b/security/py-paramiko/files/patch-setup.py
deleted file mode 100644
index 342da8999a25..000000000000
--- a/security/py-paramiko/files/patch-setup.py
+++ /dev/null
@@ -1,23 +0,0 @@
---- setup.py.orig 2014-12-19 23:01:22 UTC
-+++ setup.py
-@@ -37,17 +37,9 @@ To install the `in-development version
- #ez_setup.use_setuptools()
-
- import sys
--try:
-- from setuptools import setup
-- kw = {
-- 'install_requires': [
-- 'pycrypto >= 2.1, != 2.4',
-- 'ecdsa >= 0.11',
-- ],
-- }
--except ImportError:
-- from distutils.core import setup
-- kw = {}
-+
-+from distutils.core import setup
-+kw = {}
-
- if sys.platform == 'darwin':
- import setup_helper