aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.port.mk4
-rw-r--r--Mk/bsd.sanity.mk4
-rw-r--r--Mk/bsd.sdl.mk31
-rw-r--r--audio/adplay/Makefile1
-rw-r--r--devel/pwlib/Makefile1
-rw-r--r--games/noegnud-littlehack/Makefile7
-rw-r--r--games/noegnud-nethack-deet/Makefile7
-rw-r--r--games/noegnud-nethack/Makefile7
-rw-r--r--games/noegnud-slashem/Makefile7
-rw-r--r--games/quake2lnx/Makefile1
-rw-r--r--games/quakeforge/Makefile1
-rw-r--r--graphics/gnash/Makefile1
-rw-r--r--multimedia/audacious-plugins/Makefile1
-rw-r--r--multimedia/avidemux/Makefile.common1
-rw-r--r--multimedia/ffmpeg0/Makefile1
-rw-r--r--multimedia/mplayer/Makefile.common1
-rw-r--r--multimedia/transcode/Makefile1
17 files changed, 10 insertions, 67 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index a674863197c2..9068aa560cf6 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1445,7 +1445,7 @@ PKGCOMPATDIR?= ${LOCALBASE}/lib/compat/pkg
.include "${PORTSDIR}/Mk/bsd.gstreamer.mk"
.endif
-.if defined(USE_SDL) || defined(WANT_SDL)
+.if defined(USE_SDL)
.include "${PORTSDIR}/Mk/bsd.sdl.mk"
.endif
@@ -1916,7 +1916,7 @@ _FORCE_POST_PATTERNS= rmdir kldxref mkfontscale mkfontdir fc-cache \
.include "${PORTSDIR}/Mk/bsd.qt.mk"
.endif
-.if defined(USE_SDL) || defined(WANT_SDL)
+.if defined(USE_SDL)
.include "${PORTSDIR}/Mk/bsd.sdl.mk"
.endif
diff --git a/Mk/bsd.sanity.mk b/Mk/bsd.sanity.mk
index 3a36bf6154fd..fa5e543183f6 100644
--- a/Mk/bsd.sanity.mk
+++ b/Mk/bsd.sanity.mk
@@ -153,6 +153,10 @@ DEV_WARNING+= "PYDISTUTILS_INSTALLNOSINGLE is deprecated, please do not use it a
DEV_ERROR+= "INSTALLS_EGGINFO is no longer supported, please add the entry directly to the plist"
.endif
+.if defined(WANT_SDL)
+DEV_ERROR+= "WANT_SDL is no longer supported. If you need SDL, use USE_SDL, if you need optional dependency, use options"
+.endif
+
SANITY_UNSUPPORTED= USE_OPENAL USE_FAM USE_MAKESELF USE_ZIP USE_LHA USE_CMAKE \
USE_READLINE USE_ICONV PERL_CONFIGURE PERL_MODBUILD \
USE_PERL5_BUILD USE_PERL5_RUN USE_DISPLAY USE_FUSE \
diff --git a/Mk/bsd.sdl.mk b/Mk/bsd.sdl.mk
index de3bdfb11a63..4e93b8303c5f 100644
--- a/Mk/bsd.sdl.mk
+++ b/Mk/bsd.sdl.mk
@@ -16,17 +16,6 @@
# the standard SDL and SDL_sound, use "USE_SDL=sdl sound" and the
# required libraries are included in your LIB_DEPENDS.
#
-# If you want to check for the availability for certain SDL ports, you
-# can set WANT_SDL and run it through bsd.port.pre.mk:
-# WANT_SDL= yes
-# USE_SDL= sdl
-# .include <bsd.port.pre.mk>
-# .if ${HAVE_SDL:Mgraphics}
-# USE_SDL+= graphics
-# .endif
-# .include <bsd.port.post.mk>
-# Run "make -V USE_SDL" to see which libs are asked for at the end.
-#
#
# $FreeBSD$
@@ -132,26 +121,6 @@ _LIB_ttf2= libSDL2_ttf.so
_REQUIRES_ttf2= sdl2
#
-# If WANT_SDL is defined, check for the available libraries
-#
-.if !defined(AFTERPORTMK)
-.if !defined(SDL_Include_pre)
-
-SDL_Include_pre= bsd.sdl.mk
-
-HAVE_SDL?=
-.if defined(WANT_SDL)
-.for component in ${_USE_SDL_ALL}
-.if exists(${LOCALBASE}/lib/lib${_LIB_${component}}.so)
-HAVE_SDL+= ${component}
-.endif
-.endfor
-.endif
-
-.endif
-.endif
-
-#
# If USE_SDL is defined, make dependencies for the libraries
#
.if !defined(BEFOREPORTMK)
diff --git a/audio/adplay/Makefile b/audio/adplay/Makefile
index 23aa52be3588..e89bd57aa73c 100644
--- a/audio/adplay/Makefile
+++ b/audio/adplay/Makefile
@@ -20,7 +20,6 @@ LIB_DEPENDS= libadplug.so:${PORTSDIR}/audio/libadplug \
GNU_CONFIGURE= yes
USES= libtool
-WANT_SDL= yes
DBFILE= adplug.db
DBVERSION= 2006-07-07
diff --git a/devel/pwlib/Makefile b/devel/pwlib/Makefile
index f1e595bb0fe6..fccfbe1e4720 100644
--- a/devel/pwlib/Makefile
+++ b/devel/pwlib/Makefile
@@ -23,7 +23,6 @@ USES= bison gmake
USE_GCC= any
USE_AUTOTOOLS= autoconf
WANT_GNOME= yes
-WANT_SDL= yes
USE_OPENSSL= yes
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE= yes
diff --git a/games/noegnud-littlehack/Makefile b/games/noegnud-littlehack/Makefile
index ae8f29d1a682..204208a1aac4 100644
--- a/games/noegnud-littlehack/Makefile
+++ b/games/noegnud-littlehack/Makefile
@@ -22,7 +22,6 @@ RUN_DEPENDS= noegnud-data>0:${PORTSDIR}/games/noegnud-data
NOEGNUDVERSION= ${PORTNAME}-0.8.0
USES= bison tar:bzip2
USE_GL= yes
-WANT_SDL= yes
USE_SDL= sdl image mixer
WRKSRC= ${WRKDIR}/${DISTNAME}/variants
PATCH_WRKSRC= ${WRKDIR}/${DISTNAME}
@@ -30,14 +29,10 @@ ALL_TARGET= lh001
INSTALL_TARGET= install_lh001
MAKE_JOBS_UNSAFE= yes
-.include <bsd.port.pre.mk>
-
pre-everything::
-.if ${HAVE_SDL}
@${ECHO_MSG} "This port depends on SDL with OpenGL support."
@${ECHO_MSG} "If your SDL does not support OpenGL, hit ^C now and reinstall SDL"
@${ECHO_MSG} "with OpenGL support turned on."
-.endif
post-extract:
@${CP} ${DISTDIR}/nethack-342.tgz ${WRKSRC}/tarballs
@@ -54,4 +49,4 @@ post-patch:
do-configure:
(cd ${WRKSRC} && ${MAKE} ${NOEGNUDVERSION}-littlehack-0.0.1/Makefile)
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/noegnud-nethack-deet/Makefile b/games/noegnud-nethack-deet/Makefile
index 0f4160257cfa..42420644e47b 100644
--- a/games/noegnud-nethack-deet/Makefile
+++ b/games/noegnud-nethack-deet/Makefile
@@ -22,7 +22,6 @@ RUN_DEPENDS= noegnud-data>0:${PORTSDIR}/games/noegnud-data
NOEGNUDVERSION= ${PORTNAME}-0.8.0
USES= bison tar:bzip2
USE_GL= yes
-WANT_SDL= yes
USE_SDL= sdl image mixer
WRKSRC= ${WRKDIR}/${DISTNAME}/variants
PATCH_WRKSRC= ${WRKDIR}/${DISTNAME}
@@ -30,14 +29,10 @@ ALL_TARGET= nh342-dt
INSTALL_TARGET= install_nh342-dt
MAKE_JOBS_UNSAFE= yes
-.include <bsd.port.pre.mk>
-
pre-everything::
-.if ${HAVE_SDL}
@${ECHO_MSG} "This port depends on SDL with OpenGL support."
@${ECHO_MSG} "If your SDL does not support OpenGL, hit ^C now and reinstall SDL"
@${ECHO_MSG} "with OpenGL support turned on."
-.endif
post-extract:
@${CP} ${DISTDIR}/nethack-342.tgz ${WRKSRC}/tarballs
@@ -55,4 +50,4 @@ post-patch:
do-configure:
(cd ${WRKSRC} && ${MAKE} ${NOEGNUDVERSION}-nethack-3.4.2-deet/Makefile)
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/noegnud-nethack/Makefile b/games/noegnud-nethack/Makefile
index 0b52647d4dc1..79f4ec8ca46b 100644
--- a/games/noegnud-nethack/Makefile
+++ b/games/noegnud-nethack/Makefile
@@ -22,7 +22,6 @@ RUN_DEPENDS= noegnud-data>0:${PORTSDIR}/games/noegnud-data
NOEGNUDVERSION= ${PORTNAME}-0.8.0
USES= bison gmake tar:bzip2
USE_GL= yes
-WANT_SDL= yes
USE_SDL= sdl image mixer
WRKSRC= ${WRKDIR}/${DISTNAME}/variants
PATCH_WRKSRC= ${WRKDIR}/${DISTNAME}
@@ -30,14 +29,10 @@ ALL_TARGET= nh343
INSTALL_TARGET= install_nh343
MAKE_JOBS_UNSAFE= yes
-.include <bsd.port.pre.mk>
-
pre-everything::
-.if ${HAVE_SDL}
@${ECHO_MSG} "This port depends on SDL with OpenGL support."
@${ECHO_MSG} "If your SDL does not support OpenGL, hit ^C now and reinstall SDL"
@${ECHO_MSG} "with OpenGL support turned on."
-.endif
post-extract:
@${CP} ${DISTDIR}/nethack-343-src.tgz ${WRKSRC}/tarballs
@@ -56,4 +51,4 @@ post-patch:
do-configure:
(cd ${WRKSRC} && ${MAKE} ${NOEGNUDVERSION}-nethack-3.4.3/Makefile)
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/noegnud-slashem/Makefile b/games/noegnud-slashem/Makefile
index 57c731520378..ac6975121ade 100644
--- a/games/noegnud-slashem/Makefile
+++ b/games/noegnud-slashem/Makefile
@@ -22,7 +22,6 @@ RUN_DEPENDS= noegnud-data>0:${PORTSDIR}/games/noegnud-data
NOEGNUDVERSION= ${PORTNAME}-0.8.0
USES= bison gmake tar:bzip2
USE_GL= yes
-WANT_SDL= yes
USE_SDL= sdl image mixer
WRKSRC= ${WRKDIR}/${DISTNAME}/variants
PATCH_WRKSRC= ${WRKDIR}/${DISTNAME}
@@ -30,14 +29,10 @@ ALL_TARGET= se006e4f8
INSTALL_TARGET= install_se006e4f8
MAKE_JOBS_UNSAFE= yes
-.include <bsd.port.pre.mk>
-
pre-everything::
-.if ${HAVE_SDL}
@${ECHO_MSG} "This port depends on SDL with OpenGL support."
@${ECHO_MSG} "If your SDL does not support OpenGL, hit ^C now and reinstall SDL"
@${ECHO_MSG} "with OpenGL support turned on."
-.endif
post-extract:
@${CP} ${DISTDIR}/se006e4f8.tar.gz ${WRKSRC}/tarballs
@@ -57,4 +52,4 @@ post-patch:
do-configure:
(cd ${WRKSRC} && ${MAKE} ${NOEGNUDVERSION}-slashem-0.0.6E4F8/Makefile)
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/quake2lnx/Makefile b/games/quake2lnx/Makefile
index 6ce9329a902b..8e99d6c08d17 100644
--- a/games/quake2lnx/Makefile
+++ b/games/quake2lnx/Makefile
@@ -17,7 +17,6 @@ COMMENT= Icculus.org version of the original Quake II
LICENSE= GPLv2
USES= gmake
-WANT_SDL= yes
ALL_TARGET= build_release
LIBDIR= ${PREFIX}/lib/${PORTNAME}
diff --git a/games/quakeforge/Makefile b/games/quakeforge/Makefile
index 30862da52caa..9c24db686223 100644
--- a/games/quakeforge/Makefile
+++ b/games/quakeforge/Makefile
@@ -22,7 +22,6 @@ GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USES= bison compiler:nestedfct gmake libtool tar:bzip2
USE_LDCONFIG= yes
-WANT_SDL= yes
CONFIGURE_ARGS+=--with-global-cfg=${PREFIX}/etc/quakeforge.conf \
--with-sharepath=${DATADIR} \
diff --git a/graphics/gnash/Makefile b/graphics/gnash/Makefile
index 75fb44820dfc..09993afe7f1d 100644
--- a/graphics/gnash/Makefile
+++ b/graphics/gnash/Makefile
@@ -21,7 +21,6 @@ CONFLICTS= gnash-devel-[0-9]*
USES= cpe gmake jpeg libtool pkgconfig tar:bzip2
GNU_CONFIGURE= yes
-WANT_SDL= yes
USE_GCC= any
WANT_GSTREAMER= yes
USE_GNOME= libxml2
diff --git a/multimedia/audacious-plugins/Makefile b/multimedia/audacious-plugins/Makefile
index af8519abdaae..72828ca52921 100644
--- a/multimedia/audacious-plugins/Makefile
+++ b/multimedia/audacious-plugins/Makefile
@@ -20,7 +20,6 @@ USE_LDCONFIG= yes
LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS+= -I${LOCALBASE}/include
USE_GNOME= glib20
-WANT_SDL= yes
OPTIONS_DEFINE= DBUS OSS4 SDLOUT ALSA CUE MP3 STATUSICON AOSD AOSDXCOMP \
ADPLUG VORBIS FLAC WAVPACK AAC SNDFILE MODPLUG JACK \
diff --git a/multimedia/avidemux/Makefile.common b/multimedia/avidemux/Makefile.common
index 2055ea79a95a..b3f8f1ad3678 100644
--- a/multimedia/avidemux/Makefile.common
+++ b/multimedia/avidemux/Makefile.common
@@ -19,7 +19,6 @@ USE_QT4= # empty
OPTIONS_FILE= ${PORT_DBDIR}/${OPTIONS_NAME:C/-.*//}/options
USE_SQLITE= yes
-WANT_SDL= yes
USES= cmake:outsource pkgconfig iconv gmake compiler:features
USES+= dos2unix
DOS2UNIX_FILES= cmake/admCheckMiscLibs.cmake po/CMakeLists.txt
diff --git a/multimedia/ffmpeg0/Makefile b/multimedia/ffmpeg0/Makefile
index 1fa537bc84af..dc5317e3f963 100644
--- a/multimedia/ffmpeg0/Makefile
+++ b/multimedia/ffmpeg0/Makefile
@@ -25,7 +25,6 @@ PORTSCOUT= limit:^0\.7.*
USES= cpe gmake perl5 pkgconfig tar:bzip2
USE_LDCONFIG= ${PREFIX}/lib/ffmpeg${FFMPEG_SUFFIX}
USE_PERL5= build
-WANT_SDL= yes
FFMPEG_SUFFIX= 0
HAS_CONFIGURE= yes
diff --git a/multimedia/mplayer/Makefile.common b/multimedia/mplayer/Makefile.common
index 00bb5b10fe5b..942f9edf75a9 100644
--- a/multimedia/mplayer/Makefile.common
+++ b/multimedia/mplayer/Makefile.common
@@ -51,4 +51,3 @@ CONFIGURE_ARGS= --cc="${CC}" \
--enable-ass-internal
WANT_GNOME= yes
-WANT_SDL= yes
diff --git a/multimedia/transcode/Makefile b/multimedia/transcode/Makefile
index 38a44fa337a7..9fc934cc3d24 100644
--- a/multimedia/transcode/Makefile
+++ b/multimedia/transcode/Makefile
@@ -17,7 +17,6 @@ LIB_DEPENDS= libavcodec.so:${PORTSDIR}/multimedia/ffmpeg
USE_LDCONFIG= yes
USES= gmake libtool pkgconfig tar:bzip2
USE_GCC= any
-WANT_SDL= yes
WANT_GNOME= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-oss