aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/pinentry-gnome3/Makefile12
-rw-r--r--security/pinentry/Makefile17
3 files changed, 27 insertions, 3 deletions
diff --git a/security/Makefile b/security/Makefile
index 96036ae8103b..7693f86f960b 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -743,6 +743,7 @@
SUBDIR += pidgin-otr
SUBDIR += pinentry
SUBDIR += pinentry-curses
+ SUBDIR += pinentry-gnome3
SUBDIR += pinentry-gtk2
SUBDIR += pinentry-qt4
SUBDIR += pinentry-tty
diff --git a/security/pinentry-gnome3/Makefile b/security/pinentry-gnome3/Makefile
new file mode 100644
index 000000000000..c3bfd1b6eaf3
--- /dev/null
+++ b/security/pinentry-gnome3/Makefile
@@ -0,0 +1,12 @@
+# $FreeBSD$
+
+PORTNAME= pinentry
+PORTREVISION= 0
+
+COMMENT= GNOME 3 version of the GnuPG password dialog
+
+PINENTRY_GUI= gnome3
+
+MASTERDIR= ${.CURDIR}/../pinentry
+
+.include "${MASTERDIR}/Makefile"
diff --git a/security/pinentry/Makefile b/security/pinentry/Makefile
index f3ba8351ab17..e35e22d6c068 100644
--- a/security/pinentry/Makefile
+++ b/security/pinentry/Makefile
@@ -19,7 +19,7 @@ NO_BUILD= yes
PLIST_FILES= bin/pinentry
OPTIONS_SINGLE= FRONTEND
-OPTIONS_SINGLE_FRONTEND= TTY NCURSES GTK2 QT4
+OPTIONS_SINGLE_FRONTEND= TTY NCURSES GTK2 QT4 GNOME3
OPTIONS_DEFAULT= TTY
FRONTEND_DESC= Default frontend
@@ -44,6 +44,10 @@ QT4_DESC= Qt 4 frontend
PINENTRY_QT4= pinentry-qt4
QT4_RUN_DEPENDS= ${PINENTRY_QT4}:${PORTSDIR}/security/pinentry-qt4
+GNOME3_DESC= GNOME 3 frontend
+PINENTRY_GNOME3= pinentry-gnome3
+GNOME3_RUN_DEPENDS= ${PINENTRY_GNOME3}:${PORTSDIR}/security/pinentry-gnome3
+
.include <bsd.port.options.mk>
.for gui in ${OPTIONS_SINGLE_FRONTEND}
@@ -64,8 +68,7 @@ LIB_DEPENDS= libassuan.so:${PORTSDIR}/security/libassuan \
USES+= iconv gmake pkgconfig
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-pinentry-emacs \
- --disable-pinentry-gnome3
+CONFIGURE_ARGS= --disable-pinentry-emacs
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -76,6 +79,14 @@ LIBSECRET_DESC= Saving the passphrase with libsecret
LIBSECRET_CONFIGURE_ENABLE= libsecret
LIBSECRET_LIB_DEPENDS= libsecret-1.so:${PORTSDIR}/security/libsecret
+.if ${PINENTRY_GUI} == "gnome3"
+USE_GNOME+= gtk20
+LIB_DEPENDS+= libgcr-base-3.so:${PORTSDIR}/security/gcr
+PLIST_FILES= bin/pinentry-gnome3
+.else
+CONFIGURE_ARGS+=--disable-pinentry-gnome3
+.endif
+
.if ${PINENTRY_GUI} == "qt4"
USES+= compiler:c++11-lib
USE_CXXSTD= c++11