aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--polish/gnugadu2/Makefile3
-rw-r--r--polish/kadu/Makefile4
-rw-r--r--polish/qnapi/Makefile2
-rw-r--r--polish/tleenx2/Makefile2
-rw-r--r--print/asprint/Makefile1
-rw-r--r--print/bibview/Makefile2
-rw-r--r--print/fig2dev/Makefile2
-rw-r--r--print/flpsed/Makefile2
-rw-r--r--print/ft2demos/Makefile2
-rw-r--r--print/ghostscript7-x11/Makefile2
-rw-r--r--print/ghostscript8-x11/Makefile2
-rw-r--r--print/ghostscript9-agpl-x11/Makefile2
-rw-r--r--print/ghostscript9-x11/Makefile2
-rw-r--r--print/gl2ps/Makefile2
-rw-r--r--print/gv/Makefile2
-rw-r--r--print/libotf/Makefile2
-rw-r--r--print/lyx/Makefile2
-rw-r--r--print/pdfcube/Makefile2
-rw-r--r--print/photoprint/Makefile3
-rw-r--r--print/py-qt5-printsupport/Makefile2
-rw-r--r--print/qpdfview/Makefile2
-rw-r--r--print/tex-aleph/Makefile2
-rw-r--r--print/tex-luatex/Makefile2
-rw-r--r--print/tex-xdvik/Makefile2
-rw-r--r--print/tex-xetex/Makefile2
-rw-r--r--print/transfig/Makefile2
-rw-r--r--print/xpdfopen/Makefile2
27 files changed, 30 insertions, 27 deletions
diff --git a/polish/gnugadu2/Makefile b/polish/gnugadu2/Makefile
index c2f95f80686f..7d0da8450e08 100644
--- a/polish/gnugadu2/Makefile
+++ b/polish/gnugadu2/Makefile
@@ -21,7 +21,8 @@ LIB_DEPENDS= libaudiofile.so:audio/libaudiofile \
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-USES= gettext gmake libtool localbase pathfix perl5 pkgconfig tar:bzip2
+USES= gettext gmake gnome libtool localbase pathfix perl5 pkgconfig \
+ tar:bzip2 xorg
USE_GNOME= cairo gtk20
USE_LDCONFIG= yes
USE_XORG= x11 xaw ice xscrnsaver
diff --git a/polish/kadu/Makefile b/polish/kadu/Makefile
index 3181d2a796ca..8b481ef73fcf 100644
--- a/polish/kadu/Makefile
+++ b/polish/kadu/Makefile
@@ -36,8 +36,8 @@ LIB_DEPENDS= libmpdclient.so:audio/libmpdclient \
GG6_EMOTS_DISTFILE= kompatybilne_z_GG6.tar.gz
GG7_EMOTS_DISTFILE= dodatkowe_emoty_GG7.tar.gz
-USES= cmake:insource compiler:c++11-lib gettext-runtime \
- libarchive pkgconfig qt:5 readline tar:bzip2
+USES= cmake:insource compiler:c++11-lib gettext-runtime gnome \
+ libarchive pkgconfig qt:5 readline tar:bzip2 xorg
USE_XORG= x11 xext xfixes xscrnsaver
USE_GNOME= glib20
USE_QT= concurrent core dbus declarative gui multimedia network \
diff --git a/polish/qnapi/Makefile b/polish/qnapi/Makefile
index 10179e103ea8..f22639564bf7 100644
--- a/polish/qnapi/Makefile
+++ b/polish/qnapi/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= 7z:archivers/p7zip
USE_GITHUB= yes
-USES= compiler:c++11-lib pkgconfig qmake qt:5
+USES= compiler:c++11-lib gl pkgconfig qmake qt:5
USE_GL= gl
USE_QT= buildtools_build core gui network widgets xml
diff --git a/polish/tleenx2/Makefile b/polish/tleenx2/Makefile
index f90022291d71..a0fa7b85b14f 100644
--- a/polish/tleenx2/Makefile
+++ b/polish/tleenx2/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libtlen.so:polish/libtlen
-USES= localbase:ldflags pkgconfig
+USES= gnome localbase:ldflags pkgconfig xorg
USE_GNOME= gtk20
GNU_CONFIGURE= yes
USE_XORG= x11 xscrnsaver
diff --git a/print/asprint/Makefile b/print/asprint/Makefile
index 46e8e38a9b1e..3c5f44687915 100644
--- a/print/asprint/Makefile
+++ b/print/asprint/Makefile
@@ -12,6 +12,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Simple browser to allow a user to print
PLIST_FILES= bin/asprint
+USES= xorg
USE_XORG= xmu xpm xt xaw x11
ALL_TARGET= asprint
MAKEFILE= makefile
diff --git a/print/bibview/Makefile b/print/bibview/Makefile
index 0cd175b56c86..1c91a4770a71 100644
--- a/print/bibview/Makefile
+++ b/print/bibview/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= TEX_CTAN/biblio/bibtex/utils/bibview-2.0
MAINTAINER= ports@FreeBSD.org
COMMENT= Graphical interface for manipulating BibTeX bibliography databases
-USES= imake
+USES= imake xorg
USE_XORG= ice sm x11 xaw xext xmu xt
WRKSRC= ${WRKDIR}/bibview-${PORTVERSION}
diff --git a/print/fig2dev/Makefile b/print/fig2dev/Makefile
index a3f5f7eab8e4..88987a89dd31 100644
--- a/print/fig2dev/Makefile
+++ b/print/fig2dev/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libpng.so:graphics/png
CONFLICTS= transfig-*
-USES= alias ghostscript:run iconv tar:xz
+USES= alias ghostscript:run iconv tar:xz xorg
CFLAGS+= -Wno-return-type
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-transfig
diff --git a/print/flpsed/Makefile b/print/flpsed/Makefile
index a26519f1b60f..c3a84371f3a0 100644
--- a/print/flpsed/Makefile
+++ b/print/flpsed/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS+= libfltk.so:x11-toolkits/fltk \
libfontconfig.so:x11-fonts/fontconfig
-USES= desktop-file-utils ghostscript:x11 gmake
+USES= desktop-file-utils ghostscript:x11 gmake xorg
GNU_CONFIGURE= yes
USE_XORG= x11 xcursor xext xfixes xft xinerama xrender
diff --git a/print/ft2demos/Makefile b/print/ft2demos/Makefile
index 508b2c127710..b788d92bc672 100644
--- a/print/ft2demos/Makefile
+++ b/print/ft2demos/Makefile
@@ -16,7 +16,7 @@ LICENSE_COMB= dual
BUILD_DEPENDS= ${NONEXISTENT}:print/freetype2:build
LIB_DEPENDS= libfreetype.so:print/freetype2
-USES= gmake tar:bzip2
+USES= gmake tar:bzip2 xorg
USE_XORG= x11
MAKE_ARGS= EXES="${FT_PROGRAMS}" X11_PATH="${LOCALBASE}"
diff --git a/print/ghostscript7-x11/Makefile b/print/ghostscript7-x11/Makefile
index a966ae101fec..46f5d8025eb8 100644
--- a/print/ghostscript7-x11/Makefile
+++ b/print/ghostscript7-x11/Makefile
@@ -21,7 +21,7 @@ CONFLICTS_INSTALL= \
ghostscript9-agpl-[0-9]* \
ghostscript9-agpl-nox11-[0-9]*
-USES= autoreconf ghostscript:7 gmake tar:bzip2
+USES= autoreconf ghostscript:7 gmake tar:bzip2 xorg
USE_LDCONFIG= yes
USE_XORG= ice sm x11 xext xt
GNU_CONFIGURE= yes
diff --git a/print/ghostscript8-x11/Makefile b/print/ghostscript8-x11/Makefile
index 2d234ced94cf..84f2e9e6402c 100644
--- a/print/ghostscript8-x11/Makefile
+++ b/print/ghostscript8-x11/Makefile
@@ -23,7 +23,7 @@ CONFLICTS_INSTALL= \
ghostscript9-agpl-[0-9]* \
ghostscript9-agpl-nox11-[0-9]*
-USES= autoreconf ghostscript:8 gmake tar:xz
+USES= autoreconf ghostscript:8 gmake tar:xz xorg
USE_LDCONFIG= yes
USE_XORG= ice sm x11 xext xt
GNU_CONFIGURE= yes
diff --git a/print/ghostscript9-agpl-x11/Makefile b/print/ghostscript9-agpl-x11/Makefile
index 54839567f392..db5891e53e3e 100644
--- a/print/ghostscript9-agpl-x11/Makefile
+++ b/print/ghostscript9-agpl-x11/Makefile
@@ -22,7 +22,7 @@ CONFLICTS_INSTALL= \
DISTINFO_FILE= ${.CURDIR:H}/ghostscript9-agpl-base/distinfo
PATCHDIR= ${.CURDIR:H}/ghostscript9-agpl-base/files
-USES= cpe gmake iconv localbase pkgconfig tar:xz
+USES= cpe gmake iconv localbase pkgconfig tar:xz xorg
USE_CSTD= gnu99
USE_LDCONFIG= yes
USE_XORG= ice sm x11 xext xt
diff --git a/print/ghostscript9-x11/Makefile b/print/ghostscript9-x11/Makefile
index da0c264e59de..1c4ffab0534a 100644
--- a/print/ghostscript9-x11/Makefile
+++ b/print/ghostscript9-x11/Makefile
@@ -21,7 +21,7 @@ CONFLICTS_INSTALL= \
ghostscript9-agpl-[0-9]* \
ghostscript9-agpl-nox11-[0-9]*
-USES= autoreconf ghostscript:9 gmake tar:bzip2
+USES= autoreconf ghostscript:9 gmake tar:bzip2 xorg
USE_LDCONFIG= yes
USE_XORG= ice sm x11 xext xt
EXTRACT_AFTER_ARGS= ${EXCLUDE_DIRS:S/^/--exclude /}
diff --git a/print/gl2ps/Makefile b/print/gl2ps/Makefile
index f0d72e516909..c72b79b0b50c 100644
--- a/print/gl2ps/Makefile
+++ b/print/gl2ps/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING.LGPL
LIB_DEPENDS= libpng.so:graphics/png
-USES= cmake tar:tgz
+USES= cmake gl tar:tgz
USE_GL= gl
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-source
diff --git a/print/gv/Makefile b/print/gv/Makefile
index d7f16878d504..a8e64620b9cc 100644
--- a/print/gv/Makefile
+++ b/print/gv/Makefile
@@ -12,7 +12,7 @@ COMMENT= PostScript and PDF previewer
LIB_DEPENDS= libXaw3d.so:x11-toolkits/Xaw3d
-USES= cpe ghostscript:x11 iconv gmake perl5 shebangfix
+USES= cpe ghostscript:x11 iconv gmake perl5 shebangfix xorg
USE_PERL5= build
USE_XORG= xpm ice sm xext xmu x11
GNU_CONFIGURE= yes
diff --git a/print/libotf/Makefile b/print/libotf/Makefile
index 887d432c3dd0..8d67cd5572d4 100644
--- a/print/libotf/Makefile
+++ b/print/libotf/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libfreetype.so:print/freetype2
-USES= pathfix pkgconfig libtool:keepla
+USES= pathfix pkgconfig libtool:keepla xorg
GNU_CONFIGURE= yes
USE_XORG= ice sm x11 xaw xt xmu
INSTALL_TARGET= install-strip
diff --git a/print/lyx/Makefile b/print/lyx/Makefile
index 8bab11f663a9..2d905a9b26e9 100644
--- a/print/lyx/Makefile
+++ b/print/lyx/Makefile
@@ -23,7 +23,7 @@ MAJOR_VERSION= 2.3
MINOR_VERSION= 2
USES= compiler:c++11-lang desktop-file-utils gmake iconv pkgconfig \
- perl5 python:2.7 qt:5 shebangfix tar:xz
+ perl5 python:2.7 qt:5 shebangfix tar:xz xorg
USE_QT= core concurrent gui svg widgets x11extras buildtools_build qmake_build
USE_XORG= xcb
GNU_CONFIGURE= yes
diff --git a/print/pdfcube/Makefile b/print/pdfcube/Makefile
index f174508d42ef..1c4c35eb6bd2 100644
--- a/print/pdfcube/Makefile
+++ b/print/pdfcube/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libgtkglext-x11-1.0.so:x11-toolkits/gtkglext \
libpoppler-glib.so:graphics/poppler-glib \
libboost_program_options.so:devel/boost-libs
-USES= compiler:c++11-lang pkgconfig
+USES= compiler:c++11-lang gl pkgconfig
USE_GL= glut
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --libdir=${LOCALBASE}/lib --includedir=${LOCALBASE}/include
diff --git a/print/photoprint/Makefile b/print/photoprint/Makefile
index f57f0857474c..759b892059ea 100644
--- a/print/photoprint/Makefile
+++ b/print/photoprint/Makefile
@@ -23,7 +23,8 @@ LIB_DEPENDS= libcups.so:print/cups \
libtiff.so:graphics/tiff
GNU_CONFIGURE= yes
-USES= compiler:c++11-lang desktop-file-utils gettext jpeg libtool localbase pkgconfig
+USES= compiler:c++11-lang desktop-file-utils gettext gnome jpeg \
+ libtool localbase pkgconfig xorg
USE_GNOME= cairo gdkpixbuf2 gtk20
USE_XORG= x11
USE_CXXSTD= gnu++98
diff --git a/print/py-qt5-printsupport/Makefile b/print/py-qt5-printsupport/Makefile
index 44a475b1e3f0..9aec593e78e9 100644
--- a/print/py-qt5-printsupport/Makefile
+++ b/print/py-qt5-printsupport/Makefile
@@ -12,7 +12,7 @@ RUN_DEPENDS= ${PY_ENUM34}
CONFIGURE_ARGS= --enable QtPrintSupport
PYQT_DIST= yes
-USES= python pyqt:5 qt:5
+USES= gl python pyqt:5 qt:5
USE_GL= gl
USE_PYQT= sip_build core_run widgets_run
USE_PYTHON= concurrent flavors py3kplist
diff --git a/print/qpdfview/Makefile b/print/qpdfview/Makefile
index d11d16a7a79b..4d2bd1d210ee 100644
--- a/print/qpdfview/Makefile
+++ b/print/qpdfview/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpoppler-qt5.so:graphics/poppler-qt5
-USES+= compiler:c++11-lang desktop-file-utils gl pkgconfig qmake qt:5
+USES= compiler:c++11-lang desktop-file-utils gl pkgconfig qmake qt:5
USE_LDCONFIG= yes
USE_QT= buildtools_build concurrent core dbus gui imageformats linguisttools printsupport sql sql-sqlite3 svg widgets xml
USE_GL= gl
diff --git a/print/tex-aleph/Makefile b/print/tex-aleph/Makefile
index d374b5d4ba08..77d447c7f4b5 100644
--- a/print/tex-aleph/Makefile
+++ b/print/tex-aleph/Makefile
@@ -18,7 +18,7 @@ COMMENT= TeX Engine including Omega and e-TeX features
LIB_DEPENDS= libmpfr.so:math/mpfr \
libpng.so:graphics/png
-USES= tar:xz pkgconfig
+USES= gnome pkgconfig tar:xz xorg
USE_TEX= kpathsea web2c texmf formats fmtutil
USE_XORG= pixman
USE_GNOME= cairo
diff --git a/print/tex-luatex/Makefile b/print/tex-luatex/Makefile
index 5a840edc0102..094096bb8440 100644
--- a/print/tex-luatex/Makefile
+++ b/print/tex-luatex/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libpng.so:graphics/png \
libmpfr.so:math/mpfr \
libzzip.so:devel/zziplib
-USES= pkgconfig tar:xz libtool
+USES= gnome libtool pkgconfig tar:xz xorg
USE_TEX= kpathsea web2c texmf formats texlua texluajit fmtutil
USE_XORG= pixman
USE_GNOME= cairo
diff --git a/print/tex-xdvik/Makefile b/print/tex-xdvik/Makefile
index 44f1cc826e7b..b9d3ff4133b2 100644
--- a/print/tex-xdvik/Makefile
+++ b/print/tex-xdvik/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libfreetype.so:print/freetype2 \
libpaper.so:print/libpaper
RUN_DEPENDS= tex-dvipsk>=5.995:print/tex-dvipsk
-USES= iconv motif
+USES= iconv motif xorg
USE_TEX= web2c kpathsea texmf texhash
TEXHASHDIRS= ${TEXMFDISTDIR}
USE_XORG= ice sm x11 xmu xpm xt xi
diff --git a/print/tex-xetex/Makefile b/print/tex-xetex/Makefile
index 08d30d565ac3..0e55507ee6b2 100644
--- a/print/tex-xetex/Makefile
+++ b/print/tex-xetex/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= libfreetype.so:print/freetype2 \
libpng.so:graphics/png \
libTECkit.so:textproc/teckit
-USES= compiler:c++11-lib pkgconfig tar:xz
+USES= compiler:c++11-lib gnome pkgconfig tar:xz xorg
USE_CXXSTD= gnu++11
USE_TEX= kpathsea web2c texmf formats fmtutil dvipdfmx
USE_XORG= pixman
diff --git a/print/transfig/Makefile b/print/transfig/Makefile
index b0d2167cd9cc..c5ee782aa69b 100644
--- a/print/transfig/Makefile
+++ b/print/transfig/Makefile
@@ -14,7 +14,7 @@ COMMENT= Tools to convert Xfig .fig files
RUN_DEPENDS= ppmtogif:graphics/netpbm
LIB_DEPENDS= libpng.so:graphics/png
-USES= alias ghostscript:run imake
+USES= alias ghostscript:run imake xorg
CFLAGS+= -Wno-return-type
USE_XORG= xpm
diff --git a/print/xpdfopen/Makefile b/print/xpdfopen/Makefile
index 99fbb213e886..118d1b250110 100644
--- a/print/xpdfopen/Makefile
+++ b/print/xpdfopen/Makefile
@@ -12,7 +12,7 @@ COMMENT= Command line utility for PDF viewers
CONFLICTS= texlive-base-20150521_[1-4]
-USES= tar:xz
+USES= tar:xz xorg
USE_XORG= x11 xmu
EXTRACT_AFTER_ARGS= ${EXTRACT_FILES:S,^,${DISTNAME}/,}
EXTRACT_FILES= build-aux \