aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/p5-DBD-cego/Makefile4
-rw-r--r--databases/p5-DBD-cego/files/patch-CegoXS.h19
2 files changed, 21 insertions, 2 deletions
diff --git a/databases/p5-DBD-cego/Makefile b/databases/p5-DBD-cego/Makefile
index 85a5358eda8d..1ed4f0b825a9 100644
--- a/databases/p5-DBD-cego/Makefile
+++ b/databases/p5-DBD-cego/Makefile
@@ -6,7 +6,7 @@
PORTNAME= DBD-cego
PORTVERSION= 1.1.14
-PORTRESIVION= 1
+PORTREVISION= 1
CATEGORIES= databases perl5
MASTER_SITES= http://www.lemke-it.com/
PKGNAMEPREFIX= p5-
@@ -15,7 +15,7 @@ MAINTAINER= fbsd-ports@opsec.eu
COMMENT= A Cego DBI driver for Perl 5
BUILD_DEPENDS= p5-DBI>=1.61:${PORTSDIR}/databases/p5-DBI
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+RUN_DEPENDS= p5-DBI>=1.61:${PORTSDIR}/databases/p5-DBI
LIB_DEPENDS= cego.1:${PORTSDIR}/databases/cego
LICENSE= GPLv2
diff --git a/databases/p5-DBD-cego/files/patch-CegoXS.h b/databases/p5-DBD-cego/files/patch-CegoXS.h
new file mode 100644
index 000000000000..b4052386cb61
--- /dev/null
+++ b/databases/p5-DBD-cego/files/patch-CegoXS.h
@@ -0,0 +1,19 @@
+--- CegoXS.h.orig 2010-11-21 09:25:27.000000000 +0800
++++ CegoXS.h 2011-05-29 21:11:15.361979766 +0800
+@@ -9,4 +9,16 @@
+ #include "dbdimp.h"
+ #include <dbd_xsh.h>
+
++#ifndef sv_yes
++#define sv_yes PL_sv_yes
++#endif
++
++#ifndef sv_no
++#define sv_no PL_sv_no
++#endif
++
++#ifndef dirty
++#define dirty PL_dirty
++#endif
++
+ #endif