aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES12
-rw-r--r--Mk/Scripts/create-manifest.sh1
-rw-r--r--Mk/bsd.port.mk2
3 files changed, 14 insertions, 1 deletions
diff --git a/CHANGES b/CHANGES
index 107af49c3ec6..5276e917be7c 100644
--- a/CHANGES
+++ b/CHANGES
@@ -11,6 +11,18 @@ in the release notes and/or placed into UPDATING.
All ports committers are allowed to commit to this file.
20200414:
+AUTHOR: bapt@FreeBSD.org
+
+ package scripts can now be done in lua, the following are supported:
+
+ - pkg-pre-install.lua
+ - pkg-post-install.lua
+ - pkg-pre-deinstall.lua
+ - pkg-post-deinstall.lua
+
+ see pkg-lua-script(5) for more details.
+
+20200414:
AUTHOR: mat@FreeBSD.org
USES=lua gained flavors.
diff --git a/Mk/Scripts/create-manifest.sh b/Mk/Scripts/create-manifest.sh
index e94d637b1bbe..cb924a03839c 100644
--- a/Mk/Scripts/create-manifest.sh
+++ b/Mk/Scripts/create-manifest.sh
@@ -104,6 +104,7 @@ for stage in INSTALL DEINSTALL UPGRADE; do
output=${dp_METADIR}/+${prepost:+${prepost}_}${stage}
for input in ${files}; do
[ -f "${input}" ] && cat ${input} >> ${output}
+ [ -f "${input}.lua" ] && cp ${input}.lua ${dp_METADIR}
done
done
done
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index c4730b778029..116015aeb3be 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1047,7 +1047,7 @@ _FLAVOR:= ${FLAVOR}
.if !defined(PORTS_FEATURES) && empty(${PORTS_FEATURES:MFLAVORS})
PORTS_FEATURES+= FLAVORS
.endif
-MINIMAL_PKG_VERSION= 1.6.0
+MINIMAL_PKG_VERSION= 1.13.0
_PORTS_DIRECTORIES+= ${PKG_DBDIR} ${PREFIX} ${WRKDIR} ${EXTRACT_WRKDIR} \
${STAGEDIR}${PREFIX} ${WRKDIR}/pkg ${BINARY_LINKDIR}