aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--GIDs2
-rw-r--r--UIDs2
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libvirt-dbus/Makefile27
-rw-r--r--devel/libvirt-dbus/distinfo3
-rw-r--r--devel/libvirt-dbus/pkg-descr4
-rw-r--r--devel/libvirt-dbus/pkg-plist14
7 files changed, 51 insertions, 2 deletions
diff --git a/GIDs b/GIDs
index 467b3a515e6d..94e7b2856f7c 100644
--- a/GIDs
+++ b/GIDs
@@ -460,7 +460,7 @@ pwhois:*:512:
# free: 517
# free: 518
# free: 519
-# free: 520
+libvirtdbus:*:520:
davmail:*:521:
nullmail:*:522:
freevo:*:523:
diff --git a/UIDs b/UIDs
index a53f0545ed81..3e0cd83568dd 100644
--- a/UIDs
+++ b/UIDs
@@ -466,7 +466,7 @@ pwhois:*:512:512::0:0:pwhoisd User:/nonexistent:/usr/sbin/nologin
# free: 517
# free: 518
# free: 519
-# free: 520
+libvirtdbus:*:520:520::0:0:Libvirt D-Bus bridge:/nonexistent:/usr/sbin/nologin
davmail:*:521:521::0:0:Davmail Exchange Gateway:/nonexistent:/usr/sbin/nologin
nullmail:*:522:522::0:0:Nullmailer Mail System:/var/spool/nullmailer:/bin/sh
freevo:*:523:523::0:0:Freevo User:/var/db/freevo:/bin/sh
diff --git a/devel/Makefile b/devel/Makefile
index 931800533bba..5c4ec1517efd 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1625,6 +1625,7 @@
SUBDIR += libversion
SUBDIR += libvhdi
SUBDIR += libvirt
+ SUBDIR += libvirt-dbus
SUBDIR += libvirt-glib
SUBDIR += libvirt-java
SUBDIR += libvmdk
diff --git a/devel/libvirt-dbus/Makefile b/devel/libvirt-dbus/Makefile
new file mode 100644
index 000000000000..63d5467b17f2
--- /dev/null
+++ b/devel/libvirt-dbus/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= libvirt-dbus
+PORTVERSION= 1.2.0
+CATEGORIES= devel
+MASTER_SITES= ftp://libvirt.org/libvirt/dbus/
+
+MAINTAINER= novel@FreeBSD.org
+COMMENT= Libvirt D-Bus API binding
+
+LICENSE= LGPL21+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libvirt.so:devel/libvirt \
+ libvirt-glib-1.0.so:devel/libvirt-glib
+RUN_DEPENDS= dbus-daemon:devel/dbus
+
+USES= gettext-runtime gmake libtool perl5 pkgconfig tar:xz
+USE_GNOME= glib20
+USE_PERL5= build
+
+GNU_CONFIGURE= yes
+
+USERS= libvirtdbus
+GROUPS= libvirtdbus
+
+.include <bsd.port.mk>
diff --git a/devel/libvirt-dbus/distinfo b/devel/libvirt-dbus/distinfo
new file mode 100644
index 000000000000..6fcecc09ab76
--- /dev/null
+++ b/devel/libvirt-dbus/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1547224319
+SHA256 (libvirt-dbus-1.2.0.tar.xz) = 080e226f1579adc59e2a6d744a3da06afffeaed47c37d38782cd272bc9ccba9a
+SIZE (libvirt-dbus-1.2.0.tar.xz) = 284444
diff --git a/devel/libvirt-dbus/pkg-descr b/devel/libvirt-dbus/pkg-descr
new file mode 100644
index 000000000000..e7c677f86246
--- /dev/null
+++ b/devel/libvirt-dbus/pkg-descr
@@ -0,0 +1,4 @@
+libvirt-dbus wraps libvirt API to provide a high-level object-oriented API
+better suited for dbus-based applications.
+
+WWW: https://libvirt.org/dbus.html
diff --git a/devel/libvirt-dbus/pkg-plist b/devel/libvirt-dbus/pkg-plist
new file mode 100644
index 000000000000..5ac611211dae
--- /dev/null
+++ b/devel/libvirt-dbus/pkg-plist
@@ -0,0 +1,14 @@
+bin/libvirt-dbus
+man/man8/libvirt-dbus.8.gz
+share/dbus-1/interfaces/org.libvirt.Connect.xml
+share/dbus-1/interfaces/org.libvirt.Domain.xml
+share/dbus-1/interfaces/org.libvirt.NWFilter.xml
+share/dbus-1/interfaces/org.libvirt.Network.xml
+share/dbus-1/interfaces/org.libvirt.NodeDevice.xml
+share/dbus-1/interfaces/org.libvirt.Secret.xml
+share/dbus-1/interfaces/org.libvirt.StoragePool.xml
+share/dbus-1/interfaces/org.libvirt.StorageVol.xml
+share/dbus-1/services/org.libvirt.service
+share/dbus-1/system-services/org.libvirt.service
+share/dbus-1/system.d/org.libvirt.conf
+share/polkit-1/rules.d/libvirt-dbus.rules