aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/sdl12/Makefile14
-rw-r--r--devel/sdl12/pkg-plist304
2 files changed, 54 insertions, 264 deletions
diff --git a/devel/sdl12/Makefile b/devel/sdl12/Makefile
index aedb6a8e68c4..fdcf830f3b5d 100644
--- a/devel/sdl12/Makefile
+++ b/devel/sdl12/Makefile
@@ -31,6 +31,10 @@ CONFIGURE_ARGS= --enable-video-aalib \
CFLAGS+= ${PTHREAD_CFLAGS}
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
.if exists(/usr/lib/libvgl.so.3)
CONFIGURE_ARGS+=--enable-video-vgl
DISPLAY_MSG= ${CAT} ${PKGMESSAGE}
@@ -93,15 +97,15 @@ post-configure:
${WRKSRC}/libtool
post-install:
- @${MKDIR} ${PREFIX}/share/examples/SDL11
- ${INSTALL_DATA} ${WRKSRC}/test/* ${PREFIX}/share/examples/SDL11
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/test/* ${EXAMPLESDIR}
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/SDL11/docs
+ @${MKDIR} ${DOCSDIR}/docs
.for file in BUGS COPYING CREDITS README WhatsNew docs.html
- ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/SDL11
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
@cd ${WRKSRC}/docs; ${TAR} cf - `${ECHO_CMD} [^Mm]*` | \
- (cd ${PREFIX}/share/doc/SDL11/docs; ${TAR} --unlink -xf - )
+ (cd ${DOCSDIR}/docs; ${TAR} --unlink -xf - )
.endif
@${DISPLAY_MSG}
diff --git a/devel/sdl12/pkg-plist b/devel/sdl12/pkg-plist
index 20a7f8adc491..0fe3c9286443 100644
--- a/devel/sdl12/pkg-plist
+++ b/devel/sdl12/pkg-plist
@@ -32,263 +32,49 @@ lib/libSDL-1.1.so
lib/libSDL-1.1.so.5
lib/libSDLmain-1.1.a
share/aclocal/sdl11.m4
-share/doc/SDL11/BUGS
-share/doc/SDL11/COPYING
-share/doc/SDL11/CREDITS
-share/doc/SDL11/README
-share/doc/SDL11/WhatsNew
-share/doc/SDL11/docs.html
-share/doc/SDL11/docs/html/Makefile
-share/doc/SDL11/docs/html/Makefile.am
-share/doc/SDL11/docs/html/Makefile.in
-share/doc/SDL11/docs/html/audio.html
-share/doc/SDL11/docs/html/cdrom.html
-share/doc/SDL11/docs/html/event.html
-share/doc/SDL11/docs/html/eventfunctions.html
-share/doc/SDL11/docs/html/eventstructures.html
-share/doc/SDL11/docs/html/general.html
-share/doc/SDL11/docs/html/guide.html
-share/doc/SDL11/docs/html/guideaboutsdldoc.html
-share/doc/SDL11/docs/html/guideaudioexamples.html
-share/doc/SDL11/docs/html/guidebasicsinit.html
-share/doc/SDL11/docs/html/guidecdromexamples.html
-share/doc/SDL11/docs/html/guidecredits.html
-share/doc/SDL11/docs/html/guideeventexamples.html
-share/doc/SDL11/docs/html/guideexamples.html
-share/doc/SDL11/docs/html/guideinput.html
-share/doc/SDL11/docs/html/guideinputkeyboard.html
-share/doc/SDL11/docs/html/guidepreface.html
-share/doc/SDL11/docs/html/guidethebasics.html
-share/doc/SDL11/docs/html/guidetimeexamples.html
-share/doc/SDL11/docs/html/guidevideo.html
-share/doc/SDL11/docs/html/guidevideoexamples.html
-share/doc/SDL11/docs/html/guidevideoopengl.html
-share/doc/SDL11/docs/html/index.html
-share/doc/SDL11/docs/html/joystick.html
-share/doc/SDL11/docs/html/reference.html
-share/doc/SDL11/docs/html/sdlactiveevent.html
-share/doc/SDL11/docs/html/sdladdtimer.html
-share/doc/SDL11/docs/html/sdlaudiocvt.html
-share/doc/SDL11/docs/html/sdlaudiospec.html
-share/doc/SDL11/docs/html/sdlblitsurface.html
-share/doc/SDL11/docs/html/sdlbuildaudiocvt.html
-share/doc/SDL11/docs/html/sdlcd.html
-share/doc/SDL11/docs/html/sdlcdclose.html
-share/doc/SDL11/docs/html/sdlcdeject.html
-share/doc/SDL11/docs/html/sdlcdname.html
-share/doc/SDL11/docs/html/sdlcdnumdrives.html
-share/doc/SDL11/docs/html/sdlcdopen.html
-share/doc/SDL11/docs/html/sdlcdpause.html
-share/doc/SDL11/docs/html/sdlcdplay.html
-share/doc/SDL11/docs/html/sdlcdplaytracks.html
-share/doc/SDL11/docs/html/sdlcdresume.html
-share/doc/SDL11/docs/html/sdlcdstatus.html
-share/doc/SDL11/docs/html/sdlcdstop.html
-share/doc/SDL11/docs/html/sdlcdtrack.html
-share/doc/SDL11/docs/html/sdlcloseaudio.html
-share/doc/SDL11/docs/html/sdlcolor.html
-share/doc/SDL11/docs/html/sdlcondbroadcast.html
-share/doc/SDL11/docs/html/sdlcondsignal.html
-share/doc/SDL11/docs/html/sdlcondwait.html
-share/doc/SDL11/docs/html/sdlcondwaittimeout.html
-share/doc/SDL11/docs/html/sdlconvertaudio.html
-share/doc/SDL11/docs/html/sdlconvertsurface.html
-share/doc/SDL11/docs/html/sdlcreatecond.html
-share/doc/SDL11/docs/html/sdlcreatecursor.html
-share/doc/SDL11/docs/html/sdlcreatemutex.html
-share/doc/SDL11/docs/html/sdlcreatergbsurface.html
-share/doc/SDL11/docs/html/sdlcreatergbsurfacefrom.html
-share/doc/SDL11/docs/html/sdlcreatesemaphore.html
-share/doc/SDL11/docs/html/sdlcreatethread.html
-share/doc/SDL11/docs/html/sdlcreateyuvoverlay.html
-share/doc/SDL11/docs/html/sdldelay.html
-share/doc/SDL11/docs/html/sdldestroycond.html
-share/doc/SDL11/docs/html/sdldestroymutex.html
-share/doc/SDL11/docs/html/sdldestroysemaphore.html
-share/doc/SDL11/docs/html/sdldisplayformat.html
-share/doc/SDL11/docs/html/sdldisplayformatalpha.html
-share/doc/SDL11/docs/html/sdldisplayyuvoverlay.html
-share/doc/SDL11/docs/html/sdlenablekeyrepeat.html
-share/doc/SDL11/docs/html/sdlenableunicode.html
-share/doc/SDL11/docs/html/sdlevent.html
-share/doc/SDL11/docs/html/sdleventstate.html
-share/doc/SDL11/docs/html/sdlexposeevent.html
-share/doc/SDL11/docs/html/sdlfillrect.html
-share/doc/SDL11/docs/html/sdlflip.html
-share/doc/SDL11/docs/html/sdlfreecursor.html
-share/doc/SDL11/docs/html/sdlfreesurface.html
-share/doc/SDL11/docs/html/sdlfreewav.html
-share/doc/SDL11/docs/html/sdlfreeyuvoverlay.html
-share/doc/SDL11/docs/html/sdlgetappstate.html
-share/doc/SDL11/docs/html/sdlgetaudiostatus.html
-share/doc/SDL11/docs/html/sdlgetcliprect.html
-share/doc/SDL11/docs/html/sdlgetcursor.html
-share/doc/SDL11/docs/html/sdlgeterror.html
-share/doc/SDL11/docs/html/sdlgeteventfilter.html
-share/doc/SDL11/docs/html/sdlgetgammaramp.html
-share/doc/SDL11/docs/html/sdlgetkeyname.html
-share/doc/SDL11/docs/html/sdlgetkeystate.html
-share/doc/SDL11/docs/html/sdlgetmodstate.html
-share/doc/SDL11/docs/html/sdlgetmousestate.html
-share/doc/SDL11/docs/html/sdlgetrelativemousestate.html
-share/doc/SDL11/docs/html/sdlgetrgb.html
-share/doc/SDL11/docs/html/sdlgetrgba.html
-share/doc/SDL11/docs/html/sdlgetthreadid.html
-share/doc/SDL11/docs/html/sdlgetticks.html
-share/doc/SDL11/docs/html/sdlgetvideoinfo.html
-share/doc/SDL11/docs/html/sdlgetvideosurface.html
-share/doc/SDL11/docs/html/sdlglattr.html
-share/doc/SDL11/docs/html/sdlglgetattribute.html
-share/doc/SDL11/docs/html/sdlglgetprocaddress.html
-share/doc/SDL11/docs/html/sdlglloadlibrary.html
-share/doc/SDL11/docs/html/sdlglsetattribute.html
-share/doc/SDL11/docs/html/sdlglswapbuffers.html
-share/doc/SDL11/docs/html/sdlinit.html
-share/doc/SDL11/docs/html/sdlinitsubsystem.html
-share/doc/SDL11/docs/html/sdljoyaxisevent.html
-share/doc/SDL11/docs/html/sdljoyballevent.html
-share/doc/SDL11/docs/html/sdljoybuttonevent.html
-share/doc/SDL11/docs/html/sdljoyhatevent.html
-share/doc/SDL11/docs/html/sdljoystickclose.html
-share/doc/SDL11/docs/html/sdljoystickeventstate.html
-share/doc/SDL11/docs/html/sdljoystickgetaxis.html
-share/doc/SDL11/docs/html/sdljoystickgetball.html
-share/doc/SDL11/docs/html/sdljoystickgetbutton.html
-share/doc/SDL11/docs/html/sdljoystickgethat.html
-share/doc/SDL11/docs/html/sdljoystickindex.html
-share/doc/SDL11/docs/html/sdljoystickname.html
-share/doc/SDL11/docs/html/sdljoysticknumaxes.html
-share/doc/SDL11/docs/html/sdljoysticknumballs.html
-share/doc/SDL11/docs/html/sdljoysticknumbuttons.html
-share/doc/SDL11/docs/html/sdljoysticknumhats.html
-share/doc/SDL11/docs/html/sdljoystickopen.html
-share/doc/SDL11/docs/html/sdljoystickopened.html
-share/doc/SDL11/docs/html/sdljoystickupdate.html
-share/doc/SDL11/docs/html/sdlkey.html
-share/doc/SDL11/docs/html/sdlkeyboardevent.html
-share/doc/SDL11/docs/html/sdlkeysym.html
-share/doc/SDL11/docs/html/sdlkillthread.html
-share/doc/SDL11/docs/html/sdllistmodes.html
-share/doc/SDL11/docs/html/sdlloadbmp.html
-share/doc/SDL11/docs/html/sdlloadwav.html
-share/doc/SDL11/docs/html/sdllockaudio.html
-share/doc/SDL11/docs/html/sdllocksurface.html
-share/doc/SDL11/docs/html/sdllockyuvoverlay.html
-share/doc/SDL11/docs/html/sdlmaprgb.html
-share/doc/SDL11/docs/html/sdlmaprgba.html
-share/doc/SDL11/docs/html/sdlmixaudio.html
-share/doc/SDL11/docs/html/sdlmousebuttonevent.html
-share/doc/SDL11/docs/html/sdlmousemotionevent.html
-share/doc/SDL11/docs/html/sdlmutexp.html
-share/doc/SDL11/docs/html/sdlmutexv.html
-share/doc/SDL11/docs/html/sdlnumjoysticks.html
-share/doc/SDL11/docs/html/sdlopenaudio.html
-share/doc/SDL11/docs/html/sdloverlay.html
-share/doc/SDL11/docs/html/sdlpalette.html
-share/doc/SDL11/docs/html/sdlpauseaudio.html
-share/doc/SDL11/docs/html/sdlpeepevents.html
-share/doc/SDL11/docs/html/sdlpixelformat.html
-share/doc/SDL11/docs/html/sdlpollevent.html
-share/doc/SDL11/docs/html/sdlpumpevents.html
-share/doc/SDL11/docs/html/sdlpushevent.html
-share/doc/SDL11/docs/html/sdlquit.html
-share/doc/SDL11/docs/html/sdlquitevent.html
-share/doc/SDL11/docs/html/sdlquitsubsystem.html
-share/doc/SDL11/docs/html/sdlrect.html
-share/doc/SDL11/docs/html/sdlremovetimer.html
-share/doc/SDL11/docs/html/sdlresizeevent.html
-share/doc/SDL11/docs/html/sdlsavebmp.html
-share/doc/SDL11/docs/html/sdlsempost.html
-share/doc/SDL11/docs/html/sdlsemtrywait.html
-share/doc/SDL11/docs/html/sdlsemvalue.html
-share/doc/SDL11/docs/html/sdlsemwait.html
-share/doc/SDL11/docs/html/sdlsemwaittimeout.html
-share/doc/SDL11/docs/html/sdlsetalpha.html
-share/doc/SDL11/docs/html/sdlsetcliprect.html
-share/doc/SDL11/docs/html/sdlsetcolorkey.html
-share/doc/SDL11/docs/html/sdlsetcolors.html
-share/doc/SDL11/docs/html/sdlsetcursor.html
-share/doc/SDL11/docs/html/sdlseteventfilter.html
-share/doc/SDL11/docs/html/sdlsetgamma.html
-share/doc/SDL11/docs/html/sdlsetgammaramp.html
-share/doc/SDL11/docs/html/sdlsetmodstate.html
-share/doc/SDL11/docs/html/sdlsetpalette.html
-share/doc/SDL11/docs/html/sdlsettimer.html
-share/doc/SDL11/docs/html/sdlsetvideomode.html
-share/doc/SDL11/docs/html/sdlshowcursor.html
-share/doc/SDL11/docs/html/sdlsurface.html
-share/doc/SDL11/docs/html/sdlsyswmevent.html
-share/doc/SDL11/docs/html/sdlthreadid.html
-share/doc/SDL11/docs/html/sdlunlockaudio.html
-share/doc/SDL11/docs/html/sdlunlocksurface.html
-share/doc/SDL11/docs/html/sdlunlockyuvoverlay.html
-share/doc/SDL11/docs/html/sdlupdaterect.html
-share/doc/SDL11/docs/html/sdlupdaterects.html
-share/doc/SDL11/docs/html/sdluserevent.html
-share/doc/SDL11/docs/html/sdlvideodrivername.html
-share/doc/SDL11/docs/html/sdlvideoinfo.html
-share/doc/SDL11/docs/html/sdlvideomodeok.html
-share/doc/SDL11/docs/html/sdlwaitevent.html
-share/doc/SDL11/docs/html/sdlwaitthread.html
-share/doc/SDL11/docs/html/sdlwarpmouse.html
-share/doc/SDL11/docs/html/sdlwasinit.html
-share/doc/SDL11/docs/html/sdlwmgetcaption.html
-share/doc/SDL11/docs/html/sdlwmgrabinput.html
-share/doc/SDL11/docs/html/sdlwmiconifywindow.html
-share/doc/SDL11/docs/html/sdlwmsetcaption.html
-share/doc/SDL11/docs/html/sdlwmseticon.html
-share/doc/SDL11/docs/html/sdlwmtogglefullscreen.html
-share/doc/SDL11/docs/html/thread.html
-share/doc/SDL11/docs/html/time.html
-share/doc/SDL11/docs/html/video.html
-share/doc/SDL11/docs/html/wm.html
-share/doc/SDL11/docs/index.html
-share/examples/SDL11/COPYING
-share/examples/SDL11/Makefile.am
-share/examples/SDL11/Makefile.in
-share/examples/SDL11/README
-share/examples/SDL11/acinclude.m4
-share/examples/SDL11/aclocal.m4
-share/examples/SDL11/autogen.sh
-share/examples/SDL11/checkkeys.c
-share/examples/SDL11/config.guess
-share/examples/SDL11/config.sub
-share/examples/SDL11/configure
-share/examples/SDL11/configure.in
-share/examples/SDL11/graywin.c
-share/examples/SDL11/icon.bmp
-share/examples/SDL11/install-sh
-share/examples/SDL11/loopwave.c
-share/examples/SDL11/missing
-share/examples/SDL11/mkinstalldirs
-share/examples/SDL11/picture.xbm
-share/examples/SDL11/sail.bmp
-share/examples/SDL11/sample.bmp
-share/examples/SDL11/sample.wav
-share/examples/SDL11/testalpha.c
-share/examples/SDL11/testbitmap.c
-share/examples/SDL11/testcdrom.c
-share/examples/SDL11/testerror.c
-share/examples/SDL11/testgamma.c
-share/examples/SDL11/testgl.c
-share/examples/SDL11/testhread.c
-share/examples/SDL11/testjoystick.c
-share/examples/SDL11/testkeys.c
-share/examples/SDL11/testlock.c
-share/examples/SDL11/testoverlay.c
-share/examples/SDL11/testpalette.c
-share/examples/SDL11/testsem.c
-share/examples/SDL11/testsprite.c
-share/examples/SDL11/testtimer.c
-share/examples/SDL11/testtypes.c
-share/examples/SDL11/testver.c
-share/examples/SDL11/testvidinfo.c
-share/examples/SDL11/testwin.c
-share/examples/SDL11/testwm.c
-share/examples/SDL11/threadwin.c
-share/examples/SDL11/torturethread.c
-@dirrm share/examples/SDL11
-@dirrm share/doc/SDL11/docs/html
-@dirrm share/doc/SDL11/docs
-@dirrm share/doc/SDL11
+%%EXAMPLESDIR%%/COPYING
+%%EXAMPLESDIR%%/Makefile.am
+%%EXAMPLESDIR%%/Makefile.in
+%%EXAMPLESDIR%%/README
+%%EXAMPLESDIR%%/acinclude.m4
+%%EXAMPLESDIR%%/aclocal.m4
+%%EXAMPLESDIR%%/autogen.sh
+%%EXAMPLESDIR%%/checkkeys.c
+%%EXAMPLESDIR%%/config.guess
+%%EXAMPLESDIR%%/config.sub
+%%EXAMPLESDIR%%/configure
+%%EXAMPLESDIR%%/configure.in
+%%EXAMPLESDIR%%/graywin.c
+%%EXAMPLESDIR%%/icon.bmp
+%%EXAMPLESDIR%%/install-sh
+%%EXAMPLESDIR%%/loopwave.c
+%%EXAMPLESDIR%%/missing
+%%EXAMPLESDIR%%/mkinstalldirs
+%%EXAMPLESDIR%%/picture.xbm
+%%EXAMPLESDIR%%/sail.bmp
+%%EXAMPLESDIR%%/sample.bmp
+%%EXAMPLESDIR%%/sample.wav
+%%EXAMPLESDIR%%/testalpha.c
+%%EXAMPLESDIR%%/testbitmap.c
+%%EXAMPLESDIR%%/testcdrom.c
+%%EXAMPLESDIR%%/testerror.c
+%%EXAMPLESDIR%%/testgamma.c
+%%EXAMPLESDIR%%/testgl.c
+%%EXAMPLESDIR%%/testhread.c
+%%EXAMPLESDIR%%/testjoystick.c
+%%EXAMPLESDIR%%/testkeys.c
+%%EXAMPLESDIR%%/testlock.c
+%%EXAMPLESDIR%%/testoverlay.c
+%%EXAMPLESDIR%%/testpalette.c
+%%EXAMPLESDIR%%/testsem.c
+%%EXAMPLESDIR%%/testsprite.c
+%%EXAMPLESDIR%%/testtimer.c
+%%EXAMPLESDIR%%/testtypes.c
+%%EXAMPLESDIR%%/testver.c
+%%EXAMPLESDIR%%/testvidinfo.c
+%%EXAMPLESDIR%%/testwin.c
+%%EXAMPLESDIR%%/testwm.c
+%%EXAMPLESDIR%%/threadwin.c
+%%EXAMPLESDIR%%/torturethread.c
+@dirrm %%EXAMPLESDIR%%
@dirrm include/SDL11