aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/qjail/Makefile9
-rw-r--r--sysutils/qjail/distinfo5
-rw-r--r--sysutils/qjail/pkg-descr2
-rw-r--r--sysutils/qjail/pkg-message29
-rw-r--r--sysutils/qjail/pkg-plist24
-rw-r--r--sysutils/qjail2/Makefile6
-rw-r--r--sysutils/qjail4/Makefile51
-rw-r--r--sysutils/qjail4/distinfo2
-rw-r--r--sysutils/qjail4/pkg-descr34
-rw-r--r--sysutils/qjail4/pkg-message42
-rw-r--r--sysutils/qjail4/pkg-plist48
12 files changed, 204 insertions, 49 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 44d6af08e721..a85c6441ee11 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -869,6 +869,7 @@
SUBDIR += qchroot
SUBDIR += qjail
SUBDIR += qjail2
+ SUBDIR += qjail4
SUBDIR += qlogtools
SUBDIR += qpxtool
SUBDIR += qsynergy
diff --git a/sysutils/qjail/Makefile b/sysutils/qjail/Makefile
index 16cecb2cfd41..203110959ec0 100644
--- a/sysutils/qjail/Makefile
+++ b/sysutils/qjail/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= qjail
-PORTVERSION= 4.9
+PORTVERSION= 5.0
CATEGORIES= sysutils
MASTER_SITES= SF/${PORTNAME}
@@ -24,10 +24,13 @@ USES= tar:bzip2
NO_BUILD= yes
NO_ARCH= yes
-CONFLICTS_INSTALL= qjail-2.* qjail-3.*
+CONFLICTS_INSTALL= qjail[24]-*
+
+IGNORE_FreeBSD_9= Only for FreeBSD 11+
+IGNORE_FreeBSD_10= Only for FreeBSD 11+
do-install:
-.for i in qjail qjail.vnet.be qjail.vnet.ng
+.for i in qjail qjail.vnet.be
${INSTALL_SCRIPT} ${WRKSRC}/${i} ${STAGEDIR}${PREFIX}/bin
.endfor
${INSTALL_SCRIPT} ${WRKSRC}/qjail.bootime \
diff --git a/sysutils/qjail/distinfo b/sysutils/qjail/distinfo
index e48262345aeb..0c4ad8c5145a 100644
--- a/sysutils/qjail/distinfo
+++ b/sysutils/qjail/distinfo
@@ -1,2 +1,3 @@
-SHA256 (qjail-4.9.tar.bz2) = 163d8893d431ab0699156db4a15c1c8927a71c4918014adb6006a8b6657cb49b
-SIZE (qjail-4.9.tar.bz2) = 66048
+TIMESTAMP = 1472482359
+SHA256 (qjail-5.0.tar.bz2) = 41bc83d214035c7939d50fce091a0f888a7d109aaf93cb52c9c70d0f4357a668
+SIZE (qjail-5.0.tar.bz2) = 63015
diff --git a/sysutils/qjail/pkg-descr b/sysutils/qjail/pkg-descr
index a32f8d778c61..e631f1377f54 100644
--- a/sysutils/qjail/pkg-descr
+++ b/sysutils/qjail/pkg-descr
@@ -1,4 +1,4 @@
-This qjail version is not intended for RELEASES older than RELEASE-10.0.
+This qjail version only supports RELEASE-11.0 and newer.
Qjail [ q = quick ] is a 4th generation wrapper for the basic chroot jail
system that includes security and performance enhancements. Plus a new level
diff --git a/sysutils/qjail/pkg-message b/sysutils/qjail/pkg-message
index 305da69273dd..1921fdc9091c 100644
--- a/sysutils/qjail/pkg-message
+++ b/sysutils/qjail/pkg-message
@@ -10,33 +10,4 @@ For the BIG PICTURE issue "man qjail-howto".
########################################################################
-For users who have existing qjail environments. Please take note.
-There are changes to the internals of the jail(8) command and changes to
-parameter names in the periodic files that have occured in FreeBSD
-Release 10.2 that effects jail behavior in a very minor way.
-IF your running qjail on an 10.2 or newer version of FreeBSD you should
-consider doing the following.
-This version of qjail has an built in auto convert function that you may select
-to choose that fixes those minor behavior problems with your existing jails.
-This auto convert function is not documented in the qjail manual. Its only
-shown here. So write it down.
-
- Issue [ qjail update -u ] from the host console.
-
-This will cause the existing "flavors" default & ssh-default directories to be
-renamed and new ones populated. Then in each existing jail the periodic.conf
-and newsyslog.conf files will be renamed with .saved suffix and new ones added.
-The rc.conf file will be updated in place changing the
-syslogd_enable= parameter value from "NO" to "YES".
-
-The new periodic.conf file has many sendmail reporting options disabled because
-sendmail is disabled in the jails rc.conf file by default. This drastically
-reduces the daily. weekly, monthly system and security status reports elapse
-run times. This has a major effect on operating system performance where there
-are a large number of jails.
-
-The [ qjail install ] command will install all the correct files depending on
-what version of FreeBSD your host is running.
-
-########################################################################
diff --git a/sysutils/qjail/pkg-plist b/sysutils/qjail/pkg-plist
index 9409c8e7bc16..8df0772b6c47 100644
--- a/sysutils/qjail/pkg-plist
+++ b/sysutils/qjail/pkg-plist
@@ -1,24 +1,24 @@
bin/qjail
bin/qjail.vnet.be
-bin/qjail.vnet.ng
@sample etc/qjail.portsnap.conf.sample
etc/rc.d/qjail.bootime
man/man8/qjail.8.gz
man/man8/qjail-intro.8.gz
man/man8/qjail-howto.8.gz
-%%EXAMPLESDIR%%/vnet/ipfw.rules.host
-%%EXAMPLESDIR%%/vnet/ipfw.rules.vnet
-%%EXAMPLESDIR%%/vnet/ipf.rules.host
-%%EXAMPLESDIR%%/vnet/ipf.rules.vnet
-%%EXAMPLESDIR%%/vnet/pf.rules.host
-%%EXAMPLESDIR%%/vnet/pf.rules.vnet
+%%EXAMPLESDIR%%/vnet/ipfw.host.rules
+%%EXAMPLESDIR%%/vnet/ipfw.vnet.rules
+%%EXAMPLESDIR%%/vnet/ipf.host.rules
+%%EXAMPLESDIR%%/vnet/ipf.vnet.boot.rules
+%%EXAMPLESDIR%%/vnet/ipf.vnet.run.rules
+%%EXAMPLESDIR%%/vnet/pf.host.rules
+%%EXAMPLESDIR%%/vnet/pf.vnet.rules.script
+%%EXAMPLESDIR%%/vnet/devfsrules_vjail_pf70
+%%EXAMPLESDIR%%/vnet/devfsrules_vjail_ipf60
%%EXAMPLESDIR%%/default/etc/make.conf
%%EXAMPLESDIR%%/default/etc/motd
%%EXAMPLESDIR%%/default/etc/periodic.conf
-%%EXAMPLESDIR%%/default/etc/periodic102.conf
-%%EXAMPLESDIR%%/default/etc/newsyslog102.conf
+%%EXAMPLESDIR%%/default/etc/newsyslog.conf
%%EXAMPLESDIR%%/default/etc/rc.conf
-%%EXAMPLESDIR%%/default/etc/rc102.conf
%%EXAMPLESDIR%%/default/root/.cshrc
%%EXAMPLESDIR%%/default/usr/local/etc/pkg.conf
%%EXAMPLESDIR%%/default/usr/local/etc/sudoers
@@ -28,11 +28,9 @@ man/man8/qjail-howto.8.gz
%%EXAMPLESDIR%%/ssh-default/etc/motd
%%EXAMPLESDIR%%/ssh-default/etc/passwd
%%EXAMPLESDIR%%/ssh-default/etc/periodic.conf
-%%EXAMPLESDIR%%/ssh-default/etc/periodic102.conf
-%%EXAMPLESDIR%%/ssh-default/etc/newsyslog102.conf
+%%EXAMPLESDIR%%/ssh-default/etc/newsyslog.conf
%%EXAMPLESDIR%%/ssh-default/etc/pwd.db
%%EXAMPLESDIR%%/ssh-default/etc/rc.conf
-%%EXAMPLESDIR%%/ssh-default/etc/rc102.conf
%%EXAMPLESDIR%%/ssh-default/etc/spwd.db
%%EXAMPLESDIR%%/ssh-default/etc/ssh/sshd_config
%%EXAMPLESDIR%%/ssh-default/root/.cshrc
diff --git a/sysutils/qjail2/Makefile b/sysutils/qjail2/Makefile
index 9b7221ba73dd..27520b485f96 100644
--- a/sysutils/qjail2/Makefile
+++ b/sysutils/qjail2/Makefile
@@ -14,7 +14,11 @@ COMMENT= Utility to quickly deploy and manage jails
USES= tar:bzip2
NO_BUILD= yes
-CONFLICTS_INSTALL= qjail-1.* qjail-3.*
+CONFLICTS_INSTALL= qjail-*
+
+IGNORE_FreeBSD_10= Only for FreeBSD 8 and 9
+IGNORE_FreeBSD_11= Only for FreeBSD 8 and 9
+IGNORE_FreeBSD_12= Only for FreeBSD 8 and 9
do-install:
diff --git a/sysutils/qjail4/Makefile b/sysutils/qjail4/Makefile
new file mode 100644
index 000000000000..ed5ad74ab60a
--- /dev/null
+++ b/sysutils/qjail4/Makefile
@@ -0,0 +1,51 @@
+# Created by: Joe Barbish
+# $FreeBSD$
+
+PORTNAME= qjail
+PORTVERSION= 4.9
+CATEGORIES= sysutils
+MASTER_SITES= SF/${PORTNAME}
+PKGNAMESUFFIX= 4
+
+MAINTAINER= qjail1@a1poweruser.com
+COMMENT= Utility to quickly deploy and manage jails
+
+LICENSE= BERNE-CONVENTION
+LICENSE_NAME= Berne Convention
+LICENSE_TEXT= As per the international "Berne Convention" this work is \
+ protected and all rights reserved. \
+ Before qjail may be forked, written permission must be \
+ obtained from the author <qjail1@a1poweruser.com>. \
+ This work is provided 'AS IS' and you use it at your own risk. \
+ Redistribution and use is permitted providing this license \
+ notice is retained.
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+USES= tar:bzip2
+NO_BUILD= yes
+NO_ARCH= yes
+
+CONFLICTS_INSTALL= qjail-*
+
+IGNORE_FreeBSD_9= Only for FreeBSD 10.x
+IGNORE_FreeBSD_11= Only for FreeBSD 10.x
+IGNORE_FreeBSD_12= Only for FreeBSD 10.x
+
+do-install:
+.for i in qjail qjail.vnet.be qjail.vnet.ng
+ ${INSTALL_SCRIPT} ${WRKSRC}/${i} ${STAGEDIR}${PREFIX}/bin
+.endfor
+ ${INSTALL_SCRIPT} ${WRKSRC}/qjail.bootime \
+ ${STAGEDIR}${PREFIX}/etc/rc.d
+ ${INSTALL_DATA} ${WRKSRC}/qjail.portsnap.conf \
+ ${STAGEDIR}${PREFIX}/etc/qjail.portsnap.conf.sample
+.for i in qjail qjail-intro qjail-howto
+ ${INSTALL_MAN} ${WRKSRC}/${i}.8 ${STAGEDIR}${MAN8PREFIX}/man/man8
+.endfor
+
+# note examples are mandatory. qjail will not function without them
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC}/examples/ \
+ && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR})
+
+.include <bsd.port.mk>
diff --git a/sysutils/qjail4/distinfo b/sysutils/qjail4/distinfo
new file mode 100644
index 000000000000..e48262345aeb
--- /dev/null
+++ b/sysutils/qjail4/distinfo
@@ -0,0 +1,2 @@
+SHA256 (qjail-4.9.tar.bz2) = 163d8893d431ab0699156db4a15c1c8927a71c4918014adb6006a8b6657cb49b
+SIZE (qjail-4.9.tar.bz2) = 66048
diff --git a/sysutils/qjail4/pkg-descr b/sysutils/qjail4/pkg-descr
new file mode 100644
index 000000000000..345a38fc4966
--- /dev/null
+++ b/sysutils/qjail4/pkg-descr
@@ -0,0 +1,34 @@
+This qjail version only supports the RELEASE-10.x series of releases.
+
+Qjail [ q = quick ] is a 4th generation wrapper for the basic chroot jail
+system that includes security and performance enhancements. Plus a new level
+of "user friendliness" enhancements dealing with deploying just a few jails or
+large scale jail environments consisting of 100's of jails.
+
+Qjail uses the jail(8) jail.conf method. This provides the ability to enable
+the following options on a per-jail basis. exec.fib, securelevel, allow.sysvipc,
+devfs_rulesets, allow.raw_sockets, allow.quotas, allow.mount.nullfs,
+allow.mount.tmpfs, allow.mount.zfs, vnet.interface, and vnet. The vnet option
+gives a jail its own network stack using the experimental vimage kernel module.
+The vnet option has only been tested on i386 and amd64 equipment.
+
+Qjail requires no knowledge of the jail command usage. It uses "nullfs" for
+read-only system executables, sharing one copy of them with all the jails.
+
+Uses "mdconfig" to create sparse image jails. Sparse image jails provide a
+method to limit the total disk space a jail can consume, while only occupying
+the physical disk space of the sum size of the files in the image jail.
+
+Ability to assign ip address with their network device name,
+so aliases are auto created on jail start and auto removed on jail stop.
+
+Ability to create "ZONE"s of identical qjail systems, each with their own
+group of jails.
+
+Ability to designate a portion of the jail name as a group prefix so the
+command being executed will apply to only those jail names matching that prefix.
+
+Qjail has been incorporated into the Finch open source project,
+see http://dreamcat4.github.io/finch/ for details.
+
+WWW: http://qjail.sourceforge.net/
diff --git a/sysutils/qjail4/pkg-message b/sysutils/qjail4/pkg-message
new file mode 100644
index 000000000000..305da69273dd
--- /dev/null
+++ b/sysutils/qjail4/pkg-message
@@ -0,0 +1,42 @@
+
+########################################################################
+
+Use the qjail utility to deploy small or large numbers of jails quickly.
+
+First issue "rehash" command to enable the qjail command (if using csh).
+Then issue "man qjail-intro" to read the qjail introduction.
+After reading that do "man qjail" for the usage details.
+For the BIG PICTURE issue "man qjail-howto".
+
+########################################################################
+
+For users who have existing qjail environments. Please take note.
+There are changes to the internals of the jail(8) command and changes to
+parameter names in the periodic files that have occured in FreeBSD
+Release 10.2 that effects jail behavior in a very minor way.
+IF your running qjail on an 10.2 or newer version of FreeBSD you should
+consider doing the following.
+
+This version of qjail has an built in auto convert function that you may select
+to choose that fixes those minor behavior problems with your existing jails.
+This auto convert function is not documented in the qjail manual. Its only
+shown here. So write it down.
+
+ Issue [ qjail update -u ] from the host console.
+
+This will cause the existing "flavors" default & ssh-default directories to be
+renamed and new ones populated. Then in each existing jail the periodic.conf
+and newsyslog.conf files will be renamed with .saved suffix and new ones added.
+The rc.conf file will be updated in place changing the
+syslogd_enable= parameter value from "NO" to "YES".
+
+The new periodic.conf file has many sendmail reporting options disabled because
+sendmail is disabled in the jails rc.conf file by default. This drastically
+reduces the daily. weekly, monthly system and security status reports elapse
+run times. This has a major effect on operating system performance where there
+are a large number of jails.
+
+The [ qjail install ] command will install all the correct files depending on
+what version of FreeBSD your host is running.
+
+########################################################################
diff --git a/sysutils/qjail4/pkg-plist b/sysutils/qjail4/pkg-plist
new file mode 100644
index 000000000000..9409c8e7bc16
--- /dev/null
+++ b/sysutils/qjail4/pkg-plist
@@ -0,0 +1,48 @@
+bin/qjail
+bin/qjail.vnet.be
+bin/qjail.vnet.ng
+@sample etc/qjail.portsnap.conf.sample
+etc/rc.d/qjail.bootime
+man/man8/qjail.8.gz
+man/man8/qjail-intro.8.gz
+man/man8/qjail-howto.8.gz
+%%EXAMPLESDIR%%/vnet/ipfw.rules.host
+%%EXAMPLESDIR%%/vnet/ipfw.rules.vnet
+%%EXAMPLESDIR%%/vnet/ipf.rules.host
+%%EXAMPLESDIR%%/vnet/ipf.rules.vnet
+%%EXAMPLESDIR%%/vnet/pf.rules.host
+%%EXAMPLESDIR%%/vnet/pf.rules.vnet
+%%EXAMPLESDIR%%/default/etc/make.conf
+%%EXAMPLESDIR%%/default/etc/motd
+%%EXAMPLESDIR%%/default/etc/periodic.conf
+%%EXAMPLESDIR%%/default/etc/periodic102.conf
+%%EXAMPLESDIR%%/default/etc/newsyslog102.conf
+%%EXAMPLESDIR%%/default/etc/rc.conf
+%%EXAMPLESDIR%%/default/etc/rc102.conf
+%%EXAMPLESDIR%%/default/root/.cshrc
+%%EXAMPLESDIR%%/default/usr/local/etc/pkg.conf
+%%EXAMPLESDIR%%/default/usr/local/etc/sudoers
+%%EXAMPLESDIR%%/ssh-default/etc/group
+%%EXAMPLESDIR%%/ssh-default/etc/make.conf
+%%EXAMPLESDIR%%/ssh-default/etc/master.passwd
+%%EXAMPLESDIR%%/ssh-default/etc/motd
+%%EXAMPLESDIR%%/ssh-default/etc/passwd
+%%EXAMPLESDIR%%/ssh-default/etc/periodic.conf
+%%EXAMPLESDIR%%/ssh-default/etc/periodic102.conf
+%%EXAMPLESDIR%%/ssh-default/etc/newsyslog102.conf
+%%EXAMPLESDIR%%/ssh-default/etc/pwd.db
+%%EXAMPLESDIR%%/ssh-default/etc/rc.conf
+%%EXAMPLESDIR%%/ssh-default/etc/rc102.conf
+%%EXAMPLESDIR%%/ssh-default/etc/spwd.db
+%%EXAMPLESDIR%%/ssh-default/etc/ssh/sshd_config
+%%EXAMPLESDIR%%/ssh-default/root/.cshrc
+%%EXAMPLESDIR%%/ssh-default/usr/home/qjail/.cshrc
+%%EXAMPLESDIR%%/ssh-default/usr/home/qjail/.login
+%%EXAMPLESDIR%%/ssh-default/usr/home/qjail/.login_conf
+%%EXAMPLESDIR%%/ssh-default/usr/home/qjail/.mail_aliases
+%%EXAMPLESDIR%%/ssh-default/usr/home/qjail/.mailrc
+%%EXAMPLESDIR%%/ssh-default/usr/home/qjail/.profile
+%%EXAMPLESDIR%%/ssh-default/usr/home/qjail/.rhosts
+%%EXAMPLESDIR%%/ssh-default/usr/home/qjail/.shrc
+%%EXAMPLESDIR%%/ssh-default/usr/local/etc/pkg.conf
+%%EXAMPLESDIR%%/ssh-default/usr/local/etc/sudoers