aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/p5-Graph-Easy/Makefile32
-rw-r--r--graphics/p5-Graph-Easy/pkg-plist29
-rw-r--r--security/p5-Digest-Whirlpool/Makefile4
-rw-r--r--security/p5-Digest-Whirlpool/pkg-plist2
-rw-r--r--www/p5-Plack-Middleware-AutoRefresh/Makefile3
-rw-r--r--www/p5-Plack-Middleware-AutoRefresh/pkg-plist1
6 files changed, 32 insertions, 39 deletions
diff --git a/graphics/p5-Graph-Easy/Makefile b/graphics/p5-Graph-Easy/Makefile
index 3c9bdeabd073..0bef61c4264c 100644
--- a/graphics/p5-Graph-Easy/Makefile
+++ b/graphics/p5-Graph-Easy/Makefile
@@ -16,36 +16,4 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
-MAN1= graph-easy.1
-
-MAN3= Graph::Easy.3 \
- Graph::Easy::As_ascii.3 \
- Graph::Easy::As_graphml.3 \
- Graph::Easy::As_graphviz.3 \
- Graph::Easy::As_txt.3 \
- Graph::Easy::As_vcg.3 \
- Graph::Easy::Attributes.3 \
- Graph::Easy::Base.3 \
- Graph::Easy::Edge.3 \
- Graph::Easy::Edge::Cell.3 \
- Graph::Easy::Group.3 \
- Graph::Easy::Group::Anon.3 \
- Graph::Easy::Group::Cell.3 \
- Graph::Easy::Layout.3 \
- Graph::Easy::Layout::Chain.3 \
- Graph::Easy::Layout::Force.3 \
- Graph::Easy::Layout::Grid.3 \
- Graph::Easy::Layout::Path.3 \
- Graph::Easy::Layout::Repair.3 \
- Graph::Easy::Layout::Scout.3 \
- Graph::Easy::Node.3 \
- Graph::Easy::Node::Anon.3 \
- Graph::Easy::Node::Cell.3 \
- Graph::Easy::Node::Empty.3 \
- Graph::Easy::Parser.3 \
- Graph::Easy::Parser::Graphviz.3 \
- Graph::Easy::Parser::VCG.3 \
- Graph::Easy::Util.3
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/graphics/p5-Graph-Easy/pkg-plist b/graphics/p5-Graph-Easy/pkg-plist
index 1eacb50e5f91..a955c03a284f 100644
--- a/graphics/p5-Graph-Easy/pkg-plist
+++ b/graphics/p5-Graph-Easy/pkg-plist
@@ -28,6 +28,35 @@ bin/graph-easy
%%SITE_PERL%%/Graph/Easy/Parser/Graphviz.pm
%%SITE_PERL%%/Graph/Easy/Parser/VCG.pm
%%SITE_PERL%%/Graph/Easy/Util.pm
+%%PERL5_MAN3%%/Graph::Easy.3.gz
+%%PERL5_MAN3%%/Graph::Easy::As_ascii.3.gz
+%%PERL5_MAN3%%/Graph::Easy::As_graphml.3.gz
+%%PERL5_MAN3%%/Graph::Easy::As_graphviz.3.gz
+%%PERL5_MAN3%%/Graph::Easy::As_txt.3.gz
+%%PERL5_MAN3%%/Graph::Easy::As_vcg.3.gz
+%%PERL5_MAN3%%/Graph::Easy::Attributes.3.gz
+%%PERL5_MAN3%%/Graph::Easy::Base.3.gz
+%%PERL5_MAN3%%/Graph::Easy::Edge.3.gz
+%%PERL5_MAN3%%/Graph::Easy::Edge::Cell.3.gz
+%%PERL5_MAN3%%/Graph::Easy::Group.3.gz
+%%PERL5_MAN3%%/Graph::Easy::Group::Anon.3.gz
+%%PERL5_MAN3%%/Graph::Easy::Group::Cell.3.gz
+%%PERL5_MAN3%%/Graph::Easy::Layout.3.gz
+%%PERL5_MAN3%%/Graph::Easy::Layout::Chain.3.gz
+%%PERL5_MAN3%%/Graph::Easy::Layout::Force.3.gz
+%%PERL5_MAN3%%/Graph::Easy::Layout::Grid.3.gz
+%%PERL5_MAN3%%/Graph::Easy::Layout::Path.3.gz
+%%PERL5_MAN3%%/Graph::Easy::Layout::Repair.3.gz
+%%PERL5_MAN3%%/Graph::Easy::Layout::Scout.3.gz
+%%PERL5_MAN3%%/Graph::Easy::Node.3.gz
+%%PERL5_MAN3%%/Graph::Easy::Node::Anon.3.gz
+%%PERL5_MAN3%%/Graph::Easy::Node::Cell.3.gz
+%%PERL5_MAN3%%/Graph::Easy::Node::Empty.3.gz
+%%PERL5_MAN3%%/Graph::Easy::Parser.3.gz
+%%PERL5_MAN3%%/Graph::Easy::Parser::Graphviz.3.gz
+%%PERL5_MAN3%%/Graph::Easy::Parser::VCG.3.gz
+%%PERL5_MAN3%%/Graph::Easy::Util.3.gz
+man/man1/graph-easy.1.gz
@dirrmtry %%SITE_PERL%%/Graph/Easy/Parser
@dirrmtry %%SITE_PERL%%/Graph/Easy/Node
@dirrmtry %%SITE_PERL%%/Graph/Easy/Layout
diff --git a/security/p5-Digest-Whirlpool/Makefile b/security/p5-Digest-Whirlpool/Makefile
index 08f034606363..f05b0d964588 100644
--- a/security/p5-Digest-Whirlpool/Makefile
+++ b/security/p5-Digest-Whirlpool/Makefile
@@ -16,8 +16,4 @@ RUN_DEPENDS= p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64
USES= perl5
USE_PERL5= configure
-MAN1= whirlpoolsum.1
-MAN3= Digest::Whirlpool.3
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/security/p5-Digest-Whirlpool/pkg-plist b/security/p5-Digest-Whirlpool/pkg-plist
index 76fe335872e7..49862143895b 100644
--- a/security/p5-Digest-Whirlpool/pkg-plist
+++ b/security/p5-Digest-Whirlpool/pkg-plist
@@ -3,6 +3,8 @@
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/Whirlpool/Whirlpool.bs
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/Whirlpool/Whirlpool.so
bin/whirlpoolsum
+%%PERL5_MAN3%%/Digest::Whirlpool.3.gz
+man/man1/whirlpoolsum.1.gz
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/Whirlpool
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Digest/
diff --git a/www/p5-Plack-Middleware-AutoRefresh/Makefile b/www/p5-Plack-Middleware-AutoRefresh/Makefile
index 2179c70e54c3..eefd4f83cd8f 100644
--- a/www/p5-Plack-Middleware-AutoRefresh/Makefile
+++ b/www/p5-Plack-Middleware-AutoRefresh/Makefile
@@ -22,7 +22,4 @@ BUILD_DEPENDS:= ${RUN_DEPENDS}
USES= perl5
USE_PERL5= modbuild
-MAN3= Plack::Middleware::AutoRefresh.3
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/www/p5-Plack-Middleware-AutoRefresh/pkg-plist b/www/p5-Plack-Middleware-AutoRefresh/pkg-plist
index dec3e6909287..fadff127492e 100644
--- a/www/p5-Plack-Middleware-AutoRefresh/pkg-plist
+++ b/www/p5-Plack-Middleware-AutoRefresh/pkg-plist
@@ -1,5 +1,6 @@
%%SITE_PERL%%/Plack/Middleware/AutoRefresh.pm
%%SITE_PERL%%/auto/share/dist/Plack-Middleware-AutoRefresh/js/plackAutoRefresh.js
%%SITE_PERL%%/auto/share/dist/Plack-Middleware-AutoRefresh/js/plackAutoRefresh.min.js
+%%PERL5_MAN3%%/Plack::Middleware::AutoRefresh.3.gz
@dirrm %%SITE_PERL%%/auto/share/dist/Plack-Middleware-AutoRefresh/js
@dirrm %%SITE_PERL%%/auto/share/dist/Plack-Middleware-AutoRefresh