aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Regexp-Compare/Makefile21
-rw-r--r--devel/p5-Regexp-Compare/distinfo2
-rw-r--r--devel/p5-Regexp-Compare/pkg-descr11
-rw-r--r--devel/p5-Regexp-Compare/pkg-plist7
5 files changed, 42 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 543a25b52fcf..7fd768f01297 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2244,6 +2244,7 @@
SUBDIR += p5-Regexp-Assemble
SUBDIR += p5-Regexp-Assemble-Compressed
SUBDIR += p5-Regexp-Bind
+ SUBDIR += p5-Regexp-Compare
SUBDIR += p5-Regexp-Grammars
SUBDIR += p5-Regexp-RegGrp
SUBDIR += p5-Regexp-Shellish
diff --git a/devel/p5-Regexp-Compare/Makefile b/devel/p5-Regexp-Compare/Makefile
new file mode 100644
index 000000000000..2497ad1b4b4e
--- /dev/null
+++ b/devel/p5-Regexp-Compare/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-Regexp-Compare
+# Date created: 2011-09-11
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Regexp-Compare
+PORTVERSION= 0.17
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Partial ordering for regular expressions
+
+PERL_CONFIGURE= yes
+
+MAN3= Regexp::Compare.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Regexp-Compare/distinfo b/devel/p5-Regexp-Compare/distinfo
new file mode 100644
index 000000000000..2b56eaf6ce9a
--- /dev/null
+++ b/devel/p5-Regexp-Compare/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Regexp-Compare-0.17.tar.gz) = 325ff00f81ace8405ebfe9118a3e1bfee3bf797dd20c9b24f49984f2c4025fb6
+SIZE (Regexp-Compare-0.17.tar.gz) = 54089
diff --git a/devel/p5-Regexp-Compare/pkg-descr b/devel/p5-Regexp-Compare/pkg-descr
new file mode 100644
index 000000000000..b8773946ce08
--- /dev/null
+++ b/devel/p5-Regexp-Compare/pkg-descr
@@ -0,0 +1,11 @@
+Regexp::Compare implements a function comparing regular expressions: it returns
+true if all strings matched by the first regexp are also matched by the second.
+It's meant to be used for optimization of blacklists implemented by regular
+expressions (like, for example, http://www.communitywiki.org/cw/BannedContent).
+
+False return value does not imply that there's a string matched by the first
+regexp which isn't matched by the second - many regular expressions (i.e. those
+containing Perl code) are impossible to compare, and this module doesn't even
+implement all possible comparisons.
+
+WWW: http://search.cpan.org/dist/Regexp-Compare/
diff --git a/devel/p5-Regexp-Compare/pkg-plist b/devel/p5-Regexp-Compare/pkg-plist
new file mode 100644
index 000000000000..083b1826da14
--- /dev/null
+++ b/devel/p5-Regexp-Compare/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Regexp/Compare.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Regexp/Compare/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Regexp/Compare/Compare.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Regexp/Compare/Compare.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Regexp/Compare
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Regexp
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Regexp