aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-backports.tempfile/Makefile21
-rw-r--r--devel/py-backports.tempfile/distinfo3
-rw-r--r--devel/py-backports.tempfile/pkg-descr16
4 files changed, 41 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ef027b9caf26..30cf11013e24 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4265,6 +4265,7 @@
SUBDIR += py-backports.shutil_get_terminal_size
SUBDIR += py-backports.weakref
SUBDIR += py-backports_abc
+ SUBDIR += py-backports.tempfile
SUBDIR += py-bandit
SUBDIR += py-bcdoc
SUBDIR += py-billiard
diff --git a/devel/py-backports.tempfile/Makefile b/devel/py-backports.tempfile/Makefile
new file mode 100644
index 000000000000..fb7e13d2d215
--- /dev/null
+++ b/devel/py-backports.tempfile/Makefile
@@ -0,0 +1,21 @@
+# Created by: Dan Langille <dvl@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= backports.tempfile
+PORTVERSION= 1.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= dvl@FreeBSD.org
+COMMENT= Backports of new features in the Python tempfile module
+
+LICENSE= PSFL
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm
+
+NO_ARCH= yes
+USES= python:2.7
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/devel/py-backports.tempfile/distinfo b/devel/py-backports.tempfile/distinfo
new file mode 100644
index 000000000000..b61833b29a1c
--- /dev/null
+++ b/devel/py-backports.tempfile/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1511989773
+SHA256 (backports.tempfile-1.0.tar.gz) = 1c648c452e8770d759bdc5a5e2431209be70d25484e1be24876cf2168722c762
+SIZE (backports.tempfile-1.0.tar.gz) = 10262
diff --git a/devel/py-backports.tempfile/pkg-descr b/devel/py-backports.tempfile/pkg-descr
new file mode 100644
index 000000000000..5ec12b0b823c
--- /dev/null
+++ b/devel/py-backports.tempfile/pkg-descr
@@ -0,0 +1,16 @@
+Yet another general purpose Naive Bayesian classifier.
+(under heavy development)
+
+Naive Bayes Classifier is probably the most widely used text classifier,
+it's a supervised learning algorithm. It can be used to classify blog posts
+or news articles into different categories like sports, entertainment and
+so forth.
+
+Naive Bayes is a simple technique for constructing classifiers: models that
+assign class labels to problem instances, represented as vectors of feature
+values, where the class labels are drawn from some finite set. It is not a
+single algorithm for training such classifiers, but a family of algorithms
+This package provides backports of new features in Python???s tempfile module
+under the backports namespace.
+
+WWW: https://github.com/pjdelport/backports.tempfile