aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--astro/tclgeomap/Makefile5
-rw-r--r--astro/tkgeomap/Makefile5
-rw-r--r--audio/snack/Makefile5
-rw-r--r--databases/casstcl/Makefile5
-rw-r--r--databases/pgtcl/Makefile8
-rw-r--r--databases/pgtcl/pkg-descr2
-rw-r--r--databases/speedtables/Makefile7
-rw-r--r--databases/tcl-lmdb/Makefile15
-rw-r--r--databases/tcl-sqlite3/Makefile5
-rw-r--r--databases/tdbc/Makefile8
-rw-r--r--devel/gcvs/Makefile5
-rw-r--r--devel/yajl-tcl/Makefile12
-rw-r--r--devel/ztcl/Makefile9
13 files changed, 30 insertions, 61 deletions
diff --git a/astro/tclgeomap/Makefile b/astro/tclgeomap/Makefile
index e001ce6be531..152732688b8a 100644
--- a/astro/tclgeomap/Makefile
+++ b/astro/tclgeomap/Makefile
@@ -11,10 +11,7 @@ COMMENT= Read, manipulate, and display geo data
LICENSE= GPLv2
-USES+= tcl
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} \
- --with-tclinclude=${TCL_INCLUDEDIR}
+USES+= tcl:tea
WRKSRC= ${WRKDIR}/${DISTNAME}/unix
USE_LDCONFIG= yes
diff --git a/astro/tkgeomap/Makefile b/astro/tkgeomap/Makefile
index 24f9fd25ea8e..0c89251561b3 100644
--- a/astro/tkgeomap/Makefile
+++ b/astro/tkgeomap/Makefile
@@ -13,11 +13,8 @@ LICENSE= GPLv2
LIB_DEPENDS= libtclgeomap.so:astro/tclgeomap
-USES+= tk
-GNU_CONFIGURE= yes
+USES+= tk:tea
CONFIGURE_ARGS= --with-tclgeomap-include=${LOCALBASE}/include/tclgeomap --with-x \
- --with-tcl=${TCL_LIBDIR} --with-tclinclude=${TCL_INCLUDEDIR} \
- --with-tk=${TK_LIBDIR} --with-tkinclude=${TK_INCLUDEDIR} \
--x-libraries=${LOCALBASE}/lib --x-includes=${LOCALBASE}/include
MAKE_ENV+= TCLGEOMAP_LIB="-L ${LOCALBASE}/lib -ltclgeomap"
WRKSRC= ${WRKDIR}/${DISTNAME}/unix
diff --git a/audio/snack/Makefile b/audio/snack/Makefile
index 1f6673add091..29c9593f0dc2 100644
--- a/audio/snack/Makefile
+++ b/audio/snack/Makefile
@@ -14,11 +14,8 @@ COMMENT= Sound toolkit for scripting languages
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/../COPYING
-USES= tk
+USES= tk:tea
USE_LDCONFIG= ${PREFIX}/lib/snack${PORTVERSION:R}
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} \
- --with-tk=${TK_LIBDIR}
MAKE_ENV= prefix=${PREFIX} exec_prefix=${PREFIX}
WRKSRC= ${WRKDIR}/${DISTNAME}/unix
diff --git a/databases/casstcl/Makefile b/databases/casstcl/Makefile
index 00846dcd340f..a56b4cc125e3 100644
--- a/databases/casstcl/Makefile
+++ b/databases/casstcl/Makefile
@@ -13,10 +13,7 @@ LICENSE= BSD3CLAUSE
LIB_DEPENDS= libcassandra.so:databases/cassandra-cpp-driver
-USES= autoreconf tcl:85+
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} \
- --exec-prefix=${PREFIX}
+USES= autoreconf tcl:85+,tea
USE_GITHUB= yes
GH_ACCOUNT= flightaware
diff --git a/databases/pgtcl/Makefile b/databases/pgtcl/Makefile
index fb21096092b8..59a876525ec3 100644
--- a/databases/pgtcl/Makefile
+++ b/databases/pgtcl/Makefile
@@ -19,12 +19,12 @@ LICENSE_FILE= ${WRKSRC}/COPYRIGHT
OPTIONS_DEFINE= DOCS
.if defined(PGTCL_SLAVE)
-USES= pgsql:${PGTCL_SLAVE} tcl
+USES= pgsql:${PGTCL_SLAVE}
.else
-USES= pgsql tcl
+USES= pgsql
.endif
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--with-tcl=${TCL_LIBDIR} --with-tclinclude=${TCL_INCLUDEDIR}
+
+USES+= tcl:tea
LIBDIR= ${PREFIX}/lib/${PORTNAME}
USE_LDCONFIG= ${LIBDIR}
PLIST_SUB+= PORTVERSION=${PORTVERSION}
diff --git a/databases/pgtcl/pkg-descr b/databases/pgtcl/pkg-descr
index 13ddba0f99c5..814a0be216db 100644
--- a/databases/pgtcl/pkg-descr
+++ b/databases/pgtcl/pkg-descr
@@ -2,4 +2,4 @@ A TCL extension for accessing PostgreSQL databases. This used
to come bunlded with PostgreSQL itself, but was split into a
separate project in more recent version (8+).
-WWW: http://pgfoundry.org/projects/pgtclng/
+WWW: http://pgfoundry.org/projects/pgtclng/
diff --git a/databases/speedtables/Makefile b/databases/speedtables/Makefile
index b68fa25b9cc7..e27237bf22fd 100644
--- a/databases/speedtables/Makefile
+++ b/databases/speedtables/Makefile
@@ -18,11 +18,8 @@ LIB_DEPENDS= libtclx8.4.so:lang/tclX \
USE_GITHUB= yes
GH_ACCOUNT= flightaware
-USES= autoreconf tcl
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--exec-prefix=${PREFIX} \
- --with-boost=${PREFIX} \
- --with-tcl=${TCL_LIBDIR}
+USES= autoreconf tcl:tea
+CONFIGURE_ARGS= --with-boost=${LOCALBASE}
PORTDOCS= *
diff --git a/databases/tcl-lmdb/Makefile b/databases/tcl-lmdb/Makefile
index a96d50f52ea2..6770ae044a4f 100644
--- a/databases/tcl-lmdb/Makefile
+++ b/databases/tcl-lmdb/Makefile
@@ -15,22 +15,17 @@ LIB_DEPENDS= liblmdb.so:databases/lmdb
USE_GITHUB= yes
GH_ACCOUNT= ray2501
-USES= gmake tcl
-GNU_CONFIGURE= yes
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS+=--with-tcl=${TCL_LIBDIR} --with-system-lmdb
-CONFIGURE_ENV+= CPPFLAGS="${CFLAGS}"
+USES= gmake tcl:tea
+CONFIGURE_ARGS= --with-system-lmdb
TEST_TARGET= test
-TCLPKG= lmdb${PORTVERSION}
-PLIST_FILES= lib/${TCLPKG}/lib${TCLPKG}.so \
- lib/${TCLPKG}/pkgIndex.tcl \
+PLIST_FILES= lib/${TCL_PKG}/lib${TCL_PKG}.so \
+ lib/${TCL_PKG}/pkgIndex.tcl \
man/mann/lmdb.n.gz
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/${TCLPKG}/lib${TCLPKG}.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/${TCL_PKG}/lib${TCL_PKG}.so
.include <bsd.port.mk>
diff --git a/databases/tcl-sqlite3/Makefile b/databases/tcl-sqlite3/Makefile
index 9940516c77fe..6b0070968ee6 100644
--- a/databases/tcl-sqlite3/Makefile
+++ b/databases/tcl-sqlite3/Makefile
@@ -19,14 +19,13 @@ OPTIONS_DEFAULT= THREADS
WRKSRC= ${WRKDIR}/${DISTNAME}/tea
-USES= pkgconfig tcl
+USES= pkgconfig tcl:tea
USE_LDCONFIG= yes
-GNU_CONFIGURE= yes
CFLAGS+= -Os
CFLAGS+= `pkg-config --cflags sqlite3`
LDFLAGS+= `pkg-config --libs sqlite3`
-CONFIGURE_ARGS+= --with-tcl=${TCL_LIBDIR} --with-system-sqlite
+CONFIGURE_ARGS= --with-system-sqlite
THREADS_CONFIGURE_ENABLE= threads
diff --git a/databases/tdbc/Makefile b/databases/tdbc/Makefile
index 40ce5b61bef9..54ee01589987 100644
--- a/databases/tdbc/Makefile
+++ b/databases/tdbc/Makefile
@@ -20,12 +20,12 @@ OPTIONS_DEFINE= MYSQL PGSQL SQLITE ODBC
OPTIONS_DEFAULT=MYSQL PGSQL SQLITE ODBC
OPTIONS_SUB= yes
-USES= tcl:86
+USES= tcl:86,tea
USE_LDCONFIG= yes
MAKE_ENV+= DESTDIR=${STAGEDIR}
-CONFIGURE_ARGS+=--with-tcl=${TCL_LIBDIR} --with-tcloo=${TCL_LIBDIR} \
- --prefix=${PREFIX} --exec-prefix=${PREFIX} \
- --with-tdbc=${WRKDIR}/tdbc${PORTVERSION} --enable-threads \
+CONFIGURE_ARGS+=--with-tcloo=${TCL_LIBDIR} \
+ --with-tdbc=${WRKDIR}/tdbc${PORTVERSION} \
+ --enable-threads \
--mandir=${PREFIX}/man \
--includedir=${PREFIX}/include/tdbc
PLIST_SUB+= VERSION=${DISTVERSION} \
diff --git a/devel/gcvs/Makefile b/devel/gcvs/Makefile
index 3921d32145d9..717c6b45b9b1 100644
--- a/devel/gcvs/Makefile
+++ b/devel/gcvs/Makefile
@@ -14,11 +14,8 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
USE_GNOME= gtk12
-USES= autoreconf gmake tk:wrapper
-GNU_CONFIGURE= yes
+USES= autoreconf gmake tk:wrapper,tea
CXXFLAGS:= ${CXXFLAGS:N-std=*:N:}
-CONFIGURE_ARGS= --with-tclinclude=${TCL_INCLUDEDIR} \
- --with-tcllib=${TCL_LIBDIR}
EXTRACT_AFTER_ARGS=--exclude cvsunix --exclude 'getline.[ch]' --exclude 'getopt*.[ch]'
post-patch:
diff --git a/devel/yajl-tcl/Makefile b/devel/yajl-tcl/Makefile
index 25eaaea393b6..c4d0904d7628 100644
--- a/devel/yajl-tcl/Makefile
+++ b/devel/yajl-tcl/Makefile
@@ -16,17 +16,13 @@ LIB_DEPENDS= libyajl.so:devel/yajl
USE_GITHUB= yes
GH_ACCOUNT= flightaware
-USES+= pkgconfig tcl:85+
-USE_AUTOTOOLS= autoconf
-CONFIGURE_ARGS+=--with-tcl=${TCL_LIBDIR} \
- --exec-prefix=${PREFIX}
+USES+= autoreconf pkgconfig tcl:85+,tea
+
+TEST_TARGET= test
+TEST_DEPENDS= dtplite:devel/tcllib
PLIST_FILES= lib/yajltcl${PORTVERSION}/libyajltcl.so.1 \
lib/yajltcl${PORTVERSION}/pkgIndex.tcl \
lib/yajltcl${PORTVERSION}/yajl.tcl
-regression-test: build
-# Requires devel/tcllib
- cd ${WRKSRC} && ${MAKE} test
-
.include <bsd.port.mk>
diff --git a/devel/ztcl/Makefile b/devel/ztcl/Makefile
index a5c1919b6cf9..ce7c6bb936e5 100644
--- a/devel/ztcl/Makefile
+++ b/devel/ztcl/Makefile
@@ -17,19 +17,16 @@ LIB_DEPENDS= libtclmore0.so:devel/tclmore
OPTIONS_DEFINE= DOCS
-USES= gmake tcl
-GNU_CONFIGURE= yes
+USES= gmake tcl:tea
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${DISTNAME:S/_src$//}
INFO= ${PORTNAME} ${PORTNAME}-zlib
-CONFIGURE_ARGS+=--with-tcl=${TCL_LIBDIR} \
- --with-tclinclude=${TCL_INCLUDEDIR} \
- --with-tclmorescripts=${LOCALBASE}/libexec/tclmore \
+CONFIGURE_ARGS= --with-tclmorescripts=${LOCALBASE}/libexec/tclmore \
--enable-threads
MAKE_ENV+= STAGEDIR=${STAGEDIR}
-CPPFLAGS+= -I ${LOCALBASE}/include -I ${TCL_INCLUDEDIR}
+CPPFLAGS+= -I ${LOCALBASE}/include
LDFLAGS+= -L ${LOCALBASE}/lib
PORTDOCS= *