aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING10
-rw-r--r--security/tor-devel/Makefile3
-rw-r--r--security/tor-devel/files/tor.in13
-rw-r--r--security/tor/Makefile3
-rw-r--r--security/tor/files/tor.in13
5 files changed, 18 insertions, 24 deletions
diff --git a/UPDATING b/UPDATING
index 24e03c4b78f9..8c89ebd8c10c 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,16 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20151217:
+ AFFECTS: users of security/tor, security/tor-devel
+ AUTHOR: amdmi3
+
+ Tor rc.d script no longer overrides or forces logfile configuration,
+ you now need to setup logging by hand. To preserve old behavior, add
+ the following line to /usr/local/etc/tor/torrc:
+
+ Log notice file /var/log/tor
+
20151215:
AFFECTS: All users of www/node
AUTHOR: koobs
diff --git a/security/tor-devel/Makefile b/security/tor-devel/Makefile
index c02851d8b8cb..4ae8bb4f3a89 100644
--- a/security/tor-devel/Makefile
+++ b/security/tor-devel/Makefile
@@ -2,7 +2,8 @@
# $FreeBSD$
PORTNAME= tor
-DISTVERSION= 0.2.6.7
+PORTVERSION= 0.2.6.7
+PORTREVISION= 1
CATEGORIES= security net ipv6
MASTER_SITES= TOR
PKGNAMESUFFIX= -devel
diff --git a/security/tor-devel/files/tor.in b/security/tor-devel/files/tor.in
index 54c37308d478..3ea0285e0418 100644
--- a/security/tor-devel/files/tor.in
+++ b/security/tor-devel/files/tor.in
@@ -15,8 +15,6 @@
# Default: %%PREFIX%%/etc/tor/torrc
# tor_user (str): Tor daemon user. Default: _tor
# tor_datadir (str): Tor datadir. Default: /var/db/tor
-# tor_logfile (str): Tor log file. Default: /var/log/tor
-# tor_loglevel (str): Tor log severity level. Default: notice
#
. /etc/rc.subr
@@ -30,21 +28,14 @@ load_rc_config ${name}
: ${tor_conf="%%PREFIX%%/etc/tor/torrc"}
: ${tor_user="_tor"}
: ${tor_pidfile="/var/run/tor/tor.pid"}
-: ${tor_logfile="/var/log/tor"}
-: ${tor_loglevel="notice"}
: ${tor_datadir="/var/db/tor"}
required_files=${tor_conf}
required_dirs=${tor_datadir}
pidfile=${tor_pidfile}
command="%%PREFIX%%/bin/${name}"
-command_args="-f ${tor_conf} --PidFile ${tor_pidfile} --RunAsDaemon 1 --DataDirectory ${tor_datadir} --+Log ${tor_loglevel}\ file\ ${tor_logfile}"
-extra_commands="log reload"
-log_cmd="${name}_log"
-
-tor_log() {
- cat ${tor_logfile}
-}
+command_args="-f ${tor_conf} --PidFile ${tor_pidfile} --RunAsDaemon 1 --DataDirectory ${tor_datadir}"
+extra_commands="reload"
run_rc_command "$1"
diff --git a/security/tor/Makefile b/security/tor/Makefile
index ffca68ed1560..03a08be44eba 100644
--- a/security/tor/Makefile
+++ b/security/tor/Makefile
@@ -2,7 +2,8 @@
# $FreeBSD$
PORTNAME= tor
-DISTVERSION= 0.2.6.10
+PORTVERSION= 0.2.6.10
+PORTREVISION= 1
CATEGORIES= security net ipv6
MASTER_SITES= TOR
diff --git a/security/tor/files/tor.in b/security/tor/files/tor.in
index 54c37308d478..3ea0285e0418 100644
--- a/security/tor/files/tor.in
+++ b/security/tor/files/tor.in
@@ -15,8 +15,6 @@
# Default: %%PREFIX%%/etc/tor/torrc
# tor_user (str): Tor daemon user. Default: _tor
# tor_datadir (str): Tor datadir. Default: /var/db/tor
-# tor_logfile (str): Tor log file. Default: /var/log/tor
-# tor_loglevel (str): Tor log severity level. Default: notice
#
. /etc/rc.subr
@@ -30,21 +28,14 @@ load_rc_config ${name}
: ${tor_conf="%%PREFIX%%/etc/tor/torrc"}
: ${tor_user="_tor"}
: ${tor_pidfile="/var/run/tor/tor.pid"}
-: ${tor_logfile="/var/log/tor"}
-: ${tor_loglevel="notice"}
: ${tor_datadir="/var/db/tor"}
required_files=${tor_conf}
required_dirs=${tor_datadir}
pidfile=${tor_pidfile}
command="%%PREFIX%%/bin/${name}"
-command_args="-f ${tor_conf} --PidFile ${tor_pidfile} --RunAsDaemon 1 --DataDirectory ${tor_datadir} --+Log ${tor_loglevel}\ file\ ${tor_logfile}"
-extra_commands="log reload"
-log_cmd="${name}_log"
-
-tor_log() {
- cat ${tor_logfile}
-}
+command_args="-f ${tor_conf} --PidFile ${tor_pidfile} --RunAsDaemon 1 --DataDirectory ${tor_datadir}"
+extra_commands="reload"
run_rc_command "$1"