aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/xfce4-mpc-plugin/Makefile11
-rw-r--r--deskutils/xfce4-notifyd/Makefile2
-rw-r--r--multimedia/xfce4-media/Makefile13
-rw-r--r--sysutils/xfburn/Makefile13
-rw-r--r--sysutils/xfce4-settings/Makefile19
-rw-r--r--x11-wm/xfce4-desktop/Makefile17
-rw-r--r--x11-wm/xfce4-panel/Makefile13
-rw-r--r--x11/Terminal/Makefile9
-rw-r--r--x11/xfce4-clipman-plugin/Makefile5
-rw-r--r--x11/xfce4-screenshooter-plugin/Makefile12
-rw-r--r--x11/xfce4-verve-plugin/Makefile9
11 files changed, 56 insertions, 67 deletions
diff --git a/audio/xfce4-mpc-plugin/Makefile b/audio/xfce4-mpc-plugin/Makefile
index e4bcc2097f8f..cd96b0b6e441 100644
--- a/audio/xfce4-mpc-plugin/Makefile
+++ b/audio/xfce4-mpc-plugin/Makefile
@@ -1,12 +1,10 @@
-# New ports collection makefile for: mpc plugin for xfce4
-# Date created: 12 July 2006
-# Whom: Martin Wilke (miwi@FreeBSD.org)
-#
+# Created by: Martin Wilke (miwi@FreeBSD.org)
# $FreeBSD$
#
PORTNAME= xfce4-mpc-plugin
PORTVERSION= 0.4.4
+PORTREVISION= 1
CATEGORIES= audio xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR=src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
@@ -15,13 +13,14 @@ DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
COMMENT= An MPC plugin for Xfce
-LIB_DEPENDS= mpd.4:${PORTSDIR}/audio/libmpd
+LIB_DEPENDS= mpd:${PORTSDIR}/audio/libmpd
USE_BZIP2= yes
USE_GMAKE= yes
USE_GETTEXT= yes
GNU_CONFIGURE= yes
-USE_GNOME= gtk20 intltool intlhack pkgconfig
+USE_GNOME= gtk20 intltool intlhack
USE_XFCE= configenv libexo libmenu panel
+USE_PKGCONFIG= build
.include <bsd.port.mk>
diff --git a/deskutils/xfce4-notifyd/Makefile b/deskutils/xfce4-notifyd/Makefile
index 90c663416424..b85488bd06db 100644
--- a/deskutils/xfce4-notifyd/Makefile
+++ b/deskutils/xfce4-notifyd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xfce4-notifyd
PORTVERSION= 0.2.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= deskutils xfce
MASTER_SITES= XFCE
MASTER_SITE_SUBDIR= src/apps/${PORTNAME}/${PORTVERSION:R}
diff --git a/multimedia/xfce4-media/Makefile b/multimedia/xfce4-media/Makefile
index 4965821c2055..2e0c31b28ee6 100644
--- a/multimedia/xfce4-media/Makefile
+++ b/multimedia/xfce4-media/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xfce4-media
PORTVERSION= 0.9.2
-PORTREVISION= 25
+PORTREVISION= 26
CATEGORIES= multimedia xfce
MASTER_SITES= http://spuriousinterrupt.org/files/xfmedia/
DISTNAME= xfmedia-${PORTVERSION}
@@ -12,16 +12,17 @@ DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
COMMENT= Lightweight media player for Xfce4 based on the xine engine
-LIB_DEPENDS= xine.2:${PORTSDIR}/multimedia/libxine
+LIB_DEPENDS= xine:${PORTSDIR}/multimedia/libxine
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_GNOME= glib20 gnomehack gtk20 intltool intlhack pkgconfig
+USE_GNOME= glib20 gnomehack gtk20 intltool intlhack
USE_XFCE= configenv libexo libgui libutil panel
USE_XORG= x11 sm
+USE_PKGCONFIG= build
OPTIONS_DEFINE= TAGLIB DBUS STARTUP
OPTIONS_DEFAULT= DBUS STARTUP
@@ -32,21 +33,21 @@ STARTUP_DESC= startup notification support
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MTABLIB}
-LIB_DEPENDS+= tag.1:${PORTSDIR}/audio/taglib
+LIB_DEPENDS+= tag:${PORTSDIR}/audio/taglib
CONFIGURE_ARGS+=--with-taglib
.else
CONFIGURE_ARGS+=--without-taglib
.endif
.if ${PORT_OPTIONS:MDBUS}
-LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+LIB_DEPENDS+= dbus-glib-1:${PORTSDIR}/devel/dbus-glib
CONFIGURE_ARGS+=--enable-dbus
.else
CONFIGURE_ARGS+=--disable-dbus
.endif
.if ${PORT_OPTIONS:MSTARTUP}
-LIB_DEPENDS+= startup-notification-1.0:${PORTSDIR}/x11/startup-notification
+LIB_DEPENDS+= startup-notification-1:${PORTSDIR}/x11/startup-notification
CONFIGURE_ARGS+=--enable-startup-notification
.else
CONFIGURE_ARGS+=--disable-startup-notification
diff --git a/sysutils/xfburn/Makefile b/sysutils/xfburn/Makefile
index 1cab713614d9..3cbbc08f44cf 100644
--- a/sysutils/xfburn/Makefile
+++ b/sysutils/xfburn/Makefile
@@ -1,23 +1,20 @@
-# New ports collection makefile for: xfburn
-# Date created: 2008 November 06
-# Whom: J.R. Oldroyd <fbsd@opal.com>
-#
+# Created by: J.R. Oldroyd <fbsd@opal.com>
# $FreeBSD$
#
PORTNAME= xfburn
PORTVERSION= 0.4.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_XFCE}
-MASTER_SITE_SUBDIR=/src/apps/${PORTNAME}/${PORTVERSION:R}
+MASTER_SITE_SUBDIR=src/apps/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
MAINTAINER= ports@FreeBSD.org
COMMENT= CD/DVD burning tool for Xfce
-LIB_DEPENDS= burn.4:${PORTSDIR}/devel/libburn \
- isofs.6:${PORTSDIR}/devel/libisofs
+LIB_DEPENDS= burn:${PORTSDIR}/devel/libburn \
+ isofs:${PORTSDIR}/devel/libisofs
RUN_DEPENDS= cdrdao:${PORTSDIR}/sysutils/cdrdao
GNU_CONFIGURE= yes
diff --git a/sysutils/xfce4-settings/Makefile b/sysutils/xfce4-settings/Makefile
index 5b682e0f7d9a..9e7659d10d3d 100644
--- a/sysutils/xfce4-settings/Makefile
+++ b/sysutils/xfce4-settings/Makefile
@@ -1,13 +1,10 @@
-# New ports collection makefile for: xfce4-settings
-# Date created: 2 October 2008
-# Whom: Oliver Lehmann <oliver@FreeBSD.org>
-#
+# Created by: Oliver Lehmann <oliver@FreeBSD.org>
# $FreeBSD$
#
PORTNAME= xfce4-settings
PORTVERSION= 4.10.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
DIST_SUBDIR= xfce4
@@ -15,17 +12,17 @@ DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
COMMENT= Xfce 4 settings application
-LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+LIB_DEPENDS= dbus-glib-1:${PORTSDIR}/devel/dbus-glib
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack glib20 gtk20 desktopfileutils intltool intlhack \
- pkgconfig
+USE_GNOME= gnomehack glib20 gtk20 desktopfileutils intltool intlhack
USE_XFCE= configenv garcon libexo libmenu libutil xfconf
USE_XORG= inputproto x11 xi
+USE_PKGCONFIG= build
CONFIGURE_ARGS= --enable-pluggable-dialogs \
--enable-gio-unix
@@ -37,7 +34,7 @@ SOUND_DESC= Enable sound control
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MXKLAVIER}
-LIB_DEPENDS+= xklavier.12:${PORTSDIR}/x11/libxklavier
+LIB_DEPENDS+= xklavier:${PORTSDIR}/x11/libxklavier
CONFIGURE_ARGS+=--enable-libxklavier
.else
CONFIGURE_ARGS+=--disable-libxklavier
@@ -60,7 +57,7 @@ PLIST_SUB+= XRANDR="@comment "
.endif
.if ${PORT_OPTIONS:MNOTIFY}
-LIB_DEPENDS+= notify.4:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS+= notify:${PORTSDIR}/devel/libnotify
CONFIGURE_ARGS+=--enable-libnotify
.else
CONFIGURE_ARGS+=--disable-libnotify
@@ -76,7 +73,7 @@ PLIST_SUB+= NLS="@comment "
.endif
.if ${PORT_OPTIONS:MSOUND}
-LIB_DEPENDS+= canberra.0:${PORTSDIR}/audio/libcanberra
+LIB_DEPENDS+= canberra:${PORTSDIR}/audio/libcanberra
CONFIGURE_ARGS+=--enable-sound-settings
.else
CONFIGURE_ARGS+=--disable-sound-settings
diff --git a/x11-wm/xfce4-desktop/Makefile b/x11-wm/xfce4-desktop/Makefile
index c08093ff4602..67c174e1dc9f 100644
--- a/x11-wm/xfce4-desktop/Makefile
+++ b/x11-wm/xfce4-desktop/Makefile
@@ -1,13 +1,10 @@
-# New ports collection makefile for: xfdesktop
-# Date created: 7 June 2003
-# Whom: James Earl <jdearl@telus.net>
-#
+# Created by: James Earl <jdearl@telus.net>
# $FreeBSD$
#
PORTNAME= xfce4-desktop
PORTVERSION= 4.10.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-wm xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
DISTNAME= xfdesktop-${PORTVERSION}
@@ -16,17 +13,17 @@ DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
COMMENT= Xfce's desktop manager
-LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- wnck-1.22:${PORTSDIR}/x11-toolkits/libwnck \
- notify.4:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS= dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
+ wnck-1:${PORTSDIR}/x11-toolkits/libwnck \
+ notify:${PORTSDIR}/devel/libnotify
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= glib20 gnomehack gtk20 intltool intlhack pkgconfig \
- desktopfileutils
+USE_GNOME= glib20 gnomehack gtk20 intltool intlhack desktopfileutils
USE_XFCE= configenv garcon libmenu libutil libexo xfconf
+USE_PKGCONFIG= build
CONFIGURE_ARGS+=--enable-gio-unix \
--enable-notifications
diff --git a/x11-wm/xfce4-panel/Makefile b/x11-wm/xfce4-panel/Makefile
index 4afcece48c90..fe8429cf7384 100644
--- a/x11-wm/xfce4-panel/Makefile
+++ b/x11-wm/xfce4-panel/Makefile
@@ -1,13 +1,10 @@
-# New ports collection makefile for: xfce4-panel
-# Date created: 7 June 2003
-# Whom: James Earl <jdearl@telus.net>
-#
+# Created by: James Earl <jdearl@telus.net>
# $FreeBSD$
#
PORTNAME= xfce4-panel
PORTVERSION= 4.10.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-wm xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
DIST_SUBDIR= xfce4
@@ -15,9 +12,9 @@ DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
COMMENT= Xfce's panel
-LIB_DEPENDS= wnck-1.22:${PORTSDIR}/x11-toolkits/libwnck \
- cairo.2:${PORTSDIR}/graphics/cairo \
- dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+LIB_DEPENDS= wnck-1:${PORTSDIR}/x11-toolkits/libwnck \
+ cairo:${PORTSDIR}/graphics/cairo \
+ dbus-glib-1:${PORTSDIR}/devel/dbus-glib
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
diff --git a/x11/Terminal/Makefile b/x11/Terminal/Makefile
index e06884785aec..5d9f3140bea6 100644
--- a/x11/Terminal/Makefile
+++ b/x11/Terminal/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Terminal
PORTVERSION= 0.4.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR= src/apps/${PORTNAME:L}/${PORTVERSION:R}
@@ -17,13 +17,12 @@ GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack gtk20 glib20 intltool intlhack pkgconfig vte \
- desktopfileutils
+USE_GNOME= gnomehack gtk20 glib20 intltool intlhack vte desktopfileutils
USE_XFCE= configenv libexo
USE_XORG= x11
+USE_PKGCONFIG= build
CONFIGURE_ARGS= --without-gnome-default-appsdir
-CONFIGURE_ENV+= ac_cv_prog_AWK="${AWK}"
OPTIONS_DEFINE= DBUS NLS
@@ -37,7 +36,7 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-doc-Makefile.in
.endif
.if ${PORT_OPTIONS:MDBUS}
-LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+LIB_DEPENDS+= dbus-glib-1:${PORTSDIR}/devel/dbus-glib
CONFIGURE_ARGS+=--enable-dbus
.else
CONFIGURE_ARGS+=--disable-dbus
diff --git a/x11/xfce4-clipman-plugin/Makefile b/x11/xfce4-clipman-plugin/Makefile
index edd5d85b1dc0..3756d739949d 100644
--- a/x11/xfce4-clipman-plugin/Makefile
+++ b/x11/xfce4-clipman-plugin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xfce4-clipman-plugin
PORTVERSION= 1.2.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11 xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR= src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
@@ -22,9 +22,10 @@ GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack gtk20 intltool intlhack pkgconfig glib20 desktopfileutils
+USE_GNOME= gnomehack gtk20 intltool intlhack glib20 desktopfileutils
USE_XFCE= configenv libexo libmenu libutil panel xfconf
USE_XORG= xtst
+USE_PKGCONFIG= build
INSTALLS_ICONS= yes
diff --git a/x11/xfce4-screenshooter-plugin/Makefile b/x11/xfce4-screenshooter-plugin/Makefile
index a5cdc3b55014..01de13535552 100644
--- a/x11/xfce4-screenshooter-plugin/Makefile
+++ b/x11/xfce4-screenshooter-plugin/Makefile
@@ -1,12 +1,10 @@
-# New ports collection makefile for: screenshooter plugin for xfce4
-# Date created: 29 April 2006
-# Whom: Martin Wilke (miwi@FreeBSD.org)
-#
+# Created by: Martin Wilke (miwi@FreeBSD.org)
# $FreeBSD$
#
PORTNAME= xfce4-screenshooter-plugin
PORTVERSION= 1.8.1
+PORTREVISION= 1
CATEGORIES= x11 xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR=/src/apps/xfce4-screenshooter/${PORTVERSION:R}
@@ -22,8 +20,10 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
INSTALLS_ICONS= yes
-USE_GNOME= glib20 gtk20 intltool intlhack pkgconfig
-USE_XFCE= configenv panel libutil libgui
+USE_GNOME= glib20 gtk20 intltool intlhack
+USE_XFCE= configenv libexo libmenu libutil panel
+USE_PKGCONFIG= build
+
MAN1= xfce4-screenshooter.1
.include <bsd.port.options.mk>
diff --git a/x11/xfce4-verve-plugin/Makefile b/x11/xfce4-verve-plugin/Makefile
index d393eaa8ff2d..d840b916dc50 100644
--- a/x11/xfce4-verve-plugin/Makefile
+++ b/x11/xfce4-verve-plugin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= verve-plugin
PORTVERSION= 1.0.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= x11 xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR=/src/panel-plugins/${PKGNAMEPREFIX}${PORTNAME}/${PORTVERSION:R}
@@ -14,14 +14,15 @@ DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
MAINTAINER= xfce@FreeBSD.org
COMMENT= A command line plugin for Xfce4
-LIB_DEPENDS= pcre.3:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack glib20 intltool intlhack pkgconfig
+USE_GNOME= gnomehack glib20 intltool intlhack
USE_XFCE= configenv panel libexo libgui libutil
+USE_PKGCONFIG= build
CONFIGURE_ARGS= --disable-debug
@@ -39,7 +40,7 @@ PLIST_SUB+= NLS="@comment "
.endif
.if ${PORT_OPTIONS:MDBUS}
-LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+LIB_DEPENDS+= dbus-glib-1:${PORTSDIR}/devel/dbus-glib
CONFIGURE_ARGS+=--enable-dbus
PLIST_SUB+= DBUS=""
.else