aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/riemann-c-client/Makefile36
-rw-r--r--net-mgmt/riemann-c-client/distinfo3
-rw-r--r--net-mgmt/riemann-c-client/pkg-descr5
-rw-r--r--net-mgmt/riemann-c-client/pkg-plist15
5 files changed, 60 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 3db13c1b9218..73edcc854a32 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -291,6 +291,7 @@
SUBDIR += remarp
SUBDIR += resource-agents
SUBDIR += riemann
+ SUBDIR += riemann-c-client
SUBDIR += rotorouter
SUBDIR += routers2
SUBDIR += routers2-extensions
diff --git a/net-mgmt/riemann-c-client/Makefile b/net-mgmt/riemann-c-client/Makefile
new file mode 100644
index 000000000000..f81fcea46dc9
--- /dev/null
+++ b/net-mgmt/riemann-c-client/Makefile
@@ -0,0 +1,36 @@
+# Created by: Dave Cottlehuber <dch@skunkwerks.at>
+# $FreeBSD$
+
+PORTNAME= riemann-c-client
+PORTVERSION= 1.9.1
+DISTVERSIONPREFIX= ${PORTNAME}-
+CATEGORIES= net-mgmt
+
+MAINTAINER= dch@skunkwerks.at
+COMMENT= C library and command-line tool for Riemann
+
+LICENSE= LGPL3+
+
+BUILD_DEPENDS= libcheck>0:devel/libcheck
+LIB_DEPENDS= libprotobuf-c.so:devel/protobuf-c \
+ libgnutls.so:security/gnutls \
+ libjson-c.so:devel/json-c
+
+USE_GITHUB= yes
+GH_ACCOUNT= algernon
+
+USES= autoreconf gmake libtool pathfix pkgconfig
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+PATHFIX_MAKEFILEIN= Makefile.am
+INSTALL_TARGET= install-strip
+TEST_TARGET= check
+
+post-patch:
+ @${REINPLACE_CMD} 's/-ldl//' ${WRKSRC}/Makefile.am
+
+# Running |make test| isn't on poudriere menu yet, so force-feed
+pre-install: do-test
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/riemann-c-client/distinfo b/net-mgmt/riemann-c-client/distinfo
new file mode 100644
index 000000000000..7ac624f669ec
--- /dev/null
+++ b/net-mgmt/riemann-c-client/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1475271779
+SHA256 (algernon-riemann-c-client-riemann-c-client-1.9.1_GH0.tar.gz) = 6c8279362384e0ee01cb84a12f645bf7229c7d61f565158fe4ecc82c36ce8dc0
+SIZE (algernon-riemann-c-client-riemann-c-client-1.9.1_GH0.tar.gz) = 74563
diff --git a/net-mgmt/riemann-c-client/pkg-descr b/net-mgmt/riemann-c-client/pkg-descr
new file mode 100644
index 000000000000..449b8b87a414
--- /dev/null
+++ b/net-mgmt/riemann-c-client/pkg-descr
@@ -0,0 +1,5 @@
+Riemann-C-client is a C client library for the Riemann monitoring system,
+providing a convenient and simple API, high test coverage and a copyleft
+license, along with API and ABI stability.
+
+WWW: https://github.com/algernon/riemann-c-client/#readme
diff --git a/net-mgmt/riemann-c-client/pkg-plist b/net-mgmt/riemann-c-client/pkg-plist
new file mode 100644
index 000000000000..da3a1d7742a3
--- /dev/null
+++ b/net-mgmt/riemann-c-client/pkg-plist
@@ -0,0 +1,15 @@
+bin/riemann-client
+include/riemann/attribute.h
+include/riemann/client.h
+include/riemann/event.h
+include/riemann/message.h
+include/riemann/proto/riemann.pb-c.h
+include/riemann/query.h
+include/riemann/riemann-client.h
+include/riemann/simple.h
+lib/libriemann-client.a
+lib/libriemann-client.so
+lib/libriemann-client.so.0
+lib/libriemann-client.so.0.9.1
+libdata/pkgconfig/riemann-client.pc
+man/man1/riemann-client.1.gz