aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--science/massxpert/Makefile4
-rw-r--r--science/massxpert/files/patch-lib_cleaveSpec.cpp11
-rw-r--r--science/massxpert/files/patch-plugins-src_seqToolsPlugin_seqToolsPluginDlg.cpp11
3 files changed, 24 insertions, 2 deletions
diff --git a/science/massxpert/Makefile b/science/massxpert/Makefile
index 071c1bcb8e0b..93333f541526 100644
--- a/science/massxpert/Makefile
+++ b/science/massxpert/Makefile
@@ -3,12 +3,12 @@
PORTNAME= massxpert
PORTVERSION= 3.4.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= science
MASTER_SITES= http://download.tuxfamily.org/massxpert/source/
MAINTAINER= vg@FreeBSD.org
-COMMENT= The massXpert software for (bio)chemists
+COMMENT= massXpert software for (bio)chemists
LICENSE= GPLv3
diff --git a/science/massxpert/files/patch-lib_cleaveSpec.cpp b/science/massxpert/files/patch-lib_cleaveSpec.cpp
new file mode 100644
index 000000000000..904af6ac2aca
--- /dev/null
+++ b/science/massxpert/files/patch-lib_cleaveSpec.cpp
@@ -0,0 +1,11 @@
+--- lib/cleaveSpec.cpp.orig 2012-12-25 21:02:43 UTC
++++ lib/cleaveSpec.cpp
+@@ -427,7 +427,7 @@ namespace massXpert
+ return false;
+
+
+- if (parse() == -1)
++ if (parse() == false)
+ return false;
+
+ // If there are rules, we have to check them all.
diff --git a/science/massxpert/files/patch-plugins-src_seqToolsPlugin_seqToolsPluginDlg.cpp b/science/massxpert/files/patch-plugins-src_seqToolsPlugin_seqToolsPluginDlg.cpp
new file mode 100644
index 000000000000..46c261227c5f
--- /dev/null
+++ b/science/massxpert/files/patch-plugins-src_seqToolsPlugin_seqToolsPluginDlg.cpp
@@ -0,0 +1,11 @@
+--- plugins-src/seqToolsPlugin/seqToolsPluginDlg.cpp.orig 2012-12-25 21:02:43 UTC
++++ plugins-src/seqToolsPlugin/seqToolsPluginDlg.cpp
+@@ -215,7 +215,7 @@ SeqToolsPluginDlg::loadDictionary ()
+
+ QStringList stringList = line.split (">", QString::SkipEmptyParts);
+
+- if (!stringList.size () == 2)
++ if (stringList.size () != 2)
+ {
+ QMessageBox::warning (this,
+ tr ("Sequence Manipulation Tools Plugin"),