aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--finance/Makefile1
-rw-r--r--finance/p5-Business-OnlinePayment-PaymenTech/Makefile25
-rw-r--r--finance/p5-Business-OnlinePayment-PaymenTech/distinfo3
-rw-r--r--finance/p5-Business-OnlinePayment-PaymenTech/pkg-descr5
-rw-r--r--finance/p5-Business-OnlinePayment-PaymenTech/pkg-plist8
5 files changed, 42 insertions, 0 deletions
diff --git a/finance/Makefile b/finance/Makefile
index e3e85b503009..dbce3086534e 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -43,6 +43,7 @@
SUBDIR += p5-Business-OnlinePayment-OCV
SUBDIR += p5-Business-OnlinePayment-PayConnect
SUBDIR += p5-Business-OnlinePayment-PayflowPro
+ SUBDIR += p5-Business-OnlinePayment-PaymenTech
SUBDIR += p5-Business-OnlinePayment-PaymentsGateway
SUBDIR += p5-Business-OnlinePayment-SurePay
SUBDIR += p5-Business-OnlinePayment-TCLink
diff --git a/finance/p5-Business-OnlinePayment-PaymenTech/Makefile b/finance/p5-Business-OnlinePayment-PaymenTech/Makefile
new file mode 100644
index 000000000000..50537f0a4b7f
--- /dev/null
+++ b/finance/p5-Business-OnlinePayment-PaymenTech/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Business-OnlinePayment-PaymenTech
+# Date created: 2008/08/31
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Business-OnlinePayment-PaymenTech
+PORTVERSION= 1.0.2
+CATEGORIES= finance perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= PaymenTech backend for Business::OnlinePayment
+
+BUILD_DEPENDS= ${SITE_PERL}/Business/OnlinePayment.pm:${PORTSDIR}/finance/p5-Business-OnlinePayment \
+ p5-Module-Install>=0:${PORTSDIR}/devel/p5-Module-Install
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Business::OnlinePayment::PaymenTech.3
+
+.include <bsd.port.mk>
diff --git a/finance/p5-Business-OnlinePayment-PaymenTech/distinfo b/finance/p5-Business-OnlinePayment-PaymenTech/distinfo
new file mode 100644
index 000000000000..4aac0cdaa4a2
--- /dev/null
+++ b/finance/p5-Business-OnlinePayment-PaymenTech/distinfo
@@ -0,0 +1,3 @@
+MD5 (Business-OnlinePayment-PaymenTech-1.0.2.tar.gz) = e2c7281f94b0b360f943d4e49a0f515b
+SHA256 (Business-OnlinePayment-PaymenTech-1.0.2.tar.gz) = 87ac3535536b422072e3fd4ecde51f9cce29384ba05d6a6b1ea40fc6a7974f88
+SIZE (Business-OnlinePayment-PaymenTech-1.0.2.tar.gz) = 2658
diff --git a/finance/p5-Business-OnlinePayment-PaymenTech/pkg-descr b/finance/p5-Business-OnlinePayment-PaymenTech/pkg-descr
new file mode 100644
index 000000000000..b27758851e51
--- /dev/null
+++ b/finance/p5-Business-OnlinePayment-PaymenTech/pkg-descr
@@ -0,0 +1,5 @@
+Business::OnlinePayment::PaymenTech allows you to utilize PaymenTech's
+Orbital SDK credit card services. You will need to install the Perl Orbital
+SDK for this to work.
+
+WWW: http://search.cpan.org/dist/Business-OnlinePayment-PaymenTech/
diff --git a/finance/p5-Business-OnlinePayment-PaymenTech/pkg-plist b/finance/p5-Business-OnlinePayment-PaymenTech/pkg-plist
new file mode 100644
index 000000000000..ee6364bd6f61
--- /dev/null
+++ b/finance/p5-Business-OnlinePayment-PaymenTech/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Business/OnlinePayment/PaymenTech/.packlist
+%%SITE_PERL%%/Business/OnlinePayment/PaymenTech.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Business/OnlinePayment/PaymenTech
+@dirrmtry %%SITE_PERL%%/auto/Business/OnlinePayment/PaymenTech
+@dirrmtry %%SITE_PERL%%/auto/Business/OnlinePayment
+@dirrmtry %%SITE_PERL%%/auto/Business
+@dirrmtry %%SITE_PERL%%/Business/OnlinePayment
+@dirrmtry %%SITE_PERL%%/Business