aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--LEGAL1
-rw-r--r--audio/logitechmediaserver/Makefile8
-rw-r--r--audio/logitechmediaserver/distinfo10
-rw-r--r--audio/logitechmediaserver/files/vendorpatch-CPAN_buildme.sh55
-rw-r--r--audio/logitechmediaserver/pkg-plist139
5 files changed, 113 insertions, 100 deletions
diff --git a/LEGAL b/LEGAL
index 2bcd53dc8a5a..c5a45072a2bd 100644
--- a/LEGAL
+++ b/LEGAL
@@ -146,6 +146,7 @@ linux-ut/* games/linux-ut Redistribution is limited, see license
linuxq3ademo-* games/linux-quake3 Restrictive license by Loki Software
linuxq3ademo-* games/linux-quake3-demo Restrictive license by Loki Software
linuxsampler-* audio/linuxsampler Commercial use is prohibited
+Logitech-slimserver-* audio/logitechmediaserver Contains non-redistributable firmware, documentation, and images
lpac-* audio/lpac No commercial use
l_cc_p*_*.*.*.tar.gz lang/icc No redistribution allowed
l_fc_p*_*.*.*.tar.gz lang/ifc Intel forbids any redistribution
diff --git a/audio/logitechmediaserver/Makefile b/audio/logitechmediaserver/Makefile
index ac1d188cc017..e22462e3319c 100644
--- a/audio/logitechmediaserver/Makefile
+++ b/audio/logitechmediaserver/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= logitechmediaserver
-PORTVERSION= 7.9.1.g2017.07.11
+PORTVERSION= 7.9.1.g2018.04.23
CATEGORIES= audio
MAINTAINER= mark@tranquillussoftware.co.uk
@@ -13,6 +13,7 @@ LICENSE_FILE= ${WRKSRC}/License.txt
LICENSE_PERMS= no-dist-mirror no-dist-sell no-pkg-mirror no-pkg-sell
ONLY_FOR_ARCHS= amd64 i386
+BROKEN_FreeBSD_10_i386= libmediascan does not compile
BUILD_DEPENDS= nasm:devel/nasm \
bash:shells/bash \
@@ -21,8 +22,8 @@ LIB_DEPENDS= libgd.so:graphics/gd
USES= gettext-runtime gmake perl5 shebangfix
USE_GITHUB= yes
-GH_TUPLE= Logitech:slimserver:762b5cb \
- Logitech:slimserver-vendor:1463b00:vendor
+GH_TUPLE= Logitech:slimserver:7b3c28c \
+ Logitech:slimserver-vendor:21f307f:vendor
USE_RC_SUBR= logitechmediaserver
SHEBANG_FILES= Bin/darwin/check-update.pl \
Bin/dbish \
@@ -114,6 +115,7 @@ do-install:
${RM} -- ${CONFFILES} ${DOCFILES})
(cd ${STAGEDIR}${PREFIX}/${SLIMDIR}/CPAN/arch/${PERL_VER} && \
${RM} -r -- arm-linux-gnueabihf-thread-multi-64int && \
+ ${RM} -r -- aarch64-linux-thread-multi && \
${RM} -r -- i386-linux-thread-multi-64int && \
${RM} -r -- x86_64-linux-thread-multi)
.for _CONF in ${CONFFILES}
diff --git a/audio/logitechmediaserver/distinfo b/audio/logitechmediaserver/distinfo
index d5a2e3845667..64d0d451fabf 100644
--- a/audio/logitechmediaserver/distinfo
+++ b/audio/logitechmediaserver/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1510570168
-SHA256 (Logitech-slimserver-7.9.1.g2017.07.11-762b5cb_GH0.tar.gz) = 8b7660b12e040af92418374ab53e6f1bf3ac2f4bd31b90a6b8c81846accee0c9
-SIZE (Logitech-slimserver-7.9.1.g2017.07.11-762b5cb_GH0.tar.gz) = 204890704
-SHA256 (Logitech-slimserver-vendor-1463b00_GH0.tar.gz) = 101524a0472c5976ca8696e34013efcc18ed4943b9c6838136e24c9f28a9bce6
-SIZE (Logitech-slimserver-vendor-1463b00_GH0.tar.gz) = 115661641
+TIMESTAMP = 1524506588
+SHA256 (Logitech-slimserver-7.9.1.g2018.04.23-7b3c28c_GH0.tar.gz) = 74127e7b2901adf3e9b27da63ace2458ae173f04690fd3b6c7b0caa45b502e40
+SIZE (Logitech-slimserver-7.9.1.g2018.04.23-7b3c28c_GH0.tar.gz) = 231132844
+SHA256 (Logitech-slimserver-vendor-21f307f_GH0.tar.gz) = e4a831077e040485b2df938c0dec37d8660fdda3c9dabb5a8eafcd5a9120f424
+SIZE (Logitech-slimserver-vendor-21f307f_GH0.tar.gz) = 139203047
diff --git a/audio/logitechmediaserver/files/vendorpatch-CPAN_buildme.sh b/audio/logitechmediaserver/files/vendorpatch-CPAN_buildme.sh
index c36de058f253..b90d339b7411 100644
--- a/audio/logitechmediaserver/files/vendorpatch-CPAN_buildme.sh
+++ b/audio/logitechmediaserver/files/vendorpatch-CPAN_buildme.sh
@@ -1,50 +1,11 @@
---- ../slimserver-vendor-1463b00/CPAN/buildme.sh.orig 2017-06-07 14:29:20.000000000 +0100
-+++ ../slimserver-vendor-1463b00/CPAN/buildme.sh 2017-07-12 21:44:11.808290000 +0100
-@@ -92,7 +92,7 @@
- exit
- fi
-
--for i in gcc cpp rsync make rsync ; do
-+for i in cc cpp rsync make rsync ; do
- which $i > /dev/null
- if [ $? -ne 0 ] ; then
- echo "$i not found - please install it"
-@@ -556,6 +556,19 @@
- # because it takes so damn long on slow platforms
- if [ ! -f build/lib/libicudata_s.a ]; then
- tar_wrapper zxvf icu4c-4_6-src.tgz
-+ patch << END
-+--- icu/source/i18n/uspoof.cpp.orig 2017-07-12 21:35:34.014645000 +0100
-++++ icu/source/i18n/uspoof.cpp 2017-07-12 21:33:44.790884000 +0100
-+@@ -366,7 +366,7 @@
-+ // u_strToUTF8() in preflight mode is an easy way to do it.
-+ U_ASSERT(position16 <= len16);
-+ u_strToUTF8(NULL, 0, position, text16, position16, status);
-+- if (position > 0) {
-++ if (position != NULL && *position > 0) {
-+ // position is the required buffer length from u_strToUTF8, which includes
-+ // space for a terminating NULL, which we don't want, hence the -1.
-+ *position -= 1;
-+END
+--- ../slimserver-vendor-21f307f/CPAN/buildme.sh.orig 2018-04-11 08:51:55.360230000 +0100
++++ ../slimserver-vendor-21f307f/CPAN/buildme.sh 2018-04-11 08:52:15.289491000 +0100
+@@ -657,7 +657,7 @@
+ tar_wrapper zxf icu4c-58_2-src.tgz
cd icu/source
+ # Need to patch ICU to adapt to removal of xlocale.h on some platforms.
+- patch -p0 < ../../icu58_patches/digitlst.cpp.patch
++ # DONT DO THIS patch -p0 < ../../icu58_patches/digitlst.cpp.patch
+ . ../../update-config.sh
if [ "$OS" = 'Darwin' ]; then
ICUFLAGS="$FLAGS $OSX_ARCH $OSX_FLAGS -DU_USING_ICU_NAMESPACE=0 -DU_CHARSET_IS_UTF8=1" # faster code for native UTF-8 systems
-@@ -568,7 +581,7 @@
- ICUOS="FreeBSD"
- fi
- CFLAGS="$ICUFLAGS" CXXFLAGS="$ICUFLAGS" LDFLAGS="$FLAGS $OSX_ARCH $OSX_FLAGS" \
-- ./runConfigureICU $ICUOS --prefix=$BUILD --enable-static --with-data-packaging=archive
-+ ./configure --prefix=$BUILD --enable-static --with-data-packaging=archive
- $MAKE
- if [ $? != 0 ]; then
- echo "make failed"
-@@ -1239,6 +1252,9 @@
- if [ "$ARCH" = "amd64-freebsd" -o "$ARCH" = "amd64-freebsd-thread-multi" ]; then
- FFOPTS="$FFOPTS --arch=x86"
- fi
-+ if [ "$OS" = "FreeBSD" ]; then
-+ FFOPTS="$FFOPTS --cc=clang"
-+ fi
-
- if [ "$OS" = "Darwin" ]; then
- SAVED_FLAGS=$FLAGS
diff --git a/audio/logitechmediaserver/pkg-plist b/audio/logitechmediaserver/pkg-plist
index ef27d66cdb62..f08b1259ad7d 100644
--- a/audio/logitechmediaserver/pkg-plist
+++ b/audio/logitechmediaserver/pkg-plist
@@ -820,6 +820,7 @@ etc/newsyslog.conf.d/logitechmediaserver.conf
%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/Test/Warn.pm
%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/Tree/DAG_Node.pm
%%I386_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/common/sense.pm
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Audio/Cuefile/Parser.pm
%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Audio/Scan.pm
%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Bundle/DBI.pm
%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Class/XSAccessor.pm
@@ -878,6 +879,10 @@ etc/newsyslog.conf.d/logitechmediaserver.conf
%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/DBI/Util/CacheMemory.pm
%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/DBI/Util/_accessor.pm
%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/DBI/W32ODBC.pm
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Data/Dump.pm
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Data/Dump/FilterContext.pm
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Data/Dump/Filtered.pm
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Data/Dump/Trace.pm
%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Digest/SHA1.pm
%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/EV.pm
%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/EV/EVAPI.h
@@ -886,12 +891,23 @@ etc/newsyslog.conf.d/logitechmediaserver.conf
%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/EV/libev.pod
%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Encode/Detect.pm
%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Encode/Detect/Detector.pm
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/ExtUtils/CBuilder.pm
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/ExtUtils/CBuilder/Base.pm
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/ExtUtils/CBuilder/Platform/Unix.pm
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/ExtUtils/CBuilder/Platform/VMS.pm
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/ExtUtils/CBuilder/Platform/Windows.pm
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/ExtUtils/CBuilder/Platform/aix.pm
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/ExtUtils/CBuilder/Platform/cygwin.pm
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/ExtUtils/CBuilder/Platform/darwin.pm
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/ExtUtils/CBuilder/Platform/dec_osf.pm
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/ExtUtils/CBuilder/Platform/os2.pm
%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/HTML/Entities.pm
%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/HTML/Filter.pm
%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/HTML/HeadParser.pm
%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/HTML/LinkExtor.pm
%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/HTML/Parser.pm
%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/HTML/PullParser.pm
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/HTML/Tagset.pm
%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/HTML/TokeParser.pm
%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/IO/Interface.pm
%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/IO/Interface/Simple.pm
@@ -907,7 +923,35 @@ etc/newsyslog.conf.d/logitechmediaserver.conf
%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Media/Scan/Progress.pm
%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Media/Scan/Result.pm
%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Media/Scan/Video.pm
+%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Module/Build.pm
+%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Module/Build/Base.pm
+%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Module/Build/Compat.pm
+%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Module/Build/Config.pm
+%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Module/Build/ConfigData.pm
+%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Module/Build/Cookbook.pm
+%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Module/Build/Dumper.pm
+%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Module/Build/ModuleInfo.pm
+%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Module/Build/Notes.pm
+%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Module/Build/PPMMaker.pm
+%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Module/Build/Platform/Amiga.pm
+%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Module/Build/Platform/Default.pm
+%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Module/Build/Platform/EBCDIC.pm
+%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Module/Build/Platform/MPEiX.pm
+%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Module/Build/Platform/MacOS.pm
+%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Module/Build/Platform/RiscOS.pm
+%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Module/Build/Platform/Unix.pm
+%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Module/Build/Platform/VMS.pm
+%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Module/Build/Platform/VOS.pm
+%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Module/Build/Platform/Windows.pm
+%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Module/Build/Platform/aix.pm
+%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Module/Build/Platform/cygwin.pm
+%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Module/Build/Platform/darwin.pm
+%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Module/Build/Platform/os2.pm
+%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Module/Build/PodParser.pm
+%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Module/Build/Version.pm
+%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Module/Build/YAML.pm
%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Sub/Name.pm
+%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Sub/Uplevel.pm
%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Template.pm
%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Template/Base.pm
%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Template/Config.pm
@@ -974,41 +1018,47 @@ etc/newsyslog.conf.d/logitechmediaserver.conf
%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Template/Tutorial/Web.pod
%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Template/VMethods.pm
%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Template/View.pm
+%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Test/NoWarnings.pm
+%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Test/NoWarnings/Warning.pm
+%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Test/Warn.pm
+%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Tree/DAG_Node.pm
%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/Win32/DBIODBC.pm
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser.pm
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/Japanese_Encodings.msg
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/README
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/big5.enc
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/euc-kr.enc
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/ibm866.enc
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/iso-8859-2.enc
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/iso-8859-3.enc
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/iso-8859-4.enc
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/iso-8859-5.enc
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/iso-8859-7.enc
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/iso-8859-8.enc
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/iso-8859-9.enc
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/koi8-r.enc
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/windows-1250.enc
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/windows-1251.enc
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/windows-1252.enc
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/windows-1255.enc
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/x-euc-jp-jisx0221.enc
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/x-euc-jp-unicode.enc
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/x-sjis-cp932.enc
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/x-sjis-jdk117.enc
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/x-sjis-jisx0221.enc
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/x-sjis-unicode.enc
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Expat.pm
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/LWPExternEnt.pl
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Style/Debug.pm
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Style/Objects.pm
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Style/Stream.pm
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Style/Subs.pm
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Style/Tree.pm
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/YAML/LibYAML.pm
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/YAML/XS.pm
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/YAML/XS/LibYAML.pm
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser.pm
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/Japanese_Encodings.msg
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/README
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/big5.enc
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/euc-kr.enc
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/ibm866.enc
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/iso-8859-2.enc
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/iso-8859-3.enc
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/iso-8859-4.enc
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/iso-8859-5.enc
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/iso-8859-7.enc
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/iso-8859-8.enc
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/iso-8859-9.enc
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/koi8-r.enc
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/windows-1250.enc
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/windows-1251.enc
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/windows-1252.enc
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/windows-1255.enc
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/x-euc-jp-jisx0221.enc
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/x-euc-jp-unicode.enc
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/x-sjis-cp932.enc
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/x-sjis-jdk117.enc
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/x-sjis-jisx0221.enc
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Encodings/x-sjis-unicode.enc
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Expat.pm
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/LWPExternEnt.pl
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Style/Debug.pm
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Style/Objects.pm
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Style/Stream.pm
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Style/Subs.pm
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/XML/Parser/Style/Tree.pm
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/YAML/LibYAML.pm
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/YAML/LibYAML.pod
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/YAML/XS.pm
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/YAML/XS.pod
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/YAML/XS/LibYAML.pm
%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/auto/Audio/Scan/Scan.so
%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/auto/Class/XSAccessor/XSAccessor.so
%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/auto/DBD/SQLite/SQLite.so
@@ -1031,12 +1081,13 @@ etc/newsyslog.conf.d/logitechmediaserver.conf
%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/auto/JSON/XS/XS.so
%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/auto/MP3/Cut/Gapless/Gapless.so
%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/auto/Media/Scan/Scan.so
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/auto/Sub/Name/Name.so
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/auto/Template/Stash/XS/XS.so
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/auto/XML/Parser/Expat/Expat.so
-%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/auto/YAML/XS/LibYAML/LibYAML.so
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/auto/Sub/Name/Name.so
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/auto/Template/Stash/XS/XS.so
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/auto/XML/Parser/Expat/Expat.so
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/auto/YAML/XS/LibYAML/LibYAML.so
%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/auto/share/dist/DBD-SQLite/sqlite3.c
%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/auto/share/dist/DBD-SQLite/sqlite3.h
+%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/common/sense.pm
%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/dbixs_rev.pl
%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/%%ARCHNAME%%/perllocal.pod
%%AMD64_ONLY%%%%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/common/sense.pm
@@ -1637,6 +1688,7 @@ etc/newsyslog.conf.d/logitechmediaserver.conf
%%SLIMDIR%%/HTML/EN/include.html
%%SLIMDIR%%/HTML/EN/index.html
%%SLIMDIR%%/HTML/EN/listparams.html
+%%SLIMDIR%%/HTML/EN/log.html
%%SLIMDIR%%/HTML/EN/mobile.css
%%SLIMDIR%%/HTML/EN/pagebarheader.html
%%SLIMDIR%%/HTML/EN/pagefooter.html
@@ -1997,8 +2049,7 @@ etc/newsyslog.conf.d/logitechmediaserver.conf
%%SLIMDIR%%/Slim/Plugin/DigitalInput/install.xml
%%SLIMDIR%%/Slim/Plugin/DigitalInput/strings.txt
%%SLIMDIR%%/Slim/Plugin/DnDPlay/FileManager.pm
-%%SLIMDIR%%/Slim/Plugin/DnDPlay/HTML/Default/html/FileDnD.js
-%%SLIMDIR%%/Slim/Plugin/DnDPlay/HTML/Default/html/js-main-dd.html
+%%SLIMDIR%%/Slim/Plugin/DnDPlay/HTML/Default/js-main-dd.js
%%SLIMDIR%%/Slim/Plugin/DnDPlay/HTML/EN/plugins/DnDPlay/settings.html
%%SLIMDIR%%/Slim/Plugin/DnDPlay/Plugin.pm
%%SLIMDIR%%/Slim/Plugin/DnDPlay/Settings.pm
@@ -2262,11 +2313,6 @@ etc/newsyslog.conf.d/logitechmediaserver.conf
%%SLIMDIR%%/Slim/Plugin/Sounds/ProtocolHandler.pm
%%SLIMDIR%%/Slim/Plugin/Sounds/install.xml
%%SLIMDIR%%/Slim/Plugin/Sounds/strings.txt
-%%SLIMDIR%%/Slim/Plugin/SpotifyLogi/HTML/EN/plugins/SpotifyLogi/html/images/icon.png
-%%SLIMDIR%%/Slim/Plugin/SpotifyLogi/Plugin.pm
-%%SLIMDIR%%/Slim/Plugin/SpotifyLogi/ProtocolHandler.pm
-%%SLIMDIR%%/Slim/Plugin/SpotifyLogi/install.xml
-%%SLIMDIR%%/Slim/Plugin/SpotifyLogi/strings.txt
%%SLIMDIR%%/Slim/Plugin/TT/Clients.pm
%%SLIMDIR%%/Slim/Plugin/TT/Prefs.pm
%%SLIMDIR%%/Slim/Plugin/TT/README
@@ -2465,6 +2511,7 @@ etc/newsyslog.conf.d/logitechmediaserver.conf
%%SLIMDIR%%/Slim/Web/Pages/Common.pm
%%SLIMDIR%%/Slim/Web/Pages/EditPlaylist.pm
%%SLIMDIR%%/Slim/Web/Pages/Home.pm
+%%SLIMDIR%%/Slim/Web/Pages/JS.pm
%%SLIMDIR%%/Slim/Web/Pages/Playlist.pm
%%SLIMDIR%%/Slim/Web/Pages/Progress.pm
%%SLIMDIR%%/Slim/Web/Pages/Search.pm
@@ -2508,6 +2555,8 @@ etc/newsyslog.conf.d/logitechmediaserver.conf
%%SLIMDIR%%/gdresized.pl
%%SLIMDIR%%/icudt46b.dat
%%SLIMDIR%%/icudt46l.dat
+%%SLIMDIR%%/icudt58b.dat
+%%SLIMDIR%%/icudt58l.dat
%%SLIMDIR%%/lib/AnyEvent/DNS.pm
%%SLIMDIR%%/lib/AnyEvent/Impl/PerfMonEV.pm
%%SLIMDIR%%/lib/Audio/Scan.pm