aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dns/bind910/Makefile12
-rw-r--r--dns/bind910/distinfo4
-rw-r--r--dns/bind910/files/patch-bin__tests__system__dlzexternal__Makefile.in6
-rw-r--r--dns/bind910/files/patch-configure6
-rw-r--r--dns/bind99/Makefile12
-rw-r--r--dns/bind99/distinfo8
-rw-r--r--dns/bind99/files/extrapatch-bind-min-override-ttl37
-rw-r--r--dns/bind99/files/patch-configure4
8 files changed, 48 insertions, 41 deletions
diff --git a/dns/bind910/Makefile b/dns/bind910/Makefile
index 7b918ead17ee..12963fae332a 100644
--- a/dns/bind910/Makefile
+++ b/dns/bind910/Makefile
@@ -21,11 +21,11 @@ COMMENT?= BIND DNS suite with updated DNSSEC and DNS64
LICENSE= ISCL
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.10.2-P4
+ISCVERSION= 9.10.3
MAKE_JOBS_UNSAFE= yes
-USES= cpe
+USES= cpe libedit
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
@@ -59,7 +59,7 @@ OPTIONS_RADIO_GOSTDEF= GOST GOST_ASN1
.if !defined(BIND_TOOLS_SLAVE)
OPTIONS_DEFAULT+= RRL
OPTIONS_DEFINE+= LINKS RPZ_NSIP RPZ_NSDNAME RRL DOCS NEWSTATS GEOIP \
- MINCACHE PORTREVISION
+ MINCACHE PORTREVISION FETCHLIMIT QUERYTRACE
OPTIONS_GROUP= DLZ
OPTIONS_GROUP_DLZ= DLZ_POSTGRESQL DLZ_MYSQL DLZ_BDB \
DLZ_LDAP DLZ_FILESYSTEM DLZ_STUB
@@ -84,6 +84,8 @@ PYTHON_DESC= Build with Python utilities
START_LATE_DESC= Start BIND late in the boot process
MINCACHE_DESC= Use the mincachettl patch
PORTREVISION_DESC= Show PORTREVISION in the version string
+FETCHLIMIT_DESC= Enable the query quotas for resolvers
+QUERYTRACE_DESC= Enable the very verbose query tracelogging
LINKS_DESC= Create conf file symlinks in ${PREFIX}
NEWSTATS_DESC= Enable alternate xml statistics channel format
@@ -102,6 +104,8 @@ GSSAPI_HEIMDAL_DESC= Using security/heimdal
GSSAPI_MIT_DESC= Using security/krb5
GSSAPI_NONE_DESC= Disable
MINCACHE_EXTRA_PATCHES= ${FILESDIR}/extrapatch-bind-min-override-ttl
+FETCHLIMIT_CONFIGURE_ENABLE= fetchlimit
+QUERYTRACE_CONFIGURE_ENABLE= querytrace
.if !defined(BIND_TOOLS_SLAVE)
CONFLICTS+= bind-tools-9.*
@@ -227,9 +231,11 @@ post-patch:
${WRKSRC}/bin/${FILE}
.endfor
+.if ${PORTREVISION:N0}
post-patch-PORTREVISION-on:
@${REINPLACE_CMD} -e '/EXTENSIONS/s#=$$#=_${PORTREVISION}#' \
${WRKSRC}/version
+.endif
post-install:
.if ${PORT_OPTIONS:MDOCS}
diff --git a/dns/bind910/distinfo b/dns/bind910/distinfo
index 64dfc411f8d2..68952c1e1291 100644
--- a/dns/bind910/distinfo
+++ b/dns/bind910/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bind-9.10.2-P4.tar.gz) = c00b21ec1def212957f28efe9d10aac52d6ec515e84fbf2c42143f5d71429cb8
-SIZE (bind-9.10.2-P4.tar.gz) = 8471531
+SHA256 (bind-9.10.3.tar.gz) = 9ac33bd8754ab4b6ee449b1b2aa88e09f51cda088486f4ab1585acd920b98ff0
+SIZE (bind-9.10.3.tar.gz) = 8552545
diff --git a/dns/bind910/files/patch-bin__tests__system__dlzexternal__Makefile.in b/dns/bind910/files/patch-bin__tests__system__dlzexternal__Makefile.in
index a86155aeaf74..a63be7ce0466 100644
--- a/dns/bind910/files/patch-bin__tests__system__dlzexternal__Makefile.in
+++ b/dns/bind910/files/patch-bin__tests__system__dlzexternal__Makefile.in
@@ -1,6 +1,6 @@
---- ./bin/tests/system/dlzexternal/Makefile.in.orig 2014-04-08 00:02:19.000000000 +0200
-+++ ./bin/tests/system/dlzexternal/Makefile.in 2014-04-10 15:49:49.000000000 +0200
-@@ -43,7 +43,7 @@
+--- bin/tests/system/dlzexternal/Makefile.in.orig 2015-09-09 02:23:40 UTC
++++ bin/tests/system/dlzexternal/Makefile.in
+@@ -43,7 +43,7 @@ OBJS = ${DLOPENOBJS}
@BIND9_MAKE_RULES@
CFLAGS = @CFLAGS@ @SO_CFLAGS@
diff --git a/dns/bind910/files/patch-configure b/dns/bind910/files/patch-configure
index e4a1689912cf..01e870150ec6 100644
--- a/dns/bind910/files/patch-configure
+++ b/dns/bind910/files/patch-configure
@@ -1,6 +1,6 @@
---- ./configure.orig 2014-05-27 06:45:53.000000000 +0200
-+++ ./configure 2014-06-16 13:05:38.000000000 +0200
-@@ -13899,6 +13899,7 @@
+--- configure.orig 2015-09-09 02:23:40 UTC
++++ configure
+@@ -14105,6 +14105,7 @@ done
"-lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err -lresolv" \
"-lgssapi" \
"-lgssapi -lkrb5 -ldes -lcrypt -lasn1 -lroken -lcom_err" \
diff --git a/dns/bind99/Makefile b/dns/bind99/Makefile
index c1efadfeb48d..aa64f19d24fc 100644
--- a/dns/bind99/Makefile
+++ b/dns/bind99/Makefile
@@ -15,11 +15,11 @@ COMMENT= BIND DNS suite with updated DNSSEC and DNS64
LICENSE= ISCL
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.9.7-P3
+ISCVERSION= 9.9.8
MAKE_JOBS_UNSAFE= yes
-USES= cpe
+USES= cpe libedit
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
@@ -45,7 +45,7 @@ OPTIONS_DEFAULT= IPV6 SSL THREADS SIGCHASE IDN GSSAPI_NONE RRL
OPTIONS_DEFINE= SSL IDN REPLACE_BASE LARGE_FILE FIXED_RRSET SIGCHASE \
IPV6 THREADS FILTER_AAAA GOST PYTHON START_LATE MINCACHE \
LINKS RPZ_NSIP RPZ_NSDNAME RRL DOCS RPZ_PATCH NEWSTATS \
- PORTREVISION
+ PORTREVISION FETCHLIMIT QUERYTRACE
OPTIONS_GROUP= DLZ
OPTIONS_GROUP_DLZ= DLZ_POSTGRESQL DLZ_MYSQL DLZ_BDB \
DLZ_LDAP DLZ_FILESYSTEM DLZ_STUB
@@ -65,6 +65,8 @@ PYTHON_DESC= Build with Python utilities
START_LATE_DESC= Start BIND late in the boot process
MINCACHE_DESC= Use the mincachettl patch
PORTREVISION_DESC= Show PORTREVISION in the version string
+FETCHLIMIT_DESC= Enable the query quotas for resolvers
+QUERYTRACE_DESC= Enable the very verbose query tracelogging
LINKS_DESC= Create conf file symlinks in ${PREFIX}
NEWSTATS_DESC= Enable alternate xml statistics channel format
@@ -84,6 +86,8 @@ GSSAPI_HEIMDAL_DESC= ${GSSAPI_DESC} (security/heimdal)
GSSAPI_MIT_DESC= ${GSSAPI_DESC} (security/krb5)
GSSAPI_NONE_DESC= No ${GSSAPI_DESC}
MINCACHE_EXTRA_PATCHES= ${FILESDIR}/extrapatch-bind-min-override-ttl
+FETCHLIMIT_CONFIGURE_ENABLE= fetchlimit
+QUERYTRACE_CONFIGURE_ENABLE= querytrace
SSL_CONFIGURE_ON= --with-openssl=${OPENSSLBASE}
SSL_USE= openssl=yes
@@ -198,9 +202,11 @@ post-patch:
${WRKSRC}/bin/${FILE}
.endfor
+.if ${PORTREVISION:N0}
post-patch-PORTREVISION-on:
@${REINPLACE_CMD} -e '/EXTENSIONS/s#=$$#=_${PORTREVISION}#' \
${WRKSRC}/version
+.endif
post-configure:
@${REINPLACE_CMD} -e '/^SO_LDFLAGS/s/-Wl,-rpath,/-rpath /' ${WRKSRC}/bin/tests/system/dlzexternal/Makefile
diff --git a/dns/bind99/distinfo b/dns/bind99/distinfo
index fb8d6adc9bb5..fc48f8cffdf3 100644
--- a/dns/bind99/distinfo
+++ b/dns/bind99/distinfo
@@ -1,4 +1,4 @@
-SHA256 (bind-9.9.7-P3.tar.gz) = cb737dce18350890f350dd7d3bc836c62ea440103dfde184c09bc18cfad8a844
-SIZE (bind-9.9.7-P3.tar.gz) = 7939885
-SHA256 (9.9.7-P3-rpz2+rl.14038.05.patch.xz) = ec3c5c5a5011d605eeff664e41d3839c3ecda476a8a2eb20784dfaa79f8b8a77
-SIZE (9.9.7-P3-rpz2+rl.14038.05.patch.xz) = 39124
+SHA256 (bind-9.9.8.tar.gz) = 643997cdb0dd232a4c9f7c0f1436841fbf325c6b7269e6490bf5f380eda344e3
+SIZE (bind-9.9.8.tar.gz) = 8015834
+SHA256 (9.9.8-rpz2+rl.14038.05.patch.xz) = 1b22dec59f2c6ee798db1b9dfee252117a9a05b0646635eb8b25124298b12a26
+SIZE (9.9.8-rpz2+rl.14038.05.patch.xz) = 39212
diff --git a/dns/bind99/files/extrapatch-bind-min-override-ttl b/dns/bind99/files/extrapatch-bind-min-override-ttl
index fa6fd7be34fe..269cb59b74f8 100644
--- a/dns/bind99/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind99/files/extrapatch-bind-min-override-ttl
@@ -1,7 +1,6 @@
-diff -Nabdur bind-9.6.0-P1.orig/bin/named/config.c bind-9.6.0-P1/bin/named/config.c
---- bin/named/config.c 2009-05-22 12:24:49.000000000 +0400
-+++ bin/named/config.c 2009-05-22 12:31:35.000000000 +0400
-@@ -129,6 +129,8 @@
+--- bin/named/config.c.orig 2015-09-09 02:23:50 UTC
++++ bin/named/config.c
+@@ -141,6 +141,8 @@ options {\n\
min-roots 2;\n\
lame-ttl 600;\n\
max-ncache-ttl 10800; /* 3 hours */\n\
@@ -10,11 +9,10 @@ diff -Nabdur bind-9.6.0-P1.orig/bin/named/config.c bind-9.6.0-P1/bin/named/confi
max-cache-ttl 604800; /* 1 week */\n\
transfer-format many-answers;\n\
max-cache-size 0;\n\
-diff -Nabdur bind-9.6.0-P1.orig/bin/named/server.c bind-9.6.0-P1/bin/named/server.c
---- bin/named/server.c 2009-05-22 12:24:49.000000000 +0400
-+++ bin/named/server.c 2009-05-22 12:32:18.000000000 +0400
-@@ -1727,6 +1727,16 @@
- CHECK(mustbesecure(obj, view->resolver));
+--- bin/named/server.c.orig 2015-09-09 02:23:50 UTC
++++ bin/named/server.c
+@@ -2554,6 +2554,16 @@ configure_view(dns_view_t *view, cfg_obj
+ }
obj = NULL;
+ result = ns_config_get(maps, "override-cache-ttl", &obj);
@@ -30,10 +28,9 @@ diff -Nabdur bind-9.6.0-P1.orig/bin/named/server.c bind-9.6.0-P1/bin/named/serve
result = ns_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
-diff -Nabdur bind-9.6.0-P1.orig/lib/dns/include/dns/view.h bind-9.6.0-P1/lib/dns/include/dns/view.h
---- lib/dns/include/dns/view.h 2009-05-22 12:24:49.000000000 +0400
-+++ lib/dns/include/dns/view.h 2009-05-22 12:29:03.000000000 +0400
-@@ -131,6 +131,8 @@
+--- lib/dns/include/dns/view.h.orig 2015-09-09 02:23:50 UTC
++++ lib/dns/include/dns/view.h
+@@ -148,6 +148,8 @@ struct dns_view {
isc_boolean_t provideixfr;
isc_boolean_t requestnsid;
dns_ttl_t maxcachettl;
@@ -42,10 +39,9 @@ diff -Nabdur bind-9.6.0-P1.orig/lib/dns/include/dns/view.h bind-9.6.0-P1/lib/dns
dns_ttl_t maxncachettl;
in_port_t dstport;
dns_aclenv_t aclenv;
-diff -Nabdur bind-9.6.0-P1.orig/lib/dns/resolver.c bind-9.6.0-P1/lib/dns/resolver.c
---- lib/dns/resolver.c 2009-05-22 12:24:49.000000000 +0400
-+++ lib/dns/resolver.c 2009-05-22 12:30:41.000000000 +0400
-@@ -4054,6 +4054,18 @@
+--- lib/dns/resolver.c.orig 2015-09-09 02:23:50 UTC
++++ lib/dns/resolver.c
+@@ -5086,6 +5086,18 @@ cache_name(fetchctx_t *fctx, dns_name_t
}
/*
@@ -64,10 +60,9 @@ diff -Nabdur bind-9.6.0-P1.orig/lib/dns/resolver.c bind-9.6.0-P1/lib/dns/resolve
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl)
-diff -Nabdur bind-9.6.0-P1.orig/lib/isccfg/namedconf.c bind-9.6.0-P1/lib/isccfg/namedconf.c
---- lib/isccfg/namedconf.c 2009-05-22 12:24:49.000000000 +0400
-+++ lib/isccfg/namedconf.c 2009-05-22 12:31:21.000000000 +0400
-@@ -821,6 +821,8 @@
+--- lib/isccfg/namedconf.c.orig 2015-09-09 02:23:50 UTC
++++ lib/isccfg/namedconf.c
+@@ -1448,6 +1448,8 @@ view_clauses[] = {
{ "lame-ttl", &cfg_type_uint32, 0 },
{ "max-acache-size", &cfg_type_sizenodefault, 0 },
{ "max-cache-size", &cfg_type_sizenodefault, 0 },
diff --git a/dns/bind99/files/patch-configure b/dns/bind99/files/patch-configure
index f25f5d4de0e7..715ee8a25692 100644
--- a/dns/bind99/files/patch-configure
+++ b/dns/bind99/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2014-09-16 19:27:20 UTC
+--- configure.orig 2015-09-09 02:23:50 UTC
+++ configure
-@@ -14211,6 +14211,8 @@
+@@ -14289,6 +14289,8 @@ done
"-lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err -lresolv" \
"-lgssapi" \
"-lgssapi -lkrb5 -ldes -lcrypt -lasn1 -lroken -lcom_err" \