aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--print/libpaper/Makefile9
-rw-r--r--print/libpaper/distinfo4
-rw-r--r--print/libpaper/files/patch-configure10
-rw-r--r--print/libpaper/files/patch-lib::Makefile.in11
4 files changed, 17 insertions, 17 deletions
diff --git a/print/libpaper/Makefile b/print/libpaper/Makefile
index d4b55e22b55f..6a2f69e88536 100644
--- a/print/libpaper/Makefile
+++ b/print/libpaper/Makefile
@@ -6,22 +6,21 @@
#
PORTNAME= libpaper
-PORTVERSION= 1.1.14
+PORTVERSION= 1.1.14.3
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_DEBIAN}
MASTER_SITE_SUBDIR= pool/main/libp/libpaper
-DISTNAME= ${PORTNAME}_${PORTVERSION}
+DISTNAME= ${PORTNAME}_${PORTVERSION:S/.3/-3/}
MAINTAINER= lofi@freebsd.org
COMMENT= A library providing routines for paper size management
-USE_LIBTOOL_VER=13
-LIBTOOLFLAGS= # None, we want the libtool archives
+USE_INC_LIBTOOL_VER=15
INSTALLS_SHLIB= Yes
USE_GETOPT_LONG=Yes
CONFIGURE_ARGS= --build=${CONFIGURE_TARGET}
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.3//}
MAN1= paperconf.1
MAN3= defaultpapername.3 defaultpapersizefile.3 paperdone.3 paperfirst.3 \
diff --git a/print/libpaper/distinfo b/print/libpaper/distinfo
index 721e214d806d..27e09585ca68 100644
--- a/print/libpaper/distinfo
+++ b/print/libpaper/distinfo
@@ -1,2 +1,2 @@
-MD5 (libpaper_1.1.14.tar.gz) = 876979cb4cceb067f8af5ab79cd90fa5
-SIZE (libpaper_1.1.14.tar.gz) = 297507
+MD5 (libpaper_1.1.14-3.tar.gz) = ce8aa414571fb5afd278e2a6de0fac29
+SIZE (libpaper_1.1.14-3.tar.gz) = 301674
diff --git a/print/libpaper/files/patch-configure b/print/libpaper/files/patch-configure
deleted file mode 100644
index 8e6c8c4d9f70..000000000000
--- a/print/libpaper/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Sun Nov 16 20:06:41 2003
-+++ configure Sun Nov 16 20:06:52 2003
-@@ -7865,6 +7865,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/print/libpaper/files/patch-lib::Makefile.in b/print/libpaper/files/patch-lib::Makefile.in
new file mode 100644
index 000000000000..d48df1ecb67f
--- /dev/null
+++ b/print/libpaper/files/patch-lib::Makefile.in
@@ -0,0 +1,11 @@
+--- lib/Makefile.in.orig Sat Oct 23 12:04:02 2004
++++ lib/Makefile.in Mon Feb 14 13:12:45 2005
+@@ -543,7 +543,7 @@
+ if ($$4 == "mm") factor = 72.0 / 25.4; \
+ if ($$4 == "in") factor = 72.0; \
+ printf(" { \"%s\", %5f, %5f },\n", \
+- $$1, $$2 * factor, $$3 * factor); }' < $< >> $@
++ $$1, $$2 * factor, $$3 * factor); }' < paperspecs >> $@
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT: