aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11/Makefile1
-rw-r--r--x11/keybinder-gtk3/Makefile24
-rw-r--r--x11/keybinder-gtk3/distinfo2
-rw-r--r--x11/keybinder-gtk3/pkg-descr4
-rw-r--r--x11/keybinder-gtk3/pkg-plist8
5 files changed, 39 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index a4062029ad48..479b6f455ed8 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -129,6 +129,7 @@
SUBDIR += kde4-workspace
SUBDIR += kdelibs4
SUBDIR += keybinder
+ SUBDIR += keybinder-gtk3
SUBDIR += keyboardcast
SUBDIR += keylaunch
SUBDIR += keynav
diff --git a/x11/keybinder-gtk3/Makefile b/x11/keybinder-gtk3/Makefile
new file mode 100644
index 000000000000..40231b56f422
--- /dev/null
+++ b/x11/keybinder-gtk3/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= keybinder
+PORTVERSION= 0.3.0
+CATEGORIES= x11
+MASTER_SITES= GENTOO/distfiles
+PKGNAMESUFFIX= -gtk3
+DISTNAME= ${PORTNAME}-3.0-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Library for registering keyboard shortcuts
+
+LICENSE= GPLv2
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-gtk-doc-html --without-html-dir
+USES= gmake libtool pathfix pkgconfig
+USE_GNOME= gtk30 introspection:build
+USE_XORG= x11 xext xrender
+USE_LDCONFIG= yes
+
+PLIST_SUB+= VERSION="3.0"
+
+.include <bsd.port.mk>
diff --git a/x11/keybinder-gtk3/distinfo b/x11/keybinder-gtk3/distinfo
new file mode 100644
index 000000000000..6b17ce03e1d2
--- /dev/null
+++ b/x11/keybinder-gtk3/distinfo
@@ -0,0 +1,2 @@
+SHA256 (keybinder-3.0-0.3.0.tar.gz) = 982a6a5bc0fe1487862814b368e98211b9ec93fb5df3c9c0a88be526e0d2268e
+SIZE (keybinder-3.0-0.3.0.tar.gz) = 346383
diff --git a/x11/keybinder-gtk3/pkg-descr b/x11/keybinder-gtk3/pkg-descr
new file mode 100644
index 000000000000..85c7c55a6366
--- /dev/null
+++ b/x11/keybinder-gtk3/pkg-descr
@@ -0,0 +1,4 @@
+Keybinder is a library for registering global keyboard shortcuts. Keybinder
+works with GTK-based applications using the X Window System.
+
+WWW: https://github.com/engla/keybinder
diff --git a/x11/keybinder-gtk3/pkg-plist b/x11/keybinder-gtk3/pkg-plist
new file mode 100644
index 000000000000..975a6603b3bb
--- /dev/null
+++ b/x11/keybinder-gtk3/pkg-plist
@@ -0,0 +1,8 @@
+include/keybinder-%%VERSION%%/keybinder.h
+lib/girepository-1.0/Keybinder-%%VERSION%%.typelib
+lib/libkeybinder-%%VERSION%%.so
+lib/libkeybinder-%%VERSION%%.so.0
+lib/libkeybinder-%%VERSION%%.so.0.0.0
+libdata/pkgconfig/keybinder-%%VERSION%%.pc
+share/gir-1.0/Keybinder-%%VERSION%%.gir
+@dirrm include/keybinder-%%VERSION%%