aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--GIDs2
-rw-r--r--UIDs2
-rw-r--r--comms/svxlink/Makefile61
-rw-r--r--comms/svxlink/distinfo6
-rw-r--r--comms/svxlink/pkg-plist8
5 files changed, 41 insertions, 38 deletions
diff --git a/GIDs b/GIDs
index a2e872ae22ab..862dc28445c0 100644
--- a/GIDs
+++ b/GIDs
@@ -271,7 +271,7 @@ _reticulum:*:327:
galene:*:328:
certspotter:*:329:
orthanc:*:330:
-# free: 331
+svxlink:*:331:
# free: 332
# free: 333
honeytrap:*:333:
diff --git a/UIDs b/UIDs
index f0522ea3f17c..e8a4a025a983 100644
--- a/UIDs
+++ b/UIDs
@@ -276,7 +276,7 @@ _reticulum:*:327:327::0:0:Reticulum Daemon:/nonexistent:/usr/sbin/nologin
galene:*:328:328::0:0:Galene Visioconference server:/nonexistent:/usr/sbin/nologin
certspotter:*:329:329::0:0:Cert Spotter user:/nonexistent:/usr/sbin/nologin
orthanc:*:330:330::0:0:Orthanc Daemon:/nonexistent:/usr/sbin/nologin
-# free: 331
+svxlink:*:331:331::0:0:svxlink server:/nonexistent:/usr/sbin/nologin
# free: 332
honeytrap:*:333:333::0:0:HoneyTrap Daemon:/nonexistent:/usr/sbin/nologin
# free: 334
diff --git a/comms/svxlink/Makefile b/comms/svxlink/Makefile
index 371bf32ab611..f0180a805dce 100644
--- a/comms/svxlink/Makefile
+++ b/comms/svxlink/Makefile
@@ -1,6 +1,5 @@
PORTNAME?= svxlink
-PORTVERSION= 19.09.1
-PORTREVISION= 4
+PORTVERSION= 19.09.2
CATEGORIES= comms hamradio
MAINTAINER= hamradio@FreeBSD.org
@@ -9,15 +8,15 @@ WWW= https://www.svxlink.org/
LICENSE?= GPLv2
-LIB_DEPENDS?= libgsm.so:audio/gsm \
- libspeex.so:audio/speex \
- libgpg-error.so:security/libgpg-error \
+LIB_DEPENDS?= libcurl.so:ftp/curl \
libgcrypt.so:security/libgcrypt \
- libsigc-2.0.so:devel/libsigc++20 \
- libpopt.so:devel/popt \
+ libgpg-error.so:security/libgpg-error \
+ libgsm.so:audio/gsm \
libopus.so:audio/opus \
+ libpopt.so:devel/popt \
librtlsdr.so:comms/rtl-sdr \
- libcurl.so:ftp/curl
+ libsigc-2.0.so:devel/libsigc++20 \
+ libspeex.so:audio/speex
BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:devel/evdev-proto
USES+= cmake:noninja compiler:c++11-lang groff pkgconfig tcl
@@ -26,36 +25,39 @@ GH_ACCOUNT= sm0svx
GH_PROJECT= svxlink
CMAKE_SOURCE_PATH= ${WRKSRC}/src
-CMAKE_ARGS+= -DMAN_INSTALL_DIR:FILEPATH=${PREFIX}/share/man \
- -DLOCAL_STATE_DIR=/var \
- -DLOCALBASE:STRING="${LOCALBASE}"
+CMAKE_ARGS+= -DLOCAL_STATE_DIR=/var \
+ -DLOCALBASE:STRING="${LOCALBASE}" \
+ -DMAN_INSTALL_DIR:FILEPATH=${PREFIX}/share/man
-.if ${PORTNAME}==svxlink
+USERS= svxlink
+GROUPS= svxlink
+USE_RC_SUBR= remotetrx svxlink svxreflector
+.if ${PORTNAME} == svxlink
CMAKE_ARGS+= -DUSE_QT:BOOL=NO
.endif
USE_LDCONFIG= yes
-ALL_TARGET?= all man
-OPTIONS_DEFINE= DOXYGEN STATIC DOCS
-STATIC_DESC= Build and install static libraries
+ALL_TARGET?= all man
+OPTIONS_DEFINE= DOCS DOXYGEN STATIC
+STATIC_DESC= Build and install static libraries
STATIC_CMAKE_ON= -DBUILD_STATIC_LIBS=YES
-.if ${PORTNAME}==svxlink
-OPTIONS_DEFAULT=OSS ALSA
-OPTIONS_MULTI= SOUND
+.if ${PORTNAME} == svxlink
+OPTIONS_DEFAULT= ALSA OSS
+OPTIONS_MULTI= SOUND
OPTIONS_MULTI_SOUND= ALSA OSS
ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
-ALSA_CMAKE_OFF= -DUSE_ALSA:BOOL=OFF
-ALSA_CMAKE_ON= -DUSE_ALSA:BOOL=ON
-OSS_CMAKE_OFF= -DUSE_OSS:BOOL=OFF
-OSS_CMAKE_ON= -DUSE_OSS:BOOL=ON
+ALSA_CMAKE_OFF= -DUSE_ALSA:BOOL=OFF
+ALSA_CMAKE_ON= -DUSE_ALSA:BOOL=ON
+OSS_CMAKE_OFF= -DUSE_OSS:BOOL=OFF
+OSS_CMAKE_ON= -DUSE_OSS:BOOL=ON
.endif
DOXYGEN_IMPLIES= DOCS
-DOXYGEN_ALL_TARGET=doc
+DOXYGEN_ALL_TARGET= doc
DOXYGEN_CMAKE_OFF= -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen:BOOL=TRUE
-DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen \
- dot:graphics/graphviz
-OPTIONS_SUB= yes
-PORTDOCS= *
+DOXYGEN_BUILD_DEPENDS= dot:graphics/graphviz \
+ doxygen:devel/doxygen
+OPTIONS_SUB= yes
+PORTDOCS= *
post-patch:
@${GREP} -lr /dev/ttyS0 ${WRKSRC} | ${GREP} -v .bak | ${GREP} -v .orig | ${XARGS} \
@@ -75,7 +77,7 @@ post-patch-OSS-on:
@${GREP} -lr alsa:plughw:0 ${WRKSRC} | ${GREP} -v .bak | ${GREP} -v .orig | ${XARGS} \
${REINPLACE_CMD} -e 's|alsa:plughw:0|oss:/dev/dsp|'
-.if ${PORTNAME}==svxlink
+.if ${PORTNAME} == svxlink
post-install:
${MV} ${STAGEDIR}${PREFIX}/etc/svxlink/.procmailrc \
${STAGEDIR}${PREFIX}/etc/svxlink/.procmailrc.sample
@@ -114,10 +116,11 @@ do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/src/doc/README-19.09.adoc ${STAGEDIR}${DOCSDIR}
.endif
-.if ${PORTNAME}==qtel
+.if ${PORTNAME} == qtel
post-install:
${RM} ${STAGEDIR}${PREFIX}/include/svxlink/CppStdCompat.h
${RM} ${STAGEDIR}${PREFIX}/include/svxlink/common.h
${RM} ${STAGEDIR}${PREFIX}/lib/libsvxmisc.a
.endif
+ ${INSTALL} -d ${STAGEDIR}/var/spool/svxlink
.include <bsd.port.mk>
diff --git a/comms/svxlink/distinfo b/comms/svxlink/distinfo
index 4f58aff99b46..89a08bd93c52 100644
--- a/comms/svxlink/distinfo
+++ b/comms/svxlink/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1567427570
-SHA256 (sm0svx-svxlink-19.09.1_GH0.tar.gz) = 5e5cbc3501fa6c6ec68334f8217ef93f5dc879d4d0e41e6f71378fd67d69f6a2
-SIZE (sm0svx-svxlink-19.09.1_GH0.tar.gz) = 1730688
+TIMESTAMP = 1702760267
+SHA256 (sm0svx-svxlink-19.09.2_GH0.tar.gz) = 47e9bf098cef19a8f0a3bf567e96d70447cb028e0fcfc3bbeb692ae5bae05a70
+SIZE (sm0svx-svxlink-19.09.2_GH0.tar.gz) = 1730836
diff --git a/comms/svxlink/pkg-plist b/comms/svxlink/pkg-plist
index ebc2363e7103..23f3f559633d 100644
--- a/comms/svxlink/pkg-plist
+++ b/comms/svxlink/pkg-plist
@@ -147,7 +147,7 @@ share/man/man5/svxreflector.conf.5.gz
sbin/svxlink_gpio_down
sbin/svxlink_gpio_up
@dir %%DATADIR%%/sounds
-@dir /var/spool/svxlink/propagation_monitor
-@dir /var/spool/svxlink/qso_recorder
-@dir /var/spool/svxlink/voice_mail
-@dir /var/spool/svxlink
+@dir(svxlink,svxlink,755) /var/spool/svxlink/propagation_monitor
+@dir(svxlink,svxlink,755) /var/spool/svxlink/qso_recorder
+@dir(svxlink,svxlink,755) /var/spool/svxlink/voice_mail
+@dir(svxlink,svxlink,755) /var/spool/svxlink