aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/php56/Makefile6
-rw-r--r--lang/php56/Makefile.ext1
-rw-r--r--lang/php56/distinfo6
-rw-r--r--mail/php56-imap/Makefile1
-rw-r--r--mail/php56-imap/files/patch-php__imap.c40
-rw-r--r--mail/php56-imap/files/patch-php__imap.h10
-rw-r--r--net-mgmt/php56-snmp/files/patch-config.m410
-rw-r--r--security/php56-openssl/Makefile1
8 files changed, 17 insertions, 58 deletions
diff --git a/lang/php56/Makefile b/lang/php56/Makefile
index 10948923e6af..a2e51e89ba40 100644
--- a/lang/php56/Makefile
+++ b/lang/php56/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= php56
-PORTVERSION= 5.6.38
+PORTVERSION= 5.6.39
PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= PHP/distributions
@@ -32,7 +32,7 @@ CONFIGURE_ARGS+=--with-layout=GNU \
--with-pcre-regex=${LOCALBASE} \
--with-zlib-dir=/usr \
--program-prefix=""
-USES+= autoreconf:build
+USES+= autoreconf:build gnome
USE_GNOME= libxml2
# PR230207 Allow relocations against read-only segments (override lld default)
@@ -55,7 +55,7 @@ MAILHEAD_DESC= Enable mail header patch
LINKTHR_DESC= Link thread lib (for threaded extensions)
ZTS_DESC= Force Zend Thread Safety (ZTS) build
-CONFLICTS= php55-5* php70-* php71-* php72-* php73-*
+CONFLICTS= php70-* php71-* php72-* php73-*
DESTDIRNAME= INSTALL_ROOT
diff --git a/lang/php56/Makefile.ext b/lang/php56/Makefile.ext
index 1490ede652c8..8b92e380b4b4 100644
--- a/lang/php56/Makefile.ext
+++ b/lang/php56/Makefile.ext
@@ -316,6 +316,7 @@ USES+= readline
LIB_DEPENDS+= librecode.so:converters/recode
CONFIGURE_ARGS+=--with-recode=${LOCALBASE}
+MPHP_MOD_PRIO= 18
.endif
.if ${PHP_MODNAME} == "session"
diff --git a/lang/php56/distinfo b/lang/php56/distinfo
index 8f129e812e8e..2b1a234a3b58 100644
--- a/lang/php56/distinfo
+++ b/lang/php56/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1537790285
-SHA256 (php-5.6.38.tar.xz) = c2fac47dc6316bd230f0ea91d8a5498af122fb6a3eb43f796c9ea5f59b04aa1e
-SIZE (php-5.6.38.tar.xz) = 12467408
+TIMESTAMP = 1544448187
+SHA256 (php-5.6.39.tar.xz) = 8147576001a832ff3d03cb2980caa2d6b584a10624f87ac459fcd3948c6e4a10
+SIZE (php-5.6.39.tar.xz) = 12467096
SHA256 (php-5.5.x-mail-header.patch) = f510672c4bf2c228e4d8c7837e16a82169de82139dcf33fafce51e9e55a1b9ed
SIZE (php-5.5.x-mail-header.patch) = 4426
diff --git a/mail/php56-imap/Makefile b/mail/php56-imap/Makefile
index 6bc1c55c249e..fb2e5394f3e0 100644
--- a/mail/php56-imap/Makefile
+++ b/mail/php56-imap/Makefile
@@ -2,7 +2,6 @@
# $FreeBSD$
CATEGORIES= mail
-PORTREVISION= 1
MASTERDIR= ${.CURDIR}/../../lang/php56
diff --git a/mail/php56-imap/files/patch-php__imap.c b/mail/php56-imap/files/patch-php__imap.c
deleted file mode 100644
index faa12adafa16..000000000000
--- a/mail/php56-imap/files/patch-php__imap.c
+++ /dev/null
@@ -1,40 +0,0 @@
---- php_imap.c.orig 2018-09-11 22:12:36 UTC
-+++ php_imap.c
-@@ -562,6 +562,15 @@ static const zend_module_dep imap_deps[]
- };
- /* }}} */
-
-+
-+/* {{{ PHP_INI
-+ */
-+PHP_INI_BEGIN()
-+STD_PHP_INI_BOOLEAN("imap.enable_insecure_rsh", "0", PHP_INI_SYSTEM, OnUpdateBool, enable_rsh, zend_imap_globals, imap_globals)
-+PHP_INI_END()
-+/* }}} */
-+
-+
- /* {{{ imap_module_entry
- */
- zend_module_entry imap_module_entry = {
-@@ -835,6 +844,8 @@ PHP_MINIT_FUNCTION(imap)
- {
- unsigned long sa_all = SA_MESSAGES | SA_RECENT | SA_UNSEEN | SA_UIDNEXT | SA_UIDVALIDITY;
-
-+ REGISTER_INI_ENTRIES();
-+
- #ifndef PHP_WIN32
- mail_link(&unixdriver); /* link in the unix driver */
- mail_link(&mhdriver); /* link in the mh driver */
-@@ -1052,6 +1063,12 @@ PHP_MINIT_FUNCTION(imap)
- GC_TEXTS texts
- */
-
-+ if (!IMAPG(enable_rsh)) {
-+ /* disable SSH and RSH, see https://bugs.php.net/bug.php?id=77153 */
-+ mail_parameters (NIL, SET_RSHTIMEOUT, 0);
-+ mail_parameters (NIL, SET_SSHTIMEOUT, 0);
-+ }
-+
- le_imap = zend_register_list_destructors_ex(mail_close_it, NULL, "imap", module_number);
- return SUCCESS;
- }
diff --git a/mail/php56-imap/files/patch-php__imap.h b/mail/php56-imap/files/patch-php__imap.h
deleted file mode 100644
index f27f888f2ee7..000000000000
--- a/mail/php56-imap/files/patch-php__imap.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- php_imap.h.orig 2018-09-11 22:12:36 UTC
-+++ php_imap.h
-@@ -214,6 +214,7 @@ ZEND_BEGIN_MODULE_GLOBALS(imap)
- #endif
- /* php_stream for php_mail_gets() */
- php_stream *gets_stream;
-+ zend_bool enable_rsh;
- ZEND_END_MODULE_GLOBALS(imap)
-
- #ifdef ZTS
diff --git a/net-mgmt/php56-snmp/files/patch-config.m4 b/net-mgmt/php56-snmp/files/patch-config.m4
new file mode 100644
index 000000000000..4f39e6253c6d
--- /dev/null
+++ b/net-mgmt/php56-snmp/files/patch-config.m4
@@ -0,0 +1,10 @@
+--- config.m4.orig 2018-08-31 12:19:23 UTC
++++ config.m4
+@@ -18,7 +18,6 @@ if test "$PHP_SNMP" != "no"; then
+
+ if test -x "$SNMP_CONFIG"; then
+ SNMP_LIBS=`$SNMP_CONFIG --netsnmp-libs`
+- SNMP_LIBS="$SNMP_LIBS `$SNMP_CONFIG --external-libs`"
+ SNMP_PREFIX=`$SNMP_CONFIG --prefix`
+ snmp_full_version=`$SNMP_CONFIG --version`
+ ac_IFS=$IFS
diff --git a/security/php56-openssl/Makefile b/security/php56-openssl/Makefile
index 0ce585246dcd..66530318ade6 100644
--- a/security/php56-openssl/Makefile
+++ b/security/php56-openssl/Makefile
@@ -5,7 +5,6 @@ CATEGORIES= security
MASTERDIR= ${.CURDIR}/../../lang/php56
-PORTREVISION= 1
PKGNAMESUFFIX= -openssl
.include "${MASTERDIR}/Makefile"