aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Getopt-ArgvFile/Makefile26
-rw-r--r--devel/p5-Getopt-ArgvFile/distinfo1
-rw-r--r--devel/p5-Getopt-ArgvFile/pkg-comment1
-rw-r--r--devel/p5-Getopt-ArgvFile/pkg-descr12
-rw-r--r--devel/p5-Getopt-ArgvFile/pkg-plist7
6 files changed, 48 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 160d18254867..a7302c92600c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -442,6 +442,7 @@
SUBDIR += p5-Filter-CBC
SUBDIR += p5-FreezeThaw
SUBDIR += p5-Getargs-Long
+ SUBDIR += p5-Getopt-ArgvFile
SUBDIR += p5-Getopt-Declare
SUBDIR += p5-Getopt-Long
SUBDIR += p5-Glade-Perl
diff --git a/devel/p5-Getopt-ArgvFile/Makefile b/devel/p5-Getopt-ArgvFile/Makefile
new file mode 100644
index 000000000000..18053b79f9e1
--- /dev/null
+++ b/devel/p5-Getopt-ArgvFile/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: devel/p5-Getopt-ArgvFile
+# Date created: 03 May 2002
+# Whom: Eric Schnoebelen <eric@cirr.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Getopt-ArgvFile
+PORTVERSION= 1.05
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Getopt
+PKGNAMEPREFIX= p5-
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= eric@cirr.com
+
+PERL_CONFIGURE= yes
+
+MAN3= Getopt::ArgvFile.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+pre-configure:
+ ${PERL} -pi -e 'm.INSTALLDIRS.&&s,.,,sg' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Getopt-ArgvFile/distinfo b/devel/p5-Getopt-ArgvFile/distinfo
new file mode 100644
index 000000000000..71a525e31fac
--- /dev/null
+++ b/devel/p5-Getopt-ArgvFile/distinfo
@@ -0,0 +1 @@
+MD5 (Getopt-ArgvFile-1.05.tgz) = 2a1596236f9a9bb9e669b2ae87c6f32a
diff --git a/devel/p5-Getopt-ArgvFile/pkg-comment b/devel/p5-Getopt-ArgvFile/pkg-comment
new file mode 100644
index 000000000000..4caa64299357
--- /dev/null
+++ b/devel/p5-Getopt-ArgvFile/pkg-comment
@@ -0,0 +1 @@
+Perl module for processing argument vectors
diff --git a/devel/p5-Getopt-ArgvFile/pkg-descr b/devel/p5-Getopt-ArgvFile/pkg-descr
new file mode 100644
index 000000000000..aa389c1d5acf
--- /dev/null
+++ b/devel/p5-Getopt-ArgvFile/pkg-descr
@@ -0,0 +1,12 @@
+Module Getopt::ArgvFile is a simple supplement to other option
+handling modules. It allows script options and parameters to be
+read from files instead of from the command line by interpolating
+file contents into @ARGV. This way it PREPARES the final option
+handling.
+
+Getopt::ArgvFile does NOT perform any option processing itself, and
+should work fine together with any other option handling module
+(e.g. Getopt::Long) or even self coded option handling.
+
+-Anton
+<tobez@FreeBSD.org>
diff --git a/devel/p5-Getopt-ArgvFile/pkg-plist b/devel/p5-Getopt-ArgvFile/pkg-plist
new file mode 100644
index 000000000000..02c91f134be1
--- /dev/null
+++ b/devel/p5-Getopt-ArgvFile/pkg-plist
@@ -0,0 +1,7 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Getopt/ArgvFile/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Getopt/ArgvFile.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Getopt/ArgvFile
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Getopt/ArgvFile
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/auto/Getopt 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Getopt 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Getopt 2>/dev/null || true