aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/quelcom/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/audio/quelcom/Makefile b/audio/quelcom/Makefile
index 6e516dac23c7..9b8a8527a8f1 100644
--- a/audio/quelcom/Makefile
+++ b/audio/quelcom/Makefile
@@ -26,6 +26,12 @@ CXXFLAGS+= -I../lib -I${LOCALBASE}/include ${CPPFLAGS} \
-DHAVE_DECL_GETOPT -fPIC
LDFLAGS= -L../lib -L${LOCALBASE}/lib -lintl
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "alpha" && ${OSVERSION} < 500000
+BROKEN= "Linker error on alpha 4.x"
+.endif
+
post-patch:
@${FIND} ${WRKSRC} -name "makefile" | ${XARGS} ${REINPLACE_CMD} -e \
's|make |$$(MAKE) |g ; \
@@ -52,4 +58,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/doc/quelcom.html ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>