aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--biology/bowtie2/Makefile2
-rw-r--r--devel/onetbb/Makefile11
-rw-r--r--devel/onetbb/distinfo6
-rw-r--r--devel/onetbb/files/patch-src-tbbbind-CMakeLists.txt11
-rw-r--r--devel/onetbb/pkg-plist12
-rw-r--r--graphics/blender/Makefile2
-rw-r--r--graphics/embree/Makefile1
-rw-r--r--graphics/oidn/Makefile2
-rw-r--r--graphics/openimageio/Makefile2
-rw-r--r--math/dune-common/Makefile2
-rw-r--r--math/dune-geometry/Makefile2
-rw-r--r--math/dune-grid/Makefile2
-rw-r--r--math/dune-pdelab/Makefile2
-rw-r--r--math/dune-uggrid/Makefile2
-rw-r--r--math/openturns/Makefile2
-rw-r--r--math/saga/Makefile2
-rw-r--r--misc/ngraph/Makefile2
17 files changed, 31 insertions, 34 deletions
diff --git a/biology/bowtie2/Makefile b/biology/bowtie2/Makefile
index bc507cdcfa2e..198cf295e73e 100644
--- a/biology/bowtie2/Makefile
+++ b/biology/bowtie2/Makefile
@@ -1,7 +1,7 @@
PORTNAME= bowtie2
DISTVERSIONPREFIX= v
DISTVERSION= 2.4.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= biology perl5 python
MAINTAINER= jwb@FreeBSD.org
diff --git a/devel/onetbb/Makefile b/devel/onetbb/Makefile
index fe9f09c88155..5cda501074da 100644
--- a/devel/onetbb/Makefile
+++ b/devel/onetbb/Makefile
@@ -1,7 +1,7 @@
# Created by: Arun Sharma <arun@sharma-home.net>
PORTNAME= onetbb
-PORTVERSION= 2021.1.1
+PORTVERSION= 2021.2.0
DISTVERSIONPREFIX= v
CATEGORIES= devel
@@ -14,7 +14,10 @@ LIB_DEPENDS= libhwloc.so.15:devel/hwloc2
USES= cmake compiler:c++11-lang tar:tgz
-CMAKE_ARGS+= -DTBB_STRICT:BOOL=FALSE
+CMAKE_ARGS+= -DTBB_STRICT:BOOL=FALSE \
+ -DCMAKE_INSTALL_DOCDIR:PATH="${DOCSDIR}" \
+ -DCMAKE_HWLOC_2_4_LIBRARY_PATH:PATH="${LOCALBASE}/lib/libhwloc.so" \
+ -DCMAKE_HWLOC_2_4_INCLUDE_PATH:PATH="${LOCALBASE}/include"
CONFLICTS= tbb-[0-9]*
@@ -30,6 +33,10 @@ SUB_LIST= prefix="${PREFIX}" \
USE_LDCONFIG= yes
+PORTDOCS= README.md
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
post-install:
diff --git a/devel/onetbb/distinfo b/devel/onetbb/distinfo
index b70c4947aeee..d59b54391657 100644
--- a/devel/onetbb/distinfo
+++ b/devel/onetbb/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1608578552
-SHA256 (oneapi-src-oneTBB-v2021.1.1_GH0.tar.gz) = b182c73caaaabc44ddc5ad13113aca7e453af73c1690e4061f71dfe4935d74e8
-SIZE (oneapi-src-oneTBB-v2021.1.1_GH0.tar.gz) = 1062960
+TIMESTAMP = 1617819323
+SHA256 (oneapi-src-oneTBB-v2021.2.0_GH0.tar.gz) = cee20b0a71d977416f3e3b4ec643ee4f38cedeb2a9ff015303431dd9d8d79854
+SIZE (oneapi-src-oneTBB-v2021.2.0_GH0.tar.gz) = 1606919
diff --git a/devel/onetbb/files/patch-src-tbbbind-CMakeLists.txt b/devel/onetbb/files/patch-src-tbbbind-CMakeLists.txt
deleted file mode 100644
index 58c11a42c43a..000000000000
--- a/devel/onetbb/files/patch-src-tbbbind-CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
-Disable legacy hwloc lookup
-
---- src/tbbbind/CMakeLists.txt.orig 2020-12-08 11:00:57 UTC
-+++ src/tbbbind/CMakeLists.txt
-@@ -82,5 +82,5 @@ macro(tbbbind_build TBBBIND_NAME HWLOC_VERSION)
- endmacro()
-
- message(STATUS "Trying to find HWLOC (versions 2 and 1.11) to build TBBBind library")
--tbbbind_build(tbbbind 1.11)
-+#tbbbind_build(tbbbind 1.11)
- tbbbind_build(tbbbind_2_0 2)
diff --git a/devel/onetbb/pkg-plist b/devel/onetbb/pkg-plist
index 642e39c2a4a9..2f1601193448 100644
--- a/devel/onetbb/pkg-plist
+++ b/devel/onetbb/pkg-plist
@@ -133,14 +133,14 @@ lib/cmake/TBB/TBBTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/TBB/TBBTargets.cmake
lib/libtbb.so
lib/libtbb.so.12
-lib/libtbb.so.12.1
-lib/libtbbbind_2_0.so
-lib/libtbbbind_2_0.so.3
-lib/libtbbbind_2_0.so.3.1
+lib/libtbb.so.12.2
+lib/libtbbbind_2_4.so
+lib/libtbbbind_2_4.so.3
+lib/libtbbbind_2_4.so.3.2
lib/libtbbmalloc.so
lib/libtbbmalloc.so.2
-lib/libtbbmalloc.so.2.1
+lib/libtbbmalloc.so.2.2
lib/libtbbmalloc_proxy.so
lib/libtbbmalloc_proxy.so.2
-lib/libtbbmalloc_proxy.so.2.1
+lib/libtbbmalloc_proxy.so.2.2
libdata/pkgconfig/onetbb.pc
diff --git a/graphics/blender/Makefile b/graphics/blender/Makefile
index 297767cc79c5..71828c3af13f 100644
--- a/graphics/blender/Makefile
+++ b/graphics/blender/Makefile
@@ -2,7 +2,7 @@
PORTNAME= blender
DISTVERSION= 2.91.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics multimedia
MASTER_SITES= http://download.blender.org/source/ \
http://mirror.cs.umn.edu/blender.org/source/ \
diff --git a/graphics/embree/Makefile b/graphics/embree/Makefile
index c41dbe7a7e4b..169cfcc317ba 100644
--- a/graphics/embree/Makefile
+++ b/graphics/embree/Makefile
@@ -2,6 +2,7 @@
PORTNAME= embree
PORTVERSION= 3.12.2
+PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= graphics
diff --git a/graphics/oidn/Makefile b/graphics/oidn/Makefile
index eb61568dc31f..dbf907abd3cd 100644
--- a/graphics/oidn/Makefile
+++ b/graphics/oidn/Makefile
@@ -1,7 +1,7 @@
PORTNAME= oidn
DISTVERSIONPREFIX= v
DISTVERSION= 1.3.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= http://freebsd.org/:weights # bogus URL to make the framework happy, the fetch uses Git URL below
DISTFILES= ${PORTNAME}-weights-${WEIGHTS_GIT_HASH}${EXTRACT_SUFX}:weights
diff --git a/graphics/openimageio/Makefile b/graphics/openimageio/Makefile
index 1c6d79fe769b..3132881e843b 100644
--- a/graphics/openimageio/Makefile
+++ b/graphics/openimageio/Makefile
@@ -7,7 +7,7 @@ DISTVERSION= 2.2.13.1
# py-openimageio's PORTREVISION.
# Also, just to be on the safe side, when resetting,
# best keep PORTREVISION?= 0.
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= graphics multimedia
MAINTAINER?= FreeBSD@Shaneware.biz
diff --git a/math/dune-common/Makefile b/math/dune-common/Makefile
index c278a5a6ca37..28ae3c752d6a 100644
--- a/math/dune-common/Makefile
+++ b/math/dune-common/Makefile
@@ -1,7 +1,7 @@
PORTNAME= dune-common
DISTVERSIONPREFIX= v
DISTVERSION= 2.7.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
diff --git a/math/dune-geometry/Makefile b/math/dune-geometry/Makefile
index d5a4de5b2e0a..70b77b24401d 100644
--- a/math/dune-geometry/Makefile
+++ b/math/dune-geometry/Makefile
@@ -1,7 +1,7 @@
PORTNAME= dune-geometry
DISTVERSIONPREFIX= v
DISTVERSION= 2.7.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
diff --git a/math/dune-grid/Makefile b/math/dune-grid/Makefile
index 56f9fd69d2cf..7d7c6968c42a 100644
--- a/math/dune-grid/Makefile
+++ b/math/dune-grid/Makefile
@@ -1,7 +1,7 @@
PORTNAME= dune-grid
DISTVERSIONPREFIX= v
DISTVERSION= 2.7.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
diff --git a/math/dune-pdelab/Makefile b/math/dune-pdelab/Makefile
index 425f7967c03d..5d8a54938fb9 100644
--- a/math/dune-pdelab/Makefile
+++ b/math/dune-pdelab/Makefile
@@ -1,7 +1,7 @@
PORTNAME= dune-pdelab
DISTVERSIONPREFIX= v
DISTVERSION= 2.7.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
diff --git a/math/dune-uggrid/Makefile b/math/dune-uggrid/Makefile
index c858a82ecc4e..c45c8da8423b 100644
--- a/math/dune-uggrid/Makefile
+++ b/math/dune-uggrid/Makefile
@@ -1,7 +1,7 @@
PORTNAME= dune-uggrid
DISTVERSIONPREFIX= v
DISTVERSION= 2.7.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
diff --git a/math/openturns/Makefile b/math/openturns/Makefile
index 12f7f9525972..bc4e60d0888e 100644
--- a/math/openturns/Makefile
+++ b/math/openturns/Makefile
@@ -1,7 +1,7 @@
PORTNAME= openturns
DISTVERSIONPREFIX= v
DISTVERSION= 1.16
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
diff --git a/math/saga/Makefile b/math/saga/Makefile
index 64edd3656f45..dee268dfb611 100644
--- a/math/saga/Makefile
+++ b/math/saga/Makefile
@@ -2,7 +2,7 @@
PORTNAME= saga
PORTVERSION= 7.9.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= math
MASTER_SITES= SF/saga-gis/SAGA%20-%20${PORTVERSION:C/\.[[:digit:]]\.[[:digit:]]*$//}/SAGA%20-%20${PORTVERSION}
diff --git a/misc/ngraph/Makefile b/misc/ngraph/Makefile
index 12f47980ef21..d13f5aa0a38d 100644
--- a/misc/ngraph/Makefile
+++ b/misc/ngraph/Makefile
@@ -2,7 +2,7 @@ PORTNAME= ngraph
DISTVERSIONPREFIX= v
DISTVERSION= 0.29.0-rc.0-345
DISTVERSIONSUFFIX= -g58b649aa6
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= misc # machine-learning
PKGNAMESUFFIX= -machine-learning-library