aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-wm/plasma5-kwin/Makefile1
-rw-r--r--x11-wm/plasma5-kwin/files/patch-src_xwl_xwaylandsocket.cpp35
2 files changed, 36 insertions, 0 deletions
diff --git a/x11-wm/plasma5-kwin/Makefile b/x11-wm/plasma5-kwin/Makefile
index 53230df60d29..64a87653bc99 100644
--- a/x11-wm/plasma5-kwin/Makefile
+++ b/x11-wm/plasma5-kwin/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kwin
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= x11-wm kde kde-plasma
MAINTAINER= kde@FreeBSD.org
diff --git a/x11-wm/plasma5-kwin/files/patch-src_xwl_xwaylandsocket.cpp b/x11-wm/plasma5-kwin/files/patch-src_xwl_xwaylandsocket.cpp
new file mode 100644
index 000000000000..ad44c2215dca
--- /dev/null
+++ b/x11-wm/plasma5-kwin/files/patch-src_xwl_xwaylandsocket.cpp
@@ -0,0 +1,35 @@
+$ kwin_wayland --xwayland
+[...]
+kwin_xwl: Failed to find free X11 connection socket
+Failed to establish X11 socket
+
+--- src/xwl/xwaylandsocket.cpp.orig 2021-08-31 11:41:03 UTC
++++ src/xwl/xwaylandsocket.cpp
+@@ -179,10 +179,17 @@ XwaylandSocket::XwaylandSocket()
+ continue;
+ }
+
++#if defined(Q_OS_LINUX)
+ const int abstractFileDescriptor = listen_helper(socketFilePath, UnixSocketAddress::Type::Abstract);
++#else
++ const int abstractFileDescriptor = listen_helper(socketFilePath + "_", UnixSocketAddress::Type::Unix);
++#endif
+ if (abstractFileDescriptor == -1) {
+ QFile::remove(lockFilePath);
+ QFile::remove(socketFilePath);
++#if !defined(Q_OS_LINUX)
++ QFile::remove(socketFilePath + "_");
++#endif
+ close(unixFileDescriptor);
+ continue;
+ }
+@@ -208,6 +215,9 @@ XwaylandSocket::~XwaylandSocket()
+ }
+ if (!m_socketFilePath.isEmpty()) {
+ QFile::remove(m_socketFilePath);
++#if !defined(Q_OS_LINUX)
++ QFile::remove(m_socketFilePath + "_");
++#endif
+ }
+ if (!m_lockFilePath.isEmpty()) {
+ QFile::remove(m_lockFilePath);