aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/chromium/Makefile2
-rw-r--r--www/chromium/files/patch-components_sync__device__info_local__device__info__util__linux.cc9
2 files changed, 5 insertions, 6 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index 96cb5ca75eb2..f5f6ea1f51cf 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -2,7 +2,7 @@
PORTNAME= chromium
PORTVERSION= 94.0.4606.81
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= https://commondatastorage.googleapis.com/chromium-browser-official/ \
LOCAL/rene/chromium/:fonts
diff --git a/www/chromium/files/patch-components_sync__device__info_local__device__info__util__linux.cc b/www/chromium/files/patch-components_sync__device__info_local__device__info__util__linux.cc
index f7aa5e4cfe4d..5b28209a44f6 100644
--- a/www/chromium/files/patch-components_sync__device__info_local__device__info__util__linux.cc
+++ b/www/chromium/files/patch-components_sync__device__info_local__device__info__util__linux.cc
@@ -1,14 +1,13 @@
---- components/sync_device_info/local_device_info_util_linux.cc.orig 2021-04-14 18:41:01 UTC
+--- components/sync_device_info/local_device_info_util_linux.cc.orig 2021-04-27 04:07:31 UTC
+++ components/sync_device_info/local_device_info_util_linux.cc
-@@ -38,8 +38,9 @@ std::string GetPersonalizableDeviceNameInternal() {
+@@ -38,8 +38,8 @@ std::string GetPersonalizableDeviceNameInternal() {
#if BUILDFLAG(IS_CHROMEOS_ASH)
return GetChromeOSDeviceNameFromType();
#else
- char hostname[HOST_NAME_MAX];
- if (gethostname(hostname, HOST_NAME_MAX) == 0) // Success.
-+ int len = sysconf(_SC_HOST_NAME_MAX);
-+ char hostname[len];
-+ if (gethostname(hostname, _SC_HOST_NAME_MAX) == 0) // Success.
++ char hostname[_POSIX_HOST_NAME_MAX];
++ if (gethostname(hostname, _POSIX_HOST_NAME_MAX) == 0) // Success.
return hostname;
return base::GetLinuxDistro();
#endif