aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/pecl-APC-devel/Makefile5
-rw-r--r--www/pecl-APC/Makefile5
2 files changed, 10 insertions, 0 deletions
diff --git a/www/pecl-APC-devel/Makefile b/www/pecl-APC-devel/Makefile
index ef81fa0c4479..100497901a01 100644
--- a/www/pecl-APC-devel/Makefile
+++ b/www/pecl-APC-devel/Makefile
@@ -27,6 +27,7 @@ CONFIGURE_ARGS= --enable-apc
OPTIONS= MMAP "Enable mmap memory support (default: IPC shm)" off \
SEMAPHORES "Enable sysv IPC semaphores (default: fcntl())" off \
+ SPINLOCKS "Enable spinlocks (experimental)" off \
FILEHITS "Enable per request cache info" off \
PHP4_OPT "Little optimization to PHP4" off
@@ -42,6 +43,10 @@ CONFIGURE_ARGS+= --enable-apc-mmap
CONFIGURE_ARGS+= --enable-apc-sem
.endif
+.if defined(WITH_SPINLOCKS)
+CONFIGURE_ARGS+= --enable-apc-spinlocks
+.endif
+
.if defined(WITH_FILEHITS)
CONFIGURE_ARGS+= --enable-apc-filehits
.endif
diff --git a/www/pecl-APC/Makefile b/www/pecl-APC/Makefile
index ef81fa0c4479..100497901a01 100644
--- a/www/pecl-APC/Makefile
+++ b/www/pecl-APC/Makefile
@@ -27,6 +27,7 @@ CONFIGURE_ARGS= --enable-apc
OPTIONS= MMAP "Enable mmap memory support (default: IPC shm)" off \
SEMAPHORES "Enable sysv IPC semaphores (default: fcntl())" off \
+ SPINLOCKS "Enable spinlocks (experimental)" off \
FILEHITS "Enable per request cache info" off \
PHP4_OPT "Little optimization to PHP4" off
@@ -42,6 +43,10 @@ CONFIGURE_ARGS+= --enable-apc-mmap
CONFIGURE_ARGS+= --enable-apc-sem
.endif
+.if defined(WITH_SPINLOCKS)
+CONFIGURE_ARGS+= --enable-apc-spinlocks
+.endif
+
.if defined(WITH_FILEHITS)
CONFIGURE_ARGS+= --enable-apc-filehits
.endif