aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/firefox-esr/Makefile8
-rw-r--r--www/firefox-esr/pkg-message2
-rw-r--r--www/firefox/Makefile8
-rw-r--r--www/firefox/pkg-message2
-rw-r--r--www/firefox36/Makefile8
-rw-r--r--www/firefox36/pkg-message2
-rw-r--r--www/xulrunner/Makefile7
7 files changed, 22 insertions, 15 deletions
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index d16ed0c7697b..06c91017a96c 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -3,11 +3,12 @@
# Whom: Alan Eldridge <alane@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/www/firefox/Makefile,v 1.23 2007/12/03 20:58:20 ahze Exp $
+# $MCom: ports/www/firefox/Makefile,v 1.43 2008/02/09 16:38:43 marcus Exp $
#
PORTNAME= firefox
DISTVERSION= 2.0.0.12
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
@@ -20,7 +21,6 @@ COMMENT= Web browser based on the browser portion of Mozilla
BUILD_DEPENDS= nss>=3.11.2:${PORTSDIR}/security/nss
MOZILLA_NAME= Firefox
-MOZ_OPTIONS= --program-transform-name='s/firefox/${MOZILLA}/'
WANT_GNOME= yes
ALL_TARGET= default
@@ -36,7 +36,9 @@ GECKO_PLIST_PRE_DIRS= lib/${MOZILLA}/chrome/icons/default lib/${MOZILLA}/chrome/
FIREFOX_ICON= ${MOZILLA}.xpm
FIREFOX_ICON_SRC= ${PREFIX}/lib/${MOZILLA}/icons/default.xpm
-MOZ_OPTIONS= --enable-application=browser \
+MOZ_OPTIONS= --program-transform-name='s/firefox/${MOZILLA}/' \
+ --with-default-mozilla-five-home=${PREFIX}/lib/${MOZILLA} \
+ --enable-application=browser \
--enable-system-cairo \
--enable-official-branding \
--enable-canvas \
diff --git a/www/firefox-esr/pkg-message b/www/firefox-esr/pkg-message
index 9e0a4dd2e9ff..a2f6c162d5e4 100644
--- a/www/firefox-esr/pkg-message
+++ b/www/firefox-esr/pkg-message
@@ -10,7 +10,7 @@ setup public key authentication to "remote_host":
ssh-keygen -t dsa
cat ~/.ssh/id_dsa.pub | ssh remote_host "cat >> .ssh/authorized_keys"
-The SSH sever on remote_host must allow pub key authentication.
+The SSH server on remote_host must allow pub key authentication.
======================================================================
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index d16ed0c7697b..06c91017a96c 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -3,11 +3,12 @@
# Whom: Alan Eldridge <alane@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/www/firefox/Makefile,v 1.23 2007/12/03 20:58:20 ahze Exp $
+# $MCom: ports/www/firefox/Makefile,v 1.43 2008/02/09 16:38:43 marcus Exp $
#
PORTNAME= firefox
DISTVERSION= 2.0.0.12
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
@@ -20,7 +21,6 @@ COMMENT= Web browser based on the browser portion of Mozilla
BUILD_DEPENDS= nss>=3.11.2:${PORTSDIR}/security/nss
MOZILLA_NAME= Firefox
-MOZ_OPTIONS= --program-transform-name='s/firefox/${MOZILLA}/'
WANT_GNOME= yes
ALL_TARGET= default
@@ -36,7 +36,9 @@ GECKO_PLIST_PRE_DIRS= lib/${MOZILLA}/chrome/icons/default lib/${MOZILLA}/chrome/
FIREFOX_ICON= ${MOZILLA}.xpm
FIREFOX_ICON_SRC= ${PREFIX}/lib/${MOZILLA}/icons/default.xpm
-MOZ_OPTIONS= --enable-application=browser \
+MOZ_OPTIONS= --program-transform-name='s/firefox/${MOZILLA}/' \
+ --with-default-mozilla-five-home=${PREFIX}/lib/${MOZILLA} \
+ --enable-application=browser \
--enable-system-cairo \
--enable-official-branding \
--enable-canvas \
diff --git a/www/firefox/pkg-message b/www/firefox/pkg-message
index 9e0a4dd2e9ff..a2f6c162d5e4 100644
--- a/www/firefox/pkg-message
+++ b/www/firefox/pkg-message
@@ -10,7 +10,7 @@ setup public key authentication to "remote_host":
ssh-keygen -t dsa
cat ~/.ssh/id_dsa.pub | ssh remote_host "cat >> .ssh/authorized_keys"
-The SSH sever on remote_host must allow pub key authentication.
+The SSH server on remote_host must allow pub key authentication.
======================================================================
diff --git a/www/firefox36/Makefile b/www/firefox36/Makefile
index d16ed0c7697b..06c91017a96c 100644
--- a/www/firefox36/Makefile
+++ b/www/firefox36/Makefile
@@ -3,11 +3,12 @@
# Whom: Alan Eldridge <alane@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/www/firefox/Makefile,v 1.23 2007/12/03 20:58:20 ahze Exp $
+# $MCom: ports/www/firefox/Makefile,v 1.43 2008/02/09 16:38:43 marcus Exp $
#
PORTNAME= firefox
DISTVERSION= 2.0.0.12
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
@@ -20,7 +21,6 @@ COMMENT= Web browser based on the browser portion of Mozilla
BUILD_DEPENDS= nss>=3.11.2:${PORTSDIR}/security/nss
MOZILLA_NAME= Firefox
-MOZ_OPTIONS= --program-transform-name='s/firefox/${MOZILLA}/'
WANT_GNOME= yes
ALL_TARGET= default
@@ -36,7 +36,9 @@ GECKO_PLIST_PRE_DIRS= lib/${MOZILLA}/chrome/icons/default lib/${MOZILLA}/chrome/
FIREFOX_ICON= ${MOZILLA}.xpm
FIREFOX_ICON_SRC= ${PREFIX}/lib/${MOZILLA}/icons/default.xpm
-MOZ_OPTIONS= --enable-application=browser \
+MOZ_OPTIONS= --program-transform-name='s/firefox/${MOZILLA}/' \
+ --with-default-mozilla-five-home=${PREFIX}/lib/${MOZILLA} \
+ --enable-application=browser \
--enable-system-cairo \
--enable-official-branding \
--enable-canvas \
diff --git a/www/firefox36/pkg-message b/www/firefox36/pkg-message
index 9e0a4dd2e9ff..a2f6c162d5e4 100644
--- a/www/firefox36/pkg-message
+++ b/www/firefox36/pkg-message
@@ -10,7 +10,7 @@ setup public key authentication to "remote_host":
ssh-keygen -t dsa
cat ~/.ssh/id_dsa.pub | ssh remote_host "cat >> .ssh/authorized_keys"
-The SSH sever on remote_host must allow pub key authentication.
+The SSH server on remote_host must allow pub key authentication.
======================================================================
diff --git a/www/xulrunner/Makefile b/www/xulrunner/Makefile
index ceddb6c1f6be..c4d6c5513406 100644
--- a/www/xulrunner/Makefile
+++ b/www/xulrunner/Makefile
@@ -3,12 +3,12 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/www/xulrunner/Makefile,v 1.13 2006/10/12 12:22:03 ahze Exp $
+# $MCom: ports/www/xulrunner/Makefile,v 1.15 2007/12/28 17:39:31 mezz Exp $
#
PORTNAME= xulrunner
PORTVERSION= 1.8.0.4
-PORTREVISION?= 9
+PORTREVISION?= 10
CATEGORIES?= www devel
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= xulrunner/releases/${PORTVERSION}/source/
@@ -26,7 +26,8 @@ USE_GMAKE= yes
USE_GCC= 3.4+
PORT_MOZCONFIG= ${WRKSRC}/xulrunner/config/mozconfig
-MOZ_OPTIONS?= --disable-javaxpcom --enable-canvas \
+MOZ_OPTIONS?= --with-default-mozilla-five-home=${PREFIX}/lib/${MOZILLA} \
+ --disable-javaxpcom --enable-canvas \
--enable-system-cairo
MOZ_EXTENSIONS= default,cookie,permissions
OPTIONS= # Empty, used for generic gecko OPTIONS