aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/armadillo/Makefile9
-rw-r--r--math/armadillo/distinfo4
-rw-r--r--math/armadillo/pkg-descr32
-rw-r--r--math/armadillo/pkg-plist2
4 files changed, 24 insertions, 23 deletions
diff --git a/math/armadillo/Makefile b/math/armadillo/Makefile
index 1292d4f2abda..cd1212c9ea2a 100644
--- a/math/armadillo/Makefile
+++ b/math/armadillo/Makefile
@@ -1,17 +1,18 @@
# $FreeBSD$
PORTNAME= armadillo
-PORTVERSION= 4.300.8
+PORTVERSION= 4.320.0
CATEGORIES= math
-MASTER_SITES= SF/arma/
+MASTER_SITES= SF/arma
MAINTAINER= ports@FreeBSD.org
COMMENT= C++ linear algebra library
LICENSE= MPL
-LIB_DEPENDS= liblapack.so:${PORTSDIR}/math/lapack \
- libboost_date_time.so:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= libboost_date_time.so:${PORTSDIR}/devel/boost-libs \
+ liblapack.so:${PORTSDIR}/math/lapack \
+ libhdf5.so:${PORTSDIR}/science/hdf5
USES= cmake
USE_LDCONFIG= yes
diff --git a/math/armadillo/distinfo b/math/armadillo/distinfo
index 95ba48cd874e..410317e4908e 100644
--- a/math/armadillo/distinfo
+++ b/math/armadillo/distinfo
@@ -1,2 +1,2 @@
-SHA256 (armadillo-4.300.8.tar.gz) = 1d1a77ad7a74e8b4a74d7b71c5e3fe488e26283907b316618de0a8558c60173a
-SIZE (armadillo-4.300.8.tar.gz) = 5484286
+SHA256 (armadillo-4.320.0.tar.gz) = 2f670c164b3d26331ad1b8da39db3e06ef0e3ad8de33176903de0623ca2b11c9
+SIZE (armadillo-4.320.0.tar.gz) = 5321312
diff --git a/math/armadillo/pkg-descr b/math/armadillo/pkg-descr
index 06d13276e851..bab3ef42863e 100644
--- a/math/armadillo/pkg-descr
+++ b/math/armadillo/pkg-descr
@@ -1,20 +1,20 @@
-Armadillo is a C++ linear algebra library (matrix maths) aiming towards a
-good balance between speed and ease of use. The syntax is deliberately
+Armadillo is a C++ linear algebra library (matrix maths) aiming towards
+a good balance between speed and ease of use. The syntax is deliberately
similar to Matlab.
-
-Integer, floating point and complex numbers are supported, as well as a
-subset of trigonometric and statistics functions. Various matrix
-decompositions are provided through optional integration with LAPACK, or
-one of its high performance drop-in replacements (such as the
+
+Integer, floating point and complex numbers are supported, as well as a
+subset of trigonometric and statistics functions. Various matrix
+decompositions are provided through optional integration with LAPACK, or
+one of its high performance drop-in replacements (such as the
multi-threaded MKL or ACML libraries).
-
-A delayed evaluation approach is employed (at compile-time) to combine
-several operations into one and reduce (or eliminate) the need for
-temporaries. This is accomplished through recursive templates and template
-meta-programming.
-
-Useful for conversion of research code into production environments, or if
-C++ has been decided as the language of choice, due to speed and/or
+
+A delayed evaluation approach is employed (at compile-time) to combine
+several operations into one and reduce (or eliminate) the need for
+temporaries. This is accomplished through recursive templates and
+template meta-programming.
+
+Useful for conversion of research code into production environments, or
+if C++ has been decided as the language of choice, due to speed and/or
integration capabilities.
-
+
WWW: http://arma.sourceforge.net/
diff --git a/math/armadillo/pkg-plist b/math/armadillo/pkg-plist
index e11a4671513b..86a5d1bd1071 100644
--- a/math/armadillo/pkg-plist
+++ b/math/armadillo/pkg-plist
@@ -394,7 +394,7 @@ include/armadillo_bits/xvec_htrans_bones.hpp
include/armadillo_bits/xvec_htrans_meat.hpp
lib/libarmadillo.so
lib/libarmadillo.so.4
-lib/libarmadillo.so.4.300.8
+lib/libarmadillo.so.4.320.0
share/Armadillo/CMake/ArmadilloConfig.cmake
share/Armadillo/CMake/ArmadilloConfigVersion.cmake
share/Armadillo/CMake/ArmadilloLibraryDepends-%%CMAKE_BUILD_TYPE%%.cmake