aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING14
-rw-r--r--emulators/qemu/Makefile51
-rw-r--r--emulators/qemu/distinfo6
-rw-r--r--emulators/qemu/files/patch-Makefile14
-rw-r--r--emulators/qemu/files/patch-configure46
-rw-r--r--emulators/qemu/files/patch-disas_libvixl_vixl_a64_disasm-a64.cc2
-rw-r--r--emulators/qemu/files/patch-include_net_net.h4
-rw-r--r--emulators/qemu/files/patch-include_qemu_atomic.h10
-rw-r--r--emulators/qemu/files/patch-net_tap-bsd.c2
-rw-r--r--emulators/qemu/files/patch-qemu-doc.texi6
-rw-r--r--emulators/qemu/files/pcap-patch-qapi_net.json (renamed from emulators/qemu/files/pcap-patch)0
-rw-r--r--emulators/qemu/pkg-plist112
12 files changed, 165 insertions, 102 deletions
diff --git a/UPDATING b/UPDATING
index 8a33879f3eac..a06b927b1bfe 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,20 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20191125:
+ AFFECTS: users of emulators/qemu
+ AUTHOR: bofh@FreeBSD.org
+
+ emulators/qemu31 has been updated to 4.1.1. Previous 3.1.X branch has
+ been repocopied to emulators/qemu31. If someone wants to stick with 3.1.X
+ branch please use one of the following command:
+
+ # pkg install emulators/qemu31
+ or
+ # portmaster -o emulators/qemu31 emulators/qemu
+ or
+ # portupgrade -o emulators/qemu31 emulators/qemu
+
20191124:
AFFECTS: users of irc/eggdrop
AUTHOR: dbaio@FreeBSD.org
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index e0189695e17c..079083feb6d7 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= qemu
-PORTVERSION= 3.1.1.1
+PORTVERSION= 4.1.1
CATEGORIES= emulators
MASTER_SITES= https://download.qemu.org/
DIST_SUBDIR= qemu/${PORTVERSION}
@@ -14,19 +14,22 @@ LICENSE= GPLv2
LIB_DEPENDS?= libnettle.so:security/nettle \
libfontconfig.so:x11-fonts/fontconfig \
- libfreetype.so:print/freetype2
+ libfreetype.so:print/freetype2 \
+ libepoxy.so:graphics/libepoxy \
+ libpcre2-8.so:devel/pcre2
.if !defined(PKGNAMESUFFIX) || (${PKGNAMESUFFIX} != "-utils" && ${PKGNAMESUFFIX} != "-guest-agent")
ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64
+USES+= xorg
USE_XORG= pixman
-USE_GNOME+= cairo glib20 libxml2
.endif
-USES?= compiler:c11 cpe gmake gnome pkgconfig bison perl5 \
- python:build tar:xz
+USES?= bison compiler:c11 cpe gmake gnome iconv:wchar_t perl5 \
+ pkgconfig python:build tar:xz
+USE_GNOME= cairo glib20 libxml2
USE_PERL5= build
-PORTSCOUT= limit:^3\.0\.
+PORTSCOUT= limit:^4\.1\.
HAS_CONFIGURE= yes
MAKE_ENV+= BSD_MAKE="${MAKE}" V=1
@@ -49,25 +52,24 @@ OPTIONS_DEFAULT=X11 GTK3 OPENGL GNUTLS SASL JPEG PNG CDROM_DMA CURL PCAP NCURSES
OPTIONS_SUB= yes
CURL_CONFIGURE_OFF= --disable-curl
CURL_LIB_DEPENDS= libcurl.so:ftp/curl
-DOCS_BUILD_DEPENDS= texi2html:textproc/texi2html
+DOCS_BUILD_DEPENDS= texi2html:textproc/texi2html \
+ sphinx-build:textproc/py-sphinx
DOCS_MAKE_ARGS_OFF= NOPORTDOCS=1
DOCS_USES= makeinfo
GNUTLS_CONFIGURE_OFF= --disable-gnutls
GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
GTK3_CONFIGURE_OFF= --disable-gtk --disable-vte
-GTK3_LIB_DEPENDS= libxkbcommon.so:x11/libxkbcommon \
- libepoxy.so:graphics/libepoxy \
- libpcre2-8.so:devel/pcre2
-GTK3_USE= GNOME=gtk30,vte3,gdkpixbuf2 XORG=x11,xext GL=gbm
-GTK3_USES= gettext gl gnome xorg
+GTK3_LIB_DEPENDS= libxkbcommon.so:x11/libxkbcommon
+GTK3_USE= GNOME=gdkpixbuf2,gtk30,vte3 XORG=x11,xext
+GTK3_USES= gettext gl
JPEG_CONFIGURE_OFF= --disable-vnc-jpeg
JPEG_USES= jpeg
NCURSES_USES= ncurses:base
OPENGL_CONFIGURE_OFF= --disable-opengl
-OPENGL_USE= GL=glu
-OPENGL_USES= gl
+OPENGL_USE= GL=gl
+OPENGL_USES= gl
PCAP_CONFIGURE_ON= --enable-pcap
-PCAP_EXTRA_PATCHES= ${FILESDIR}/pcap-patch ${FILESDIR}/pcap-patch-net_net.c \
+PCAP_EXTRA_PATCHES= ${FILESDIR}/pcap-patch-qapi_net.json ${FILESDIR}/pcap-patch-net_net.c \
${FILESDIR}/pcap-patch-net_clients.h
PNG_CONFIGURE_OFF= --disable-vnc-png
PNG_LIB_DEPENDS= libpng.so:graphics/png
@@ -76,7 +78,7 @@ SAMBA_USES= samba:run # smbd
SASL_CONFIGURE_OFF= --disable-vnc-sasl
SASL_LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
STATIC_LINK_CONFIGURE_ON= --static
-STATIC_LINK_PREVENTS= GTK2 X11
+STATIC_LINK_PREVENTS= GTK3 X11
STATIC_LINK_PREVENTS_MSG= X11 ui cannot be built static
USBREDIR_BUILD_DEPENDS= usbredir>=0.6:net/usbredir
USBREDIR_CONFIGURE_OFF= --disable-usb-redir
@@ -84,24 +86,25 @@ USBREDIR_RUN_DEPENDS= usbredir>=0.6:net/usbredir
VDE_CONFIGURE_OFF= --disable-vde
VDE_LIB_DEPENDS= libvdeplug.so:net/vde2
X11_CONFIGURE_ENABLE= sdl
-X11_USE= SDL=sdl2 XORG=x11,xext
-X11_USES= sdl xorg
+X11_USE= SDL=sdl2 XORG=x11,xext GNOME=gdkpixbuf2
+X11_USES= sdl
.if !defined(PKGNAMESUFFIX) || ${PKGNAMESUFFIX} != "-utils"
-X86_TARGETS_USE_OFF= GNOME=cairo,gdkpixbuf2
-X86_TARGETS_USES_OFF= gnome
+X86_TARGETS_USE_OFF= XORG=pixman,x11
+X86_TARGETS_USES_OFF= xorg
.endif
-PORTDOCS?= docs qemu-doc.html qemu-doc.txt qemu-ga-ref.html qemu-ga-ref.txt \
- qemu-qmp-ref.html qemu-qmp-ref.txt
+PORTDOCS?= docs interop/.buildinfo interop/* qemu-doc.html qemu-doc.txt qemu-ga-ref.html qemu-ga-ref.txt \
+ qemu-qmp-ref.html qemu-qmp-ref.txt specs/.buildinfo specs/*
WITHOUT_CPU_CFLAGS=yes #to avoid problems with register allocation
CFLAGS:= ${CFLAGS:C/-fno-tree-vrp//}
-CONFIGURE_ARGS?=--localstatedir=/var --extra-ldflags=-L\"/usr/lib\" \
- --extra-ldflags=-L\"${LOCALBASE}/lib\" --disable-libssh2 --enable-debug \
+CONFIGURE_ARGS?= --localstatedir=/var --extra-ldflags=-L\"/usr/lib\" \
+ --extra-ldflags=-L\"${LOCALBASE}/lib\" --disable-libssh --enable-debug \
--prefix=${PREFIX} --cc=${CC} --enable-netmap --enable-docs --disable-kvm \
--disable-linux-user --disable-linux-aio --disable-xen \
--enable-debug-info --python=${PYTHON_CMD} \
--extra-cflags=-I${WRKSRC}\ -I${LOCALBASE}/include\ -DPREFIX=\\\"\"${PREFIX}\\\"\"
+INSTALLS_ICONS= yes
.include <bsd.port.options.mk>
diff --git a/emulators/qemu/distinfo b/emulators/qemu/distinfo
index c7586973f5ce..f31eaf8f7221 100644
--- a/emulators/qemu/distinfo
+++ b/emulators/qemu/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1570126454
-SHA256 (qemu/3.1.1.1/qemu-3.1.1.1.tar.xz) = b148fc3c7382c5addd915db433383160ca7b840bc6ea90bb0d35c6b253526d56
-SIZE (qemu/3.1.1.1/qemu-3.1.1.1.tar.xz) = 36077056
+TIMESTAMP = 1574567528
+SHA256 (qemu/4.1.1/qemu-4.1.1.tar.xz) = ed6fdbbdd272611446ff8036991e9b9f04a2ab2e3ffa9e79f3bab0eb9a95a1d2
+SIZE (qemu/4.1.1/qemu-4.1.1.tar.xz) = 61932460
diff --git a/emulators/qemu/files/patch-Makefile b/emulators/qemu/files/patch-Makefile
index df517e09efcf..095b684f8e80 100644
--- a/emulators/qemu/files/patch-Makefile
+++ b/emulators/qemu/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2019-04-12 03:28:28 UTC
+--- Makefile.orig 2019-04-23 18:14:45 UTC
+++ Makefile
-@@ -353,9 +353,14 @@ LIBS+=-lz $(LIBS_TOOLS)
+@@ -311,9 +311,14 @@ LIBS+=-lz $(LIBS_TOOLS)
HELPERS-$(call land,$(CONFIG_SOFTMMU),$(CONFIG_LINUX)) = qemu-bridge-helper$(EXESUF)
ifdef BUILD_DOCS
@@ -13,12 +13,12 @@
DOCS+=docs/interop/qemu-ga-ref.html docs/interop/qemu-ga-ref.txt docs/interop/qemu-ga-ref.7
+endif
DOCS+=docs/qemu-block-drivers.7
+ DOCS+=docs/qemu-cpu-models.7
ifdef CONFIG_VIRTFS
- DOCS+=fsdev/virtfs-proxy-helper.1
-@@ -812,11 +817,13 @@ BLOBS=
- endif
+@@ -742,11 +747,13 @@ install-sphinxdocs: sphinxdocs
+ $(call install-manual,interop)
- install-doc: $(DOCS)
+ install-doc: $(DOCS) install-sphinxdocs
+ifndef NOPORTDOCS
$(INSTALL_DIR) "$(DESTDIR)$(qemu_docdir)"
$(INSTALL_DATA) qemu-doc.html "$(DESTDIR)$(qemu_docdir)"
@@ -29,7 +29,7 @@
ifdef CONFIG_POSIX
$(INSTALL_DIR) "$(DESTDIR)$(mandir)/man1"
$(INSTALL_DATA) qemu.1 "$(DESTDIR)$(mandir)/man1"
-@@ -830,8 +837,10 @@ ifneq ($(TOOLS),)
+@@ -764,8 +771,10 @@ ifdef CONFIG_TRACE_SYSTEMTAP
endif
ifneq (,$(findstring qemu-ga,$(TOOLS)))
$(INSTALL_DATA) qemu-ga.8 "$(DESTDIR)$(mandir)/man8"
diff --git a/emulators/qemu/files/patch-configure b/emulators/qemu/files/patch-configure
index ea30d217e7b2..c41037e2774c 100644
--- a/emulators/qemu/files/patch-configure
+++ b/emulators/qemu/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2018-12-11 17:44:34 UTC
+--- configure.orig 2019-04-23 18:14:45 UTC
+++ configure
-@@ -393,7 +393,7 @@ DSOSUF=".so"
+@@ -396,7 +396,7 @@ DSOSUF=".so"
LDFLAGS_SHARED="-shared"
modules="no"
prefix="/usr/local"
@@ -9,7 +9,7 @@
datadir="\${prefix}/share"
firmwarepath="\${prefix}/share/qemu-firmware"
qemu_docdir="\${prefix}/share/doc/qemu"
-@@ -469,6 +469,9 @@ numa=""
+@@ -476,6 +476,9 @@ numa=""
tcmalloc="no"
jemalloc="no"
replication="yes"
@@ -19,7 +19,7 @@
vxhs=""
bochs="yes"
cloop="yes"
-@@ -1097,6 +1100,10 @@ for opt do
+@@ -1118,6 +1121,10 @@ for opt do
;;
--enable-vnc-png) vnc_png="yes"
;;
@@ -29,8 +29,8 @@
+ ;;
--disable-slirp) slirp="no"
;;
- --disable-vde) vde="no"
-@@ -2860,6 +2867,14 @@ if ! check_include "ifaddrs.h" ; then
+ --enable-slirp=system) slirp="system"
+@@ -2972,6 +2979,14 @@ if ! check_include "ifaddrs.h" ; then
fi
##########################################
@@ -45,19 +45,37 @@
# VTE probe
if test "$vte" != "no"; then
-@@ -4466,11 +4481,6 @@ fi
+@@ -3629,7 +3644,7 @@ for i in $glib_modules; do
+ glib_libs=$($pkg_config --libs $i)
+ QEMU_CFLAGS="$glib_cflags $QEMU_CFLAGS"
+ LIBS="$glib_libs $LIBS"
+- libs_qga="$glib_libs $libs_qga"
++ libs_qga="$glib_libs -lintl $libs_qga"
+ else
+ error_exit "glib-$glib_req_ver $i is required to compile QEMU"
+ fi
+@@ -4723,11 +4738,6 @@ has_sphinx_build() {
if test "$docs" != "no" ; then
- if has makeinfo && has pod2man; then
+ if has makeinfo && has pod2man && has_sphinx_build; then
docs=yes
- else
- if test "$docs" = "yes" ; then
-- feature_not_found "docs" "Install texinfo and Perl/perl-podlators"
+- feature_not_found "docs" "Install texinfo, Perl/perl-podlators and python-sphinx"
- fi
- docs=no
fi
fi
-@@ -4984,7 +4994,51 @@ if test "$debug_stack_usage" = "yes"; then
+@@ -4861,7 +4871,7 @@ fi
+
+ # check for libusb
+ if test "$libusb" != "no" ; then
+- if $pkg_config --atleast-version=1.0.13 libusb-1.0; then
++ if $pkg_config libusb-1.0; then
+ libusb="yes"
+ libusb_cflags=$($pkg_config --cflags libusb-1.0)
+ libusb_libs=$($pkg_config --libs libusb-1.0)
+@@ -5251,7 +5261,51 @@ if test "$debug_stack_usage" = "yes"; then
fi
fi
@@ -109,7 +127,7 @@
##########################################
# check if we have open_by_handle_at
-@@ -6005,6 +6059,7 @@ echo "Audio drivers $audio_drv_list"
+@@ -6332,6 +6386,7 @@ echo "Audio drivers $audio_drv_list"
echo "Block whitelist (rw) $block_drv_rw_whitelist"
echo "Block whitelist (ro) $block_drv_ro_whitelist"
echo "VirtFS support $virtfs"
@@ -117,7 +135,7 @@
echo "Multipath support $mpath"
echo "VNC support $vnc"
if test "$vnc" = "yes" ; then
-@@ -6240,6 +6295,15 @@ fi
+@@ -6565,6 +6620,15 @@ fi
if test "$profiler" = "yes" ; then
echo "CONFIG_PROFILER=y" >> $config_host_mak
fi
@@ -130,10 +148,10 @@
+ echo "CONFIG_BPF=y" >> $config_host_mak
+ fi
+fi
- if test "$slirp" = "yes" ; then
+ if test "$slirp" != "no"; then
echo "CONFIG_SLIRP=y" >> $config_host_mak
echo "CONFIG_SMBD_COMMAND=\"$smbd\"" >> $config_host_mak
-@@ -6470,6 +6534,9 @@ fi
+@@ -6812,6 +6876,9 @@ fi
# if this macro is set.
if test "$have_fsxattr" = "yes" ; then
echo "HAVE_FSXATTR=y" >> $config_host_mak
diff --git a/emulators/qemu/files/patch-disas_libvixl_vixl_a64_disasm-a64.cc b/emulators/qemu/files/patch-disas_libvixl_vixl_a64_disasm-a64.cc
index debacff9c250..546595845c62 100644
--- a/emulators/qemu/files/patch-disas_libvixl_vixl_a64_disasm-a64.cc
+++ b/emulators/qemu/files/patch-disas_libvixl_vixl_a64_disasm-a64.cc
@@ -1,4 +1,4 @@
---- disas/libvixl/vixl/a64/disasm-a64.cc.orig 2019-04-12 03:28:28 UTC
+--- disas/libvixl/vixl/a64/disasm-a64.cc.orig 2019-04-23 18:14:45 UTC
+++ disas/libvixl/vixl/a64/disasm-a64.cc
@@ -2693,7 +2693,7 @@ void Disassembler::AppendPCRelativeOffsetToOutput(cons
if (offset < 0) {
diff --git a/emulators/qemu/files/patch-include_net_net.h b/emulators/qemu/files/patch-include_net_net.h
index a909f8693029..92d57989a03f 100644
--- a/emulators/qemu/files/patch-include_net_net.h
+++ b/emulators/qemu/files/patch-include_net_net.h
@@ -1,6 +1,6 @@
---- include/net/net.h.orig 2019-04-12 03:28:28 UTC
+--- include/net/net.h.orig 2019-04-23 18:14:46 UTC
+++ include/net/net.h
-@@ -210,8 +210,8 @@ void qmp_netdev_add(QDict *qdict, QObject **ret, Error
+@@ -209,8 +209,8 @@ void qmp_netdev_add(QDict *qdict, QObject **ret, Error
int net_hub_id_for_client(NetClientState *nc, int *id);
NetClientState *net_hub_port_find(int hub_id);
diff --git a/emulators/qemu/files/patch-include_qemu_atomic.h b/emulators/qemu/files/patch-include_qemu_atomic.h
index c57a273abfe5..623073e0b29a 100644
--- a/emulators/qemu/files/patch-include_qemu_atomic.h
+++ b/emulators/qemu/files/patch-include_qemu_atomic.h
@@ -1,6 +1,6 @@
---- include/qemu/atomic.h.orig 2019-04-12 03:28:28 UTC
+--- include/qemu/atomic.h.orig 2019-04-23 18:14:46 UTC
+++ include/qemu/atomic.h
-@@ -200,10 +200,12 @@
+@@ -201,10 +201,12 @@
/* Provide shorter names for GCC atomic builtins, return old value */
#define atomic_fetch_inc(ptr) __atomic_fetch_add(ptr, 1, __ATOMIC_SEQ_CST)
#define atomic_fetch_dec(ptr) __atomic_fetch_sub(ptr, 1, __ATOMIC_SEQ_CST)
@@ -13,7 +13,7 @@
#define atomic_fetch_xor(ptr, n) __atomic_fetch_xor(ptr, n, __ATOMIC_SEQ_CST)
#define atomic_inc_fetch(ptr) __atomic_add_fetch(ptr, 1, __ATOMIC_SEQ_CST)
-@@ -217,10 +219,12 @@
+@@ -218,10 +220,12 @@
/* And even shorter names that return void. */
#define atomic_inc(ptr) ((void) __atomic_fetch_add(ptr, 1, __ATOMIC_SEQ_CST))
#define atomic_dec(ptr) ((void) __atomic_fetch_sub(ptr, 1, __ATOMIC_SEQ_CST))
@@ -26,7 +26,7 @@
#define atomic_xor(ptr, n) ((void) __atomic_fetch_xor(ptr, n, __ATOMIC_SEQ_CST))
#else /* __ATOMIC_RELAXED */
-@@ -388,10 +392,12 @@
+@@ -389,10 +393,12 @@
#define atomic_inc_fetch(ptr) __sync_add_and_fetch(ptr, 1)
#define atomic_dec_fetch(ptr) __sync_add_and_fetch(ptr, -1)
@@ -39,7 +39,7 @@
#define atomic_xor_fetch(ptr, n) __sync_xor_and_fetch(ptr, n)
#define atomic_cmpxchg(ptr, old, new) __sync_val_compare_and_swap(ptr, old, new)
-@@ -400,10 +406,12 @@
+@@ -401,10 +407,12 @@
/* And even shorter names that return void. */
#define atomic_inc(ptr) ((void) __sync_fetch_and_add(ptr, 1))
#define atomic_dec(ptr) ((void) __sync_fetch_and_add(ptr, -1))
diff --git a/emulators/qemu/files/patch-net_tap-bsd.c b/emulators/qemu/files/patch-net_tap-bsd.c
index bc2d0ec5b43f..6d94c1bde1ca 100644
--- a/emulators/qemu/files/patch-net_tap-bsd.c
+++ b/emulators/qemu/files/patch-net_tap-bsd.c
@@ -1,4 +1,4 @@
---- net/tap-bsd.c.orig 2019-04-12 03:28:28 UTC
+--- net/tap-bsd.c.orig 2019-04-23 18:14:46 UTC
+++ net/tap-bsd.c
@@ -31,6 +31,7 @@
diff --git a/emulators/qemu/files/patch-qemu-doc.texi b/emulators/qemu/files/patch-qemu-doc.texi
index a99fae61e45f..aa79d423f792 100644
--- a/emulators/qemu/files/patch-qemu-doc.texi
+++ b/emulators/qemu/files/patch-qemu-doc.texi
@@ -1,6 +1,6 @@
---- qemu-doc.texi.orig 2019-04-12 03:28:29 UTC
+--- qemu-doc.texi.orig 2019-04-23 18:14:46 UTC
+++ qemu-doc.texi
-@@ -198,7 +198,7 @@ VGA BIOS.
+@@ -200,7 +200,7 @@ VGA BIOS.
QEMU uses YM3812 emulation by Tatsuyuki Satoh.
QEMU uses GUS emulation (GUSEMU32 @url{http://www.deinmeister.de/gusemu/})
@@ -9,7 +9,7 @@
Note that, by default, GUS shares IRQ(7) with parallel ports and so
QEMU must be told to not have parallel ports to have working GUS.
-@@ -558,7 +558,8 @@ Send the escape character to the frontend
+@@ -560,7 +560,8 @@ Send the escape character to the frontend
@c man begin SEEALSO
The HTML documentation of QEMU for more precise information and Linux
diff --git a/emulators/qemu/files/pcap-patch b/emulators/qemu/files/pcap-patch-qapi_net.json
index 39114c65d591..39114c65d591 100644
--- a/emulators/qemu/files/pcap-patch
+++ b/emulators/qemu/files/pcap-patch-qapi_net.json
diff --git a/emulators/qemu/pkg-plist b/emulators/qemu/pkg-plist
index 87b2236d079e..914c0fda4f58 100644
--- a/emulators/qemu/pkg-plist
+++ b/emulators/qemu/pkg-plist
@@ -1,3 +1,4 @@
+bin/elf2dmp
bin/qemu-edid
bin/qemu-ga
bin/qemu-i386
@@ -51,9 +52,19 @@ man/man8/qemu-nbd.8.gz
@sample etc/qemu-ifdown.sample
%%DATADIR%%/QEMU,tcx.bin
%%DATADIR%%/QEMU,cgthree.bin
+%%DATADIR%%/bamboo.dtb
%%DATADIR%%/bios-256k.bin
%%DATADIR%%/bios.bin
%%DATADIR%%/canyonlands.dtb
+%%DATADIR%%/edk2-aarch64-code.fd
+%%DATADIR%%/edk2-arm-code.fd
+%%DATADIR%%/edk2-arm-vars.fd
+%%DATADIR%%/edk2-i386-code.fd
+%%DATADIR%%/edk2-i386-secure-code.fd
+%%DATADIR%%/edk2-i386-vars.fd
+%%DATADIR%%/edk2-licenses.txt
+%%DATADIR%%/edk2-x86_64-code.fd
+%%DATADIR%%/edk2-x86_64-secure-code.fd
%%DATADIR%%/efi-e1000.rom
%%DATADIR%%/efi-e1000e.rom
%%DATADIR%%/efi-eepro100.rom
@@ -62,48 +73,15 @@ man/man8/qemu-nbd.8.gz
%%DATADIR%%/efi-rtl8139.rom
%%DATADIR%%/efi-virtio.rom
%%DATADIR%%/efi-vmxnet3.rom
+%%DATADIR%%/firmware/50-edk2-i386-secure.json
+%%DATADIR%%/firmware/50-edk2-x86_64-secure.json
+%%DATADIR%%/firmware/60-edk2-aarch64.json
+%%DATADIR%%/firmware/60-edk2-arm.json
+%%DATADIR%%/firmware/60-edk2-i386.json
+%%DATADIR%%/firmware/60-edk2-x86_64.json
%%DATADIR%%/hppa-firmware.img
-%%DATADIR%%/openbios-ppc
-%%DATADIR%%/openbios-sparc32
-%%DATADIR%%/openbios-sparc64
-%%DATADIR%%/palcode-clipper
-%%DATADIR%%/petalogix-ml605.dtb
-%%DATADIR%%/ppc_rom.bin
-%%DATADIR%%/pxe-e1000.rom
-%%DATADIR%%/pxe-eepro100.rom
-%%DATADIR%%/pxe-ne2k_pci.rom
-%%DATADIR%%/pxe-rtl8139.rom
-%%DATADIR%%/pxe-pcnet.rom
-%%DATADIR%%/pxe-virtio.rom
-%%DATADIR%%/qemu_vga.ndrv
-%%DATADIR%%/s390-netboot.img
-%%DATADIR%%/u-boot-sam460-20100605.bin
-%%DATADIR%%/vgabios.bin
-%%DATADIR%%/vgabios-bochs-display.bin
-%%DATADIR%%/vgabios-cirrus.bin
-%%DATADIR%%/vgabios-qxl.bin
-%%DATADIR%%/vgabios-ramfb.bin
-%%DATADIR%%/vgabios-stdvga.bin
-%%DATADIR%%/vgabios-virtio.bin
-%%DATADIR%%/vgabios-vmware.bin
-%%DATADIR%%/spapr-rtas.bin
-%%DATADIR%%/slof.bin
-%%DATADIR%%/s390-ccw.img
-%%DATADIR%%/linuxboot.bin
-%%LINUXBOOT_DMA%%%%DATADIR%%/linuxboot_dma.bin
-%%DATADIR%%/multiboot.bin
-%%DATADIR%%/sgabios.bin
-%%DATADIR%%/skiboot.lid
-%%DATADIR%%/trace-events-all
-%%DATADIR%%/petalogix-s3adsp1800.dtb
-%%DATADIR%%/bamboo.dtb
-%%DATADIR%%/kvmvapic.bin
-%%DATADIR%%/qemu-icon.bmp
-%%DATADIR%%/qemu_logo_no_text.svg
-%%DATADIR%%/u-boot.e500
%%DATADIR%%/keymaps/ar
%%DATADIR%%/keymaps/bepo
-%%DATADIR%%/keymaps/common
%%DATADIR%%/keymaps/cz
%%DATADIR%%/keymaps/da
%%DATADIR%%/keymaps/de
@@ -126,9 +104,7 @@ man/man8/qemu-nbd.8.gz
%%DATADIR%%/keymaps/lt
%%DATADIR%%/keymaps/lv
%%DATADIR%%/keymaps/mk
-%%DATADIR%%/keymaps/modifiers
%%DATADIR%%/keymaps/nl
-%%DATADIR%%/keymaps/nl-be
%%DATADIR%%/keymaps/no
%%DATADIR%%/keymaps/pl
%%DATADIR%%/keymaps/pt
@@ -138,10 +114,62 @@ man/man8/qemu-nbd.8.gz
%%DATADIR%%/keymaps/sv
%%DATADIR%%/keymaps/th
%%DATADIR%%/keymaps/tr
+%%DATADIR%%/kvmvapic.bin
+%%DATADIR%%/linuxboot.bin
+%%LINUXBOOT_DMA%%%%DATADIR%%/linuxboot_dma.bin
+%%DATADIR%%/multiboot.bin
+%%DATADIR%%/openbios-ppc
+%%DATADIR%%/openbios-sparc32
+%%DATADIR%%/openbios-sparc64
+%%DATADIR%%/opensbi-riscv32-virt-fw_jump.bin
+%%DATADIR%%/opensbi-riscv64-sifive_u-fw_jump.bin
+%%DATADIR%%/opensbi-riscv64-virt-fw_jump.bin
+%%DATADIR%%/palcode-clipper
+%%DATADIR%%/petalogix-ml605.dtb
+%%DATADIR%%/petalogix-s3adsp1800.dtb
+%%DATADIR%%/ppc_rom.bin
+%%DATADIR%%/pvh.bin
+%%DATADIR%%/pxe-e1000.rom
+%%DATADIR%%/pxe-eepro100.rom
+%%DATADIR%%/pxe-ne2k_pci.rom
+%%DATADIR%%/pxe-rtl8139.rom
+%%DATADIR%%/pxe-pcnet.rom
+%%DATADIR%%/pxe-virtio.rom
+%%DATADIR%%/qemu-nsis.bmp
+%%DATADIR%%/qemu_vga.ndrv
+%%DATADIR%%/s390-ccw.img
+%%DATADIR%%/s390-netboot.img
+%%DATADIR%%/sgabios.bin
+%%DATADIR%%/skiboot.lid
+%%DATADIR%%/slof.bin
+%%DATADIR%%/spapr-rtas.bin
+%%DATADIR%%/trace-events-all
+%%DATADIR%%/u-boot-sam460-20100605.bin
+%%DATADIR%%/u-boot.e500
+%%DATADIR%%/vgabios.bin
+%%DATADIR%%/vgabios-bochs-display.bin
+%%DATADIR%%/vgabios-ati.bin
+%%DATADIR%%/vgabios-cirrus.bin
+%%DATADIR%%/vgabios-qxl.bin
+%%DATADIR%%/vgabios-ramfb.bin
+%%DATADIR%%/vgabios-stdvga.bin
+%%DATADIR%%/vgabios-virtio.bin
+%%DATADIR%%/vgabios-vmware.bin
+share/icons/hicolor/128x128/apps/qemu.png
+share/icons/hicolor/16x16/apps/qemu.png
+share/icons/hicolor/24x24/apps/qemu.png
+share/icons/hicolor/256x256/apps/qemu.png
+share/icons/hicolor/32x32/apps/qemu.bmp
+share/icons/hicolor/32x32/apps/qemu.png
+share/icons/hicolor/48x48/apps/qemu.png
+share/icons/hicolor/512x512/apps/qemu.png
+share/icons/hicolor/64x64/apps/qemu.png
+share/icons/hicolor/scalable/apps/qemu.svg
+share/applications/qemu.desktop
%%GTK3%%share/locale/bg/LC_MESSAGES/qemu.mo
%%GTK3%%share/locale/de_DE/LC_MESSAGES/qemu.mo
%%GTK3%%share/locale/fr_FR/LC_MESSAGES/qemu.mo
-%%GTK3%%share/locale/it/LC_MESSAGES/qemu.mo
%%GTK3%%share/locale/hu/LC_MESSAGES/qemu.mo
+%%GTK3%%share/locale/it/LC_MESSAGES/qemu.mo
%%GTK3%%share/locale/tr/LC_MESSAGES/qemu.mo
%%GTK3%%share/locale/zh_CN/LC_MESSAGES/qemu.mo