aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--print/lilypond/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/print/lilypond/Makefile b/print/lilypond/Makefile
index 65180651f07d..0fdd830e9e99 100644
--- a/print/lilypond/Makefile
+++ b/print/lilypond/Makefile
@@ -25,7 +25,6 @@ BUILD_DEPENDS= bash:shells/bash \
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libgmp.so:math/gmp \
- libguile.so:lang/guile1 \
libltdl.so:devel/libltdl
RUN_DEPENDS= ${LOCALBASE}/share/fonts/dejavu/DejaVuSans-Bold.ttf:x11-fonts/dejavu \
mftrace:print/mftrace
@@ -61,11 +60,16 @@ INFO= lilypond-changes \
music-glossary
PLIST_SUB= DISTVERSION=${DISTVERSION}
-OPTIONS_DEFINE= URW NLS
+OPTIONS_DEFINE= GUILE2 NLS URW
OPTIONS_SUB= yes
+GUILE2_DESC= Use guile2 (will incur some performance penalty)
URW_DESC= Use bundled URW fonts
+GUILE2_LIB_DEPENDS= libgc-threaded.so:devel/boehm-gc-threaded \
+ libguile-2.2.so:lang/guile2
+GUILE2_LIB_DEPENDS_OFF= libguile.so:lang/guile1
+
NLS_USES= gettext
URW_BUILD_DEPENDS= urw-core35-fonts>0:x11-fonts/urw-core35-fonts